aboutsummaryrefslogtreecommitdiff
path: root/mail/mahogany
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-01-02 17:59:24 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-01-02 17:59:24 +0000
commite946eea8edb5d70410fb9036ba90fae595389dd5 (patch)
tree0f98d9ecb8004367d14985836988e95ab2dca630 /mail/mahogany
parent587c8c414ded2d4850ba407a4040531a1ebcb816 (diff)
downloadports-e946eea8edb5d70410fb9036ba90fae595389dd5.tar.gz
ports-e946eea8edb5d70410fb9036ba90fae595389dd5.zip
Notes
Diffstat (limited to 'mail/mahogany')
-rw-r--r--mail/mahogany/Makefile53
-rw-r--r--mail/mahogany/distinfo6
-rw-r--r--mail/mahogany/files/patch-Makefile12
-rw-r--r--mail/mahogany/files/patch-c-client-Makefile11
-rw-r--r--mail/mahogany/files/patch-makeopts.in17
-rw-r--r--mail/mahogany/files/patch-src-Makefile19
-rw-r--r--mail/mahogany/files/patch-src-classes-MModule.cpp14
-rw-r--r--mail/mahogany/files/patch-src-classes-MessageView.cpp11
-rw-r--r--mail/mahogany/files/patch-src-gui-wxMApp.cpp11
-rw-r--r--mail/mahogany/files/patch-src-gui-wxMDialogs.cpp25
-rw-r--r--mail/mahogany/pkg-plist387
11 files changed, 244 insertions, 322 deletions
diff --git a/mail/mahogany/Makefile b/mail/mahogany/Makefile
index 588310b744a9..bf8e16c2030f 100644
--- a/mail/mahogany/Makefile
+++ b/mail/mahogany/Makefile
@@ -5,37 +5,44 @@
# $FreeBSD$
#
-PORTNAME= mahogany
-PORTVERSION= 0.65
-PORTREVISION= 6
-CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= mahogany
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An X11 mail and news client
-
-USE_X_PREFIX= yes
-USE_WX= 2.4
+PORTNAME= mahogany
+PORTVERSION= 0.67
+CATEGORIES= mail
+MASTER_SITES= SF
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An X11 mail and news client
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_WX= 2.6+
WX_CONF_ARGS= absolute
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-ALL_TARGET= all locales
-INSTALL_TARGET= install_bin install_locale
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-dspam --with-python=none
+ALL_TARGET= all locales
+INSTALL_TARGET= install_bin install_locale
-MAN1= M.1 mahogany.1
+OPTIONS= NLS "Enable Native Language Support" on
-CONFIGURE_ARGS= --with-python=none
-CONFIGURE_ENV= OSTYPE=${OPSYS} CFLAGS="${CFLAGS}"
+MAN1= M.1 mahogany.1
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-DOPENSSL_NO_KRB5||' -e 's|-O2|${CFLAGS}|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|$$(DATADIR)/locale|$$(DESTDIR)/share/locale|' ${WRKSRC}/locale/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|-DOPENSSL_NO_KRB5||; \
+ s|-O2|${CFLAGS}|; \
+ s|-Wno-pointer-sign||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|$$(DATADIR)/locale|$$(DESTDIR)/share/locale|' \
+ ${WRKSRC}/locale/Makefile
.include <bsd.port.post.mk>
diff --git a/mail/mahogany/distinfo b/mail/mahogany/distinfo
index 84936ce73fd5..50f3dcc36b4b 100644
--- a/mail/mahogany/distinfo
+++ b/mail/mahogany/distinfo
@@ -1,3 +1,3 @@
-MD5 (mahogany-0.65.tar.gz) = acaa375cb3659c6a434649bf823e85cc
-SHA256 (mahogany-0.65.tar.gz) = 786e46f47ebc00df64fc0777ee732bc70a313d0ec71fa76aa2390b0fb2baa9c7
-SIZE (mahogany-0.65.tar.gz) = 3982956
+MD5 (mahogany-0.67.tar.bz2) = 0e6901fb4baf08114c2f2cb18f34d2ea
+SHA256 (mahogany-0.67.tar.bz2) = c9d1ab0bc3d1441facb879f01aa3151beaac85819d00bbac075b7c0150cc1b78
+SIZE (mahogany-0.67.tar.bz2) = 5315580
diff --git a/mail/mahogany/files/patch-Makefile b/mail/mahogany/files/patch-Makefile
deleted file mode 100644
index 53188f5aa1d0..000000000000
--- a/mail/mahogany/files/patch-Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- Makefile.orig Mon Jul 28 23:10:47 2003
-+++ Makefile Sat Oct 4 23:28:15 2003
-@@ -76,9 +76,6 @@
- set -e; for i in \
- $(BINDIR) \
- $(DATADIR) \
-- $(DATADIR)/$(CANONICAL_HOST) \
-- $(DATADIR)/$(CANONICAL_HOST)/bin \
-- $(DATADIR)/$(CANONICAL_HOST)/lib \
- $(DOCDIR) \
- $(DOCDIR)/Tips \
- ;do \
diff --git a/mail/mahogany/files/patch-c-client-Makefile b/mail/mahogany/files/patch-c-client-Makefile
deleted file mode 100644
index 8efd7196bb62..000000000000
--- a/mail/mahogany/files/patch-c-client-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- extra/src/c-client/Makefile.old Tue Jun 1 19:59:40 2004
-+++ extra/src/c-client/Makefile Tue Jun 1 20:00:37 2004
-@@ -866,7 +866,7 @@
- echo $(CC) > CCTYPE
- echo $(CFLAGS) > CFLAGS
- echo -DCREATEPROTO=$(CREATEPROTO) -DEMPTYPROTO=$(EMPTYPROTO) \
-- -DMAILSPOOL=\"$(MAILSPOOL)\" \
-+ -DMD5ENABLE=\"/etc/cram-md5.pwd\" -DMAILSPOOL=\"$(MAILSPOOL)\" \
- -DANONYMOUSHOME=\"$(MAILSPOOL)/anonymous\" \
- -DACTIVEFILE=\"$(ACTIVEFILE)\" -DNEWSSPOOL=\"$(NEWSSPOOL)\" \
- -DRSHPATH=\"$(RSHPATH)\" -DLOCKPGM=\"$(LOCKPGM)\" > OSCFLAGS
diff --git a/mail/mahogany/files/patch-makeopts.in b/mail/mahogany/files/patch-makeopts.in
deleted file mode 100644
index 2e2cbc2b4bf3..000000000000
--- a/mail/mahogany/files/patch-makeopts.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- makeopts.in.orig Sat Oct 4 23:36:51 2003
-+++ makeopts.in Sat Oct 4 23:38:06 2003
-@@ -108,11 +108,11 @@
- # Directory in which to install library files.
- DATADIR = $(DESTDIR)/share/Mahogany
- # where to install docs
--DOCDIR = $(DATADIR)/doc
-+DOCDIR = $(DESTDIR)/share/doc/Mahogany
-
- # for the dynamic linker, better than using -rpath
--LD_RUN_PATH=$(DATADIR)/$(CANONICAL_HOST)/lib
--MODULEDIR=$(DATADIR)/$(CANONICAL_HOST)/modules
-+LD_RUN_PATH=$(DESTDIR)/lib
-+MODULEDIR=$(DESTDIR)/libexec/Mahogany/modules
-
- LINK = $(CXX)
-
diff --git a/mail/mahogany/files/patch-src-Makefile b/mail/mahogany/files/patch-src-Makefile
deleted file mode 100644
index bc38fead4689..000000000000
--- a/mail/mahogany/files/patch-src-Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/Makefile.orig Sat Oct 4 23:45:28 2003
-+++ src/Makefile Sat Oct 4 23:47:49 2003
-@@ -139,14 +139,8 @@
- $(RM) $(MOBJS:.o=.d) $(MSOS:.so=.d)
-
- install:
-- $(INSTALL_PROGRAM) $(INSTALL_OPTIONS) M $(DATADIR)/$(CANONICAL_HOST)/bin
-- if test -f libM.so; \
-- then $(INSTALL_PROGRAM) libM.so $(DATADIR)/$(CANONICAL_HOST)/lib; \
-- fi
-- $(RM) -f $(BINDIR)/M $(DATADIR)/bin/M
-- ln -f -s ../share/Mahogany/$(CANONICAL_HOST)/bin/M $(BINDIR)/M
-- $(RM) $(BINDIR)/mahogany
-- ln -f -s ../share/Mahogany/$(CANONICAL_HOST)/bin/M $(BINDIR)/mahogany
-+ ${INSTALL_PROGRAM} ${INSTALL_OPTIONS} M ${BINDIR}
-+ ln -f -s ${BINDIR}/M ${BINDIR}/mahogany
- ifeq ($(USE_MODULES),dynamic)
- $(INSTALL) -d $(MODULEDIR)
- set -e $(MSOS); while test $$# -ge 1; \
diff --git a/mail/mahogany/files/patch-src-classes-MModule.cpp b/mail/mahogany/files/patch-src-classes-MModule.cpp
deleted file mode 100644
index d55fc6c7b7a4..000000000000
--- a/mail/mahogany/files/patch-src-classes-MModule.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/classes/MModule.cpp.orig Tue Jul 22 14:07:38 2003
-+++ src/classes/MModule.cpp Sun Oct 5 03:02:24 2003
-@@ -870,10 +870,7 @@
- // platforms (doesn't make much sense under Windows)
-
- wxString path1;
-- path1 << mApplication->GetGlobalDir()
--#ifdef OS_UNIX
-- << DIR_SEPARATOR << M_CANONICAL_HOST
--#endif // Unix
-+ path1 << M_PREFIX << DIR_SEPARATOR << "libexec" << DIR_SEPARATOR << "Mahogany"
- << DIR_SEPARATOR << _T("modules") << DIR_SEPARATOR;
-
- dirs.Add(path1);
diff --git a/mail/mahogany/files/patch-src-classes-MessageView.cpp b/mail/mahogany/files/patch-src-classes-MessageView.cpp
new file mode 100644
index 000000000000..c18cfb7e2d09
--- /dev/null
+++ b/mail/mahogany/files/patch-src-classes-MessageView.cpp
@@ -0,0 +1,11 @@
+--- src/classes/MessageView.cpp.orig Mon Jan 1 18:26:12 2007
++++ src/classes/MessageView.cpp Mon Jan 1 18:51:17 2007
+@@ -2473,7 +2473,7 @@
+ CHECK( !cidOrig.empty(), false, "empty CID not allowed" );
+
+ String cid;
+- if ( *cidOrig.begin() == '<' && *cidOrig.rbegin() == '>' )
++ if ( *cidOrig.begin() == '<' && cidOrig.Last() == '>' )
+ cid.assign(cidOrig, 1, cidOrig.length() - 2);
+ else
+ cid = cidOrig;
diff --git a/mail/mahogany/files/patch-src-gui-wxMApp.cpp b/mail/mahogany/files/patch-src-gui-wxMApp.cpp
deleted file mode 100644
index 369a961917f0..000000000000
--- a/mail/mahogany/files/patch-src-gui-wxMApp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gui/wxMApp.cpp.orig Tue Aug 5 01:04:21 2003
-+++ src/gui/wxMApp.cpp Sun Oct 5 03:06:51 2003
-@@ -911,7 +911,7 @@
- // now load the message catalogs
- #ifdef OS_UNIX
- String localePath;
-- localePath << M_BASEDIR << "/locale";
-+ localePath << M_PREFIX << "/share/locale";
- #elif defined(OS_WIN)
- // the program directory is not initialized yet so we can't do much
- // more than looking in the current directory...
diff --git a/mail/mahogany/files/patch-src-gui-wxMDialogs.cpp b/mail/mahogany/files/patch-src-gui-wxMDialogs.cpp
deleted file mode 100644
index 132b94dbbfdb..000000000000
--- a/mail/mahogany/files/patch-src-gui-wxMDialogs.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/gui/wxMDialogs.cpp.orig Wed Jul 23 00:01:41 2003
-+++ src/gui/wxMDialogs.cpp Sun Oct 5 03:10:29 2003
-@@ -1286,19 +1286,9 @@
- {
- String dir, filename;
-
-- // Tips files are in @prefix@/share/Mahogany/doc/Tips/
-- dir = mApplication->GetGlobalDir();
-- if ( !dir )
-- {
-- // like this, it will work in an uninstalled copy of M too
-- dir = _T("..");
-- }
--
-- dir << DIR_SEPARATOR << _T("doc") << DIR_SEPARATOR
--#ifndef OS_WIN
-- << _T("Tips") << DIR_SEPARATOR
--#endif // !Windows
-- ;
-+ // Tips files are in @prefix@/share/doc/Mahogany/Tips/
-+ dir << M_PREFIX << DIR_SEPARATOR << "share" << DIR_SEPARATOR << "doc";
-+ dir << DIR_SEPARATOR << "Mahogany" << DIR_SEPARATOR << "Tips" << DIR_SEPARATOR;
-
- // Tips files are either Tips_LOCALENAME.txt, e.g. Tips_de.txt or
- // simply Tips.txt
diff --git a/mail/mahogany/pkg-plist b/mail/mahogany/pkg-plist
index 040abfbdddec..8f843caf6359 100644
--- a/mail/mahogany/pkg-plist
+++ b/mail/mahogany/pkg-plist
@@ -1,189 +1,202 @@
bin/M
bin/mahogany
-libexec/Mahogany/modules/ExportPalm.so
-libexec/Mahogany/modules/ExportText.so
-libexec/Mahogany/modules/ExportVCard.so
-libexec/Mahogany/modules/Filters.so
-libexec/Mahogany/modules/HtmlViewer.so
-libexec/Mahogany/modules/ImportMailrc.so
-libexec/Mahogany/modules/ImportPine.so
-libexec/Mahogany/modules/ImportText.so
-libexec/Mahogany/modules/ImportVCard.so
-libexec/Mahogany/modules/ImportXFMail.so
-libexec/Mahogany/modules/LayoutEditor.so
-libexec/Mahogany/modules/LayoutViewer.so
-libexec/Mahogany/modules/Mdummy.so
-libexec/Mahogany/modules/Migrate.so
-libexec/Mahogany/modules/NetscapeImporter.so
-libexec/Mahogany/modules/PGP.so
-libexec/Mahogany/modules/PGPEngine.so
-libexec/Mahogany/modules/PineImport.so
-libexec/Mahogany/modules/QuoteURL.so
-libexec/Mahogany/modules/Rot13.so
-libexec/Mahogany/modules/Signature.so
-libexec/Mahogany/modules/TextMarkup.so
-libexec/Mahogany/modules/TextViewer.so
-libexec/Mahogany/modules/Trailer.so
-libexec/Mahogany/modules/XFMailImport.so
-share/Mahogany/afm/Cour.afm
-share/Mahogany/afm/CourBo.afm
-share/Mahogany/afm/CourBoO.afm
-share/Mahogany/afm/CourO.afm
-share/Mahogany/afm/Helv.afm
-share/Mahogany/afm/HelvBo.afm
-share/Mahogany/afm/HelvBoO.afm
-share/Mahogany/afm/HelvO.afm
-share/Mahogany/afm/TimesBo.afm
-share/Mahogany/afm/TimesBoO.afm
-share/Mahogany/afm/TimesO.afm
-share/Mahogany/afm/TimesRo.afm
-share/Mahogany/icons/MFrame.xpm
-share/Mahogany/icons/MFrameNewMail.xpm
-share/Mahogany/icons/MLogFrame.xpm
-share/Mahogany/icons/M_16x16.xpm
-share/Mahogany/icons/M_32x32.xpm
-share/Mahogany/icons/MainFrame.xpm
-share/Mahogany/icons/MainFrameNewMail.xpm
-share/Mahogany/icons/Micon.xpm
-share/Mahogany/icons/Msplash.xpm
-share/Mahogany/icons/PythonPowered.xpm
-share/Mahogany/icons/access.xpm
-share/Mahogany/icons/adb_address.xpm
-share/Mahogany/icons/adb_bbdb.xpm
-share/Mahogany/icons/adb_book.xpm
-share/Mahogany/icons/adb_closed.xpm
-share/Mahogany/icons/adb_library.xpm
-share/Mahogany/icons/adb_opened.xpm
-share/Mahogany/icons/adb_palmos.xpm
-share/Mahogany/icons/adbedit.xpm
-share/Mahogany/icons/adbimport.xpm
-share/Mahogany/icons/adrbook.xpm
-share/Mahogany/icons/application.xpm
-share/Mahogany/icons/audio.xpm
-share/Mahogany/icons/autocollect.xpm
-share/Mahogany/icons/background.xpm
-share/Mahogany/icons/bbdb.xpm
-share/Mahogany/icons/binary.xpm
-share/Mahogany/icons/calendar.xpm
-share/Mahogany/icons/compose.xpm
-share/Mahogany/icons/dnd_msg.xpm
-share/Mahogany/icons/dnd_msgs.xpm
-share/Mahogany/icons/dvi.xpm
-share/Mahogany/icons/email.xpm
-share/Mahogany/icons/folder_file.xpm
-share/Mahogany/icons/folder_group.xpm
-share/Mahogany/icons/folder_imap.xpm
-share/Mahogany/icons/folder_inbox.xpm
-share/Mahogany/icons/folder_newmail.xpm
-share/Mahogany/icons/folder_news.xpm
-share/Mahogany/icons/folder_nntp.xpm
-share/Mahogany/icons/folder_outbox.xpm
-share/Mahogany/icons/folder_palmpilot.xpm
-share/Mahogany/icons/folder_pop.xpm
-share/Mahogany/icons/folder_root.xpm
-share/Mahogany/icons/folder_sentmail.xpm
-share/Mahogany/icons/folder_trash.xpm
-share/Mahogany/icons/folders.xpm
-share/Mahogany/icons/folderview.xpm
-share/Mahogany/icons/foldertree.xpm
-share/Mahogany/icons/ftplink.xpm
-share/Mahogany/icons/general.xpm
-share/Mahogany/icons/help.xpm
-share/Mahogany/icons/helpers.xpm
-share/Mahogany/icons/hlink.xpm
-share/Mahogany/icons/home.xpm
-share/Mahogany/icons/ident.xpm
-share/Mahogany/icons/image.xpm
-share/Mahogany/icons/image_both.xpm
-share/Mahogany/icons/image_mail.xpm
-share/Mahogany/icons/image_news.xpm
-share/Mahogany/icons/import.xpm
-share/Mahogany/icons/install_welcome.xpm
-share/Mahogany/icons/mahogany.xpm
-share/Mahogany/icons/message.xpm
-share/Mahogany/icons/miscopt.xpm
-share/Mahogany/icons/msg_del.xpm
-share/Mahogany/icons/msg_error.xpm
-share/Mahogany/icons/msg_info.xpm
-share/Mahogany/icons/msg_new.xpm
-share/Mahogany/icons/msg_normal.xpm
-share/Mahogany/icons/msg_question.xpm
-share/Mahogany/icons/msg_recent.xpm
-share/Mahogany/icons/msg_warning.xpm
-share/Mahogany/icons/msg_unread.xpm
-share/Mahogany/icons/msg_unread_bw.xpm
-share/Mahogany/icons/msgview.xpm
-share/Mahogany/icons/multipart.xpm
-share/Mahogany/icons/network.xpm
-share/Mahogany/icons/new.xpm
-share/Mahogany/icons/newmail.xpm
-share/Mahogany/icons/nomail_s.xpm
-share/Mahogany/icons/noxface.xpm
-share/Mahogany/icons/offline.xpm
-share/Mahogany/icons/online.xpm
-share/Mahogany/icons/palmpilot.xpm
-share/Mahogany/icons/postscript.xpm
-share/Mahogany/icons/python.xpm
-share/Mahogany/icons/pythonpower.xpm
-share/Mahogany/icons/sortdown.xpm
-share/Mahogany/icons/sortup.xpm
-share/Mahogany/icons/spam.xpm
-share/Mahogany/icons/ssllogo.xpm
-share/Mahogany/icons/sync.xpm
-share/Mahogany/icons/tb_adrbook.xpm
-share/Mahogany/icons/tb_attach.xpm
-share/Mahogany/icons/tb_book_open.xpm
-share/Mahogany/icons/tb_check_mail.xpm
-share/Mahogany/icons/tb_close.xpm
-share/Mahogany/icons/tb_delete.xpm
-share/Mahogany/icons/tb_document.xpm
-share/Mahogany/icons/tb_editor.xpm
-share/Mahogany/icons/tb_exit.xpm
-share/Mahogany/icons/tb_help.xpm
-share/Mahogany/icons/tb_lookup.xpm
-share/Mahogany/icons/tb_mail.xpm
-share/Mahogany/icons/tb_mail_compose.xpm
-share/Mahogany/icons/tb_mail_forward.xpm
-share/Mahogany/icons/tb_mail_reply.xpm
-share/Mahogany/icons/tb_mail_send.xpm
-share/Mahogany/icons/tb_modules.xpm
-share/Mahogany/icons/tb_new.xpm
-share/Mahogany/icons/tb_next_unread.xpm
-share/Mahogany/icons/tb_open.xpm
-share/Mahogany/icons/tb_openany.xpm
-share/Mahogany/icons/tb_palmos.xpm
-share/Mahogany/icons/tb_paste.xpm
-share/Mahogany/icons/tb_preferences.xpm
-share/Mahogany/icons/tb_print.xpm
-share/Mahogany/icons/tb_refresh.xpm
-share/Mahogany/icons/tb_trash.xpm
-share/Mahogany/icons/tb_undo.xpm
-share/Mahogany/icons/text.xpm
-share/Mahogany/icons/tgz.xpm
-share/Mahogany/icons/undo.xpm
-share/Mahogany/icons/unknown.xpm
-share/Mahogany/icons/vcard.xpm
-share/Mahogany/icons/video.xpm
-share/Mahogany/icons/work.xpm
-share/Mahogany/icons/wxlogo.xpm
-share/Mahogany/icons/xface.xpm
-share/Mahogany/kylemail.wav
-share/Mahogany/M.conf
-share/Mahogany/newmail.wav
-share/doc/Mahogany/Tips/Tips.txt
-share/locale/de/LC_MESSAGES/M.mo
-share/locale/es/LC_MESSAGES/M.mo
-share/locale/fi/LC_MESSAGES/M.mo
-share/locale/fr/LC_MESSAGES/M.mo
-share/locale/it/LC_MESSAGES/M.mo
-share/locale/nl/LC_MESSAGES/M.mo
-share/locale/pt/LC_MESSAGES/M.mo
-share/locale/pt_BR/LC_MESSAGES/M.mo
-@dirrm libexec/Mahogany/modules
-@dirrm libexec/Mahogany
-@dirrm share/doc/Mahogany/Tips
-@dirrm share/doc/Mahogany
-@dirrm share/Mahogany/afm
-@dirrm share/Mahogany/icons
-@dirrm share/Mahogany/scripts
-@dirrm share/Mahogany
+lib/mahogany/modules/BareBonesEditor.so
+lib/mahogany/modules/ExportPalm.so
+lib/mahogany/modules/ExportText.so
+lib/mahogany/modules/ExportVCard.so
+lib/mahogany/modules/Filters.so
+lib/mahogany/modules/HeadersFilter.so
+lib/mahogany/modules/HtmlViewer.so
+lib/mahogany/modules/ImportMailrc.so
+lib/mahogany/modules/ImportPine.so
+lib/mahogany/modules/ImportText.so
+lib/mahogany/modules/ImportVCard.so
+lib/mahogany/modules/ImportXFMail.so
+lib/mahogany/modules/LayoutEditor.so
+lib/mahogany/modules/LayoutViewer.so
+lib/mahogany/modules/Mdummy.so
+lib/mahogany/modules/Migrate.so
+lib/mahogany/modules/NetscapeImporter.so
+lib/mahogany/modules/PGP.so
+lib/mahogany/modules/PGPEngine.so
+lib/mahogany/modules/PineImport.so
+lib/mahogany/modules/QuoteURL.so
+lib/mahogany/modules/Rot13.so
+lib/mahogany/modules/Signature.so
+lib/mahogany/modules/TextMarkup.so
+lib/mahogany/modules/TextViewer.so
+lib/mahogany/modules/Trailer.so
+lib/mahogany/modules/UUDecode.so
+lib/mahogany/modules/XFMailImport.so
+%%NLS%%share/locale/de/LC_MESSAGES/M.mo
+%%NLS%%share/locale/es/LC_MESSAGES/M.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/M.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/M.mo
+%%NLS%%share/locale/it/LC_MESSAGES/M.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/M.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/M.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/M.mo
+%%DATADIR%%/M.conf
+%%DATADIR%%/afm/Cour.afm
+%%DATADIR%%/afm/CourBo.afm
+%%DATADIR%%/afm/CourBoO.afm
+%%DATADIR%%/afm/CourO.afm
+%%DATADIR%%/afm/Helv.afm
+%%DATADIR%%/afm/HelvBo.afm
+%%DATADIR%%/afm/HelvBoO.afm
+%%DATADIR%%/afm/HelvO.afm
+%%DATADIR%%/afm/TimesBo.afm
+%%DATADIR%%/afm/TimesBoO.afm
+%%DATADIR%%/afm/TimesO.afm
+%%DATADIR%%/afm/TimesRo.afm
+%%DATADIR%%/doc/Tips/Tips.txt
+%%DATADIR%%/icons/MFrame.xpm
+%%DATADIR%%/icons/MFrameNewMail.xpm
+%%DATADIR%%/icons/MLogFrame.xpm
+%%DATADIR%%/icons/M_16x16.xpm
+%%DATADIR%%/icons/M_32x32.xpm
+%%DATADIR%%/icons/MainFrame.xpm
+%%DATADIR%%/icons/MainFrameNewMail.xpm
+%%DATADIR%%/icons/Micon.xpm
+%%DATADIR%%/icons/Msplash.png
+%%DATADIR%%/icons/PythonPowered.xpm
+%%DATADIR%%/icons/access.xpm
+%%DATADIR%%/icons/adb_address.xpm
+%%DATADIR%%/icons/adb_bbdb.xpm
+%%DATADIR%%/icons/adb_book.xpm
+%%DATADIR%%/icons/adb_closed.xpm
+%%DATADIR%%/icons/adb_library.xpm
+%%DATADIR%%/icons/adb_opened.xpm
+%%DATADIR%%/icons/adb_palmos.xpm
+%%DATADIR%%/icons/adbedit.xpm
+%%DATADIR%%/icons/adbimport.xpm
+%%DATADIR%%/icons/adrbook.xpm
+%%DATADIR%%/icons/application.xpm
+%%DATADIR%%/icons/audio.xpm
+%%DATADIR%%/icons/autocollect.xpm
+%%DATADIR%%/icons/background.xpm
+%%DATADIR%%/icons/bbdb.xpm
+%%DATADIR%%/icons/binary.xpm
+%%DATADIR%%/icons/calendar.xpm
+%%DATADIR%%/icons/compose.xpm
+%%DATADIR%%/icons/dnd_msg.xpm
+%%DATADIR%%/icons/dnd_msgs.xpm
+%%DATADIR%%/icons/dspam.xpm
+%%DATADIR%%/icons/dvi.xpm
+%%DATADIR%%/icons/email.xpm
+%%DATADIR%%/icons/folder_file.xpm
+%%DATADIR%%/icons/folder_group.xpm
+%%DATADIR%%/icons/folder_imap.xpm
+%%DATADIR%%/icons/folder_inbox.xpm
+%%DATADIR%%/icons/folder_newmail.xpm
+%%DATADIR%%/icons/folder_news.xpm
+%%DATADIR%%/icons/folder_nntp.xpm
+%%DATADIR%%/icons/folder_outbox.xpm
+%%DATADIR%%/icons/folder_palmpilot.xpm
+%%DATADIR%%/icons/folder_pop.xpm
+%%DATADIR%%/icons/folder_root.xpm
+%%DATADIR%%/icons/folder_sentmail.xpm
+%%DATADIR%%/icons/folder_trash.xpm
+%%DATADIR%%/icons/folders.xpm
+%%DATADIR%%/icons/foldertree.xpm
+%%DATADIR%%/icons/folderview.xpm
+%%DATADIR%%/icons/ftplink.xpm
+%%DATADIR%%/icons/general.xpm
+%%DATADIR%%/icons/help.xpm
+%%DATADIR%%/icons/helpers.xpm
+%%DATADIR%%/icons/hlink.xpm
+%%DATADIR%%/icons/home.xpm
+%%DATADIR%%/icons/ident.xpm
+%%DATADIR%%/icons/image.xpm
+%%DATADIR%%/icons/image_both.xpm
+%%DATADIR%%/icons/image_mail.xpm
+%%DATADIR%%/icons/image_news.xpm
+%%DATADIR%%/icons/import.xpm
+%%DATADIR%%/icons/install_welcome.xpm
+%%DATADIR%%/icons/mahogany.xpm
+%%DATADIR%%/icons/message.xpm
+%%DATADIR%%/icons/miscopt.xpm
+%%DATADIR%%/icons/msg_del.xpm
+%%DATADIR%%/icons/msg_error.xpm
+%%DATADIR%%/icons/msg_info.xpm
+%%DATADIR%%/icons/msg_new.xpm
+%%DATADIR%%/icons/msg_normal.xpm
+%%DATADIR%%/icons/msg_question.xpm
+%%DATADIR%%/icons/msg_recent.xpm
+%%DATADIR%%/icons/msg_unread.xpm
+%%DATADIR%%/icons/msg_unread_bw.xpm
+%%DATADIR%%/icons/msg_warning.xpm
+%%DATADIR%%/icons/msgview.xpm
+%%DATADIR%%/icons/multipart.xpm
+%%DATADIR%%/icons/network.xpm
+%%DATADIR%%/icons/new.xpm
+%%DATADIR%%/icons/newmail.xpm
+%%DATADIR%%/icons/nomail_s.xpm
+%%DATADIR%%/icons/noxface.xpm
+%%DATADIR%%/icons/offline.xpm
+%%DATADIR%%/icons/online.xpm
+%%DATADIR%%/icons/palmpilot.xpm
+%%DATADIR%%/icons/pgpmsg_bad.xpm
+%%DATADIR%%/icons/pgpmsg_ok.xpm
+%%DATADIR%%/icons/pgpsig_bad.xpm
+%%DATADIR%%/icons/pgpsig_exp.xpm
+%%DATADIR%%/icons/pgpsig_good.xpm
+%%DATADIR%%/icons/pgpsig_untrust.xpm
+%%DATADIR%%/icons/postscript.xpm
+%%DATADIR%%/icons/python.xpm
+%%DATADIR%%/icons/pythonpower.xpm
+%%DATADIR%%/icons/sortdown.xpm
+%%DATADIR%%/icons/sortup.xpm
+%%DATADIR%%/icons/spam.xpm
+%%DATADIR%%/icons/ssllogo.xpm
+%%DATADIR%%/icons/sync.xpm
+%%DATADIR%%/icons/tb_adrbook.xpm
+%%DATADIR%%/icons/tb_attach.xpm
+%%DATADIR%%/icons/tb_book_open.xpm
+%%DATADIR%%/icons/tb_check_mail.xpm
+%%DATADIR%%/icons/tb_close.xpm
+%%DATADIR%%/icons/tb_delete.xpm
+%%DATADIR%%/icons/tb_document.xpm
+%%DATADIR%%/icons/tb_editor.xpm
+%%DATADIR%%/icons/tb_exit.xpm
+%%DATADIR%%/icons/tb_help.xpm
+%%DATADIR%%/icons/tb_lookup.xpm
+%%DATADIR%%/icons/tb_mail.xpm
+%%DATADIR%%/icons/tb_mail_compose.xpm
+%%DATADIR%%/icons/tb_mail_forward.xpm
+%%DATADIR%%/icons/tb_mail_new.xpm
+%%DATADIR%%/icons/tb_mail_reply.xpm
+%%DATADIR%%/icons/tb_mail_replyall.xpm
+%%DATADIR%%/icons/tb_mail_send.xpm
+%%DATADIR%%/icons/tb_modules.xpm
+%%DATADIR%%/icons/tb_new.xpm
+%%DATADIR%%/icons/tb_next_unread.xpm
+%%DATADIR%%/icons/tb_open.xpm
+%%DATADIR%%/icons/tb_openany.xpm
+%%DATADIR%%/icons/tb_palmos.xpm
+%%DATADIR%%/icons/tb_paste.xpm
+%%DATADIR%%/icons/tb_preferences.xpm
+%%DATADIR%%/icons/tb_print.xpm
+%%DATADIR%%/icons/tb_refresh.xpm
+%%DATADIR%%/icons/tb_trash.xpm
+%%DATADIR%%/icons/tb_undo.xpm
+%%DATADIR%%/icons/text.xpm
+%%DATADIR%%/icons/tgz.xpm
+%%DATADIR%%/icons/thread.xpm
+%%DATADIR%%/icons/undo.xpm
+%%DATADIR%%/icons/unknown.xpm
+%%DATADIR%%/icons/vcard.xpm
+%%DATADIR%%/icons/video.xpm
+%%DATADIR%%/icons/work.xpm
+%%DATADIR%%/icons/wxlogo.xpm
+%%DATADIR%%/icons/xface.xpm
+%%DATADIR%%/kylemail.wav
+%%DATADIR%%/newmail.wav
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/doc/Tips
+@dirrm %%DATADIR%%/doc
+@dirrm %%DATADIR%%/afm
+@dirrm %%DATADIR%%
+@dirrm lib/mahogany/modules
+@dirrm lib/mahogany