aboutsummaryrefslogtreecommitdiff
path: root/mail/mail-notification/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-17 07:26:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-17 07:26:23 +0000
commitf3577ab988181f7456df03e371a5a2443c43567e (patch)
treec26932af1312d2a459bb2640dec626e51738a1f4 /mail/mail-notification/Makefile
parentb96243c3e88ffc666dda78bbb7c970c73fe6621a (diff)
Notes
Diffstat (limited to 'mail/mail-notification/Makefile')
-rw-r--r--mail/mail-notification/Makefile34
1 files changed, 28 insertions, 6 deletions
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
index 7ce2cf1be6a3..51ce6b24d5ef 100644
--- a/mail/mail-notification/Makefile
+++ b/mail/mail-notification/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= mail-notification
-PORTVERSION= 0.5.0
-CATEGORIES= mail
+PORTVERSION= 0.6.0
+CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= mailnotify
@@ -18,13 +18,17 @@ USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack eel2
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
OPTIONS= MBOX "mbox support" on \
MH "MH support" on \
MAILDIR "Maildir support" on \
POP3 "POP3 support" on \
+ IMAP "IMAP support" on \
+ SSL "SSL support" on \
+ SASL "SASL authentication support" on \
SYLPHEED "Sylpheed support" on \
GMAIL "Gmail support" on
@@ -41,8 +45,14 @@ CONFIGURE_ARGS+= --disable-maildir
.endif
.if defined(WITHOUT_POP3)
CONFIGURE_ARGS+= --disable-pop3
-.else
-LIB_DEPENDS+= gnet-2.0:${PORTSDIR}/net/gnet2
+.endif
+.if defined(WITHOUT_IMAP)
+CONFIGURE_ARGS+= --disable-imap
+.endif
+.if defined(WITHOUT_POP3) && defined(WITHOUT_IMAP)
+# only POP3 and IMAP use SSL and SASL
+WITHOUT_SSL= yes
+WITHOUT_SASL= yes
.endif
.if defined(WITHOUT_SYLPHEED)
CONFIGURE_ARGS+= --disable-sylpheed
@@ -53,4 +63,16 @@ CONFIGURE_ARGS+= --disable-gmail
LIB_DEPENDS+= soup-2.0:${PORTSDIR}/devel/libsoup
.endif
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --disable-ssl
+.else
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+.endif
+.if defined(WITHOUT_SASL)
+CONFIGURE_ARGS+= --disable-sasl
+.else
+LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+.endif
+
.include <bsd.port.post.mk>