aboutsummaryrefslogtreecommitdiff
path: root/mail/mail-notification
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-09 18:57:13 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-09 18:57:13 +0000
commite6ebdafa900cb57830d85b1b442d9c75baa3c99c (patch)
tree730682ca697611346b8f15d61e7f87cf16055e41 /mail/mail-notification
parent582264dc7ad488634ee9ebfe903b89f76b684301 (diff)
Notes
Diffstat (limited to 'mail/mail-notification')
-rw-r--r--mail/mail-notification/Makefile2
-rw-r--r--mail/mail-notification/files/patch-src_mn-mailbox.c35
2 files changed, 36 insertions, 1 deletions
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
index c0be9cae2ce2..28cf698e56a4 100644
--- a/mail/mail-notification/Makefile
+++ b/mail/mail-notification/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mail-notification
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= mailnotify
diff --git a/mail/mail-notification/files/patch-src_mn-mailbox.c b/mail/mail-notification/files/patch-src_mn-mailbox.c
new file mode 100644
index 000000000000..bff2fc50b9d7
--- /dev/null
+++ b/mail/mail-notification/files/patch-src_mn-mailbox.c
@@ -0,0 +1,35 @@
+--- src/mn-mailbox.c.orig Mon May 9 20:49:29 2005
++++ src/mn-mailbox.c Mon May 9 20:51:26 2005
+@@ -913,31 +913,11 @@
+ {
+ #line 378 "mn-mailbox.gob"
+
+- GnomeVFSResult result;
+-
+ g_return_if_fail(MN_MAILBOX_CAN_CHECK(self));
+ g_return_if_fail(selfp->monitor_handle == NULL);
+
+- gdk_flush();
+- GDK_THREADS_LEAVE();
+-
+- result = gnome_vfs_monitor_add(&selfp->monitor_handle,
+- uri,
+- monitor_type,
+- self_monitor_cb,
+- self);
+-
+- GDK_THREADS_ENTER();
+-
+- if (result == GNOME_VFS_OK)
+- {
+- selfp->monitor_uri = g_strdup(uri);
+- selfp->monitor_events = events;
+- self_set_must_poll(self, FALSE);
+- }
+- else
+ {
+- self_warning(self, _("unable to enable immediate notification: %s"), gnome_vfs_result_to_string(result));
++ self_warning(self, _("unable to enable immediate notification: broken, will be fixed in the next release"));
+
+ if (! eel_gconf_get_boolean(MN_CONF_IMMEDIATE_NOTIFICATION_ERROR_DIALOG_DO_NOT_SHOW))
+ {