aboutsummaryrefslogtreecommitdiff
path: root/mail/mail-notification
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2015-06-29 17:56:00 +0000
committerRene Ladan <rene@FreeBSD.org>2015-06-29 17:56:00 +0000
commit222937640c40b8137681360f65e347a7a8cf4e9d (patch)
tree9fec67b85cc28b792be9eebcc0d068e53851de6d /mail/mail-notification
parentbd216a7b5d2ebfeeb6231cbd1cecf1277390f3f5 (diff)
downloadports-222937640c40b8137681360f65e347a7a8cf4e9d.tar.gz
ports-222937640c40b8137681360f65e347a7a8cf4e9d.zip
Notes
Diffstat (limited to 'mail/mail-notification')
-rw-r--r--mail/mail-notification/Makefile125
-rw-r--r--mail/mail-notification/distinfo2
-rw-r--r--mail/mail-notification/files/patch-50-evolution188
-rw-r--r--mail/mail-notification/files/patch-52-sasl_encode6424
-rw-r--r--mail/mail-notification/files/patch-53-evolution-gtkhtml12
-rw-r--r--mail/mail-notification/files/patch-54-camel_headers36
-rw-r--r--mail/mail-notification/files/patch-56-weak11
-rw-r--r--mail/mail-notification/files/patch-57-popup-attach45
-rw-r--r--mail/mail-notification/files/patch-58-kde-trayicon72
-rw-r--r--mail/mail-notification/files/patch-jbsrc-jb.c10
-rw-r--r--mail/mail-notification/files/patch-openssl-threads11
-rw-r--r--mail/mail-notification/files/patch-po_pl.po15
-rw-r--r--mail/mail-notification/files/patch-src-mn-stock.c39
-rw-r--r--mail/mail-notification/pkg-descr22
-rw-r--r--mail/mail-notification/pkg-plist36
15 files changed, 0 insertions, 648 deletions
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
deleted file mode 100644
index 102118f527e6..000000000000
--- a/mail/mail-notification/Makefile
+++ /dev/null
@@ -1,125 +0,0 @@
-# Created by: Jean-Yves Lefort <jylefort@brutele.be>
-# $FreeBSD$
-
-PORTNAME= mail-notification
-DISTVERSION= 5.4
-PORTREVISION= 15
-CATEGORIES= mail ipv6
-MASTER_SITES= SAVANNAH/mailnotify-orig
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Mail notification for freedesktop.org-compliant system trays
-
-BROKEN= Run-time failure with Gnome 3
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2015-06-29
-
-LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
- libgnome-keyring.so:${PORTSDIR}/security/gnome-keyring \
- libnotify.so:${PORTSDIR}/devel/libnotify
-
-USES= gettext tar:bzip2
-USE_LDCONFIG= yes
-USE_GNOME= gconf2 gnomeprefix gnomevfs2 libglade2 libgnomeui libxml2
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-JB_CONF_ARGS= cc="${CC}" cflags="${CFLAGS}" cppflags="${CPPFLAGS}" ldflags="${LDFLAGS}" prefix="${PREFIX}" destdir="${STAGEDIR}" hotmail=no
-JB_CONF_ENV= ${MAKE_ENV} jb_cppflags="${CPPFLAGS}" jb_ldflags="${LDFLAGS}"
-GCONF_SCHEMAS= mail-notification.schemas
-INSTALLS_OMF= yes
-INSTALLS_ICONS= yes
-
-OPTIONS_DEFINE= EVOLUTION GMAIL IMAP MAILDIR MBOX MH MOZILLA \
- POP3 SASL SSL SYLPHEED
-OPTIONS_DEFAULT= GMAIL IMAP MAILDIR MBOX MH MOZILLA \
- POP3 SASL SSL SYLPHEED
-EVOLUTION_DESC= Evolution support
-GMAIL_DESC= Gmail support
-IMAP_DESC= IMAP support
-MAILDIR_DESC= Maildir support
-MBOX_DESC= mbox support
-MH_DESC= MH support
-MOZILLA_DESC= Mozilla products support
-POP3_DESC= POP3 support
-SYLPHEED_DESC= Sylpheed support
-
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MMBOX}
-JB_CONF_ARGS+= mbox=no
-.endif
-.if ! ${PORT_OPTIONS:MMH}
-JB_CONF_ARGS+= mh=no
-.endif
-.if ! ${PORT_OPTIONS:MMAILDIR}
-JB_CONF_ARGS+= maildir=no
-.endif
-.if ! ${PORT_OPTIONS:MPOP3}
-JB_CONF_ARGS+= pop3=no
-.endif
-.if ! ${PORT_OPTIONS:MIMAP}
-JB_CONF_ARGS+= imap=no
-.endif
-.if ! ${PORT_OPTIONS:MPOP3} && ! ${PORT_OPTIONS:MIMAP}
-# only POP3 and IMAP use SSL and SASL
-WITHOUT_SSL= yes
-WITHOUT_SASL= yes
-.endif
-.if ! ${PORT_OPTIONS:MGMAIL}
-JB_CONF_ARGS+= gmail=no
-PLIST_SUB+= GMAIL="@comment "
-.else
-PLIST_SUB+= GMAIL=""
-.endif
-JB_CONF_ARGS+= yahoo=no
-.if ! ${PORT_OPTIONS:MEVOLUTION}
-JB_CONF_ARGS+= evolution=no
-PLIST_SUB+= EVOLUTION="@comment "
-.else
-EVO_VERSION!= make -C ${PORTSDIR}/mail/evolution -V EVO_VERSION
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/evolution-plugin.pc:${PORTSDIR}/mail/evolution
-RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/evolution-plugin.pc:${PORTSDIR}/mail/evolution
-USE_GNOME+= gtkhtml3
-PLIST_SUB+= EVOLUTION="" EVO_VERSION=${EVO_VERSION}
-.endif
-.if ! ${PORT_OPTIONS:MMOZILLA}
-JB_CONF_ARGS+= mozilla=no
-.endif
-.if ! ${PORT_OPTIONS:MSYLPHEED}
-JB_CONF_ARGS+= sylpheed=no
-.endif
-.if ${PORT_OPTIONS:MMBOX} \
- || ${PORT_OPTIONS:MMH} \
- || ${PORT_OPTIONS:MMAILDIR} \
- || ${PORT_OPTIONS:MPOP3} \
- || ${PORT_OPTIONS:MIMAP} \
- || ${PORT_OPTIONS:MMOZILLA} \
- || ${PORT_OPTIONS:MSYLPHEED}
-LIB_DEPENDS+= libgmime-2.6.so:${PORTSDIR}/mail/gmime26
-.endif
-.if ! ${PORT_OPTIONS:MSSL}
-JB_CONF_ARGS+= ssl=no
-.else
-USE_OPENSSL= yes
-.endif
-.if ! ${PORT_OPTIONS:MSASL}
-JB_CONF_ARGS+= sasl=no
-.else
-LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-Werror||g' ${WRKSRC}/jb ${WRKSRC}/jbsrc/jb.c
-
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${JB_CONF_ENV} \
- ./jb configure ${JB_CONF_ARGS}
-
-do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./jb build
- ${STRIP_CMD} ${WRKSRC}/build/src/mail-notification
-
-do-install:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./jb install
-
-.include <bsd.port.mk>
diff --git a/mail/mail-notification/distinfo b/mail/mail-notification/distinfo
deleted file mode 100644
index d5eea0fb4e3f..000000000000
--- a/mail/mail-notification/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (mail-notification-5.4.tar.bz2) = 5dec5f3852437e7735269697c77a29a24ea230987c764523fe66dabdca815af5
-SIZE (mail-notification-5.4.tar.bz2) = 570008
diff --git a/mail/mail-notification/files/patch-50-evolution b/mail/mail-notification/files/patch-50-evolution
deleted file mode 100644
index aac23eb4e063..000000000000
--- a/mail/mail-notification/files/patch-50-evolution
+++ /dev/null
@@ -1,188 +0,0 @@
-diff -Nrbu build/src/mn-evolution-folder-tree-server.c build/src/mn-evolution-folder-tree-server.c
---- build/src/mn-evolution-folder-tree-server.c 2008-05-22 19:47:48.000000000 +0400
-+++ build/src/mn-evolution-folder-tree-server.c 2010-09-17 17:45:05.000000000 +0400
-@@ -25,7 +25,10 @@
- #line 24 "src/mn-evolution-folder-tree-server.gob"
-
- #include <dbus/dbus.h>
-+#include <libedataserver/eds-version.h>
-+#if !EDS_CHECK_VERSION(2,29,0)
- #include <mail/mail-component.h>
-+#endif
- #include <mail/em-folder-tree.h>
- #include "mn-evolution-plugin.h"
- #include "mn-evolution.h"
-@@ -441,10 +444,14 @@
- {
- #line 61 "src/mn-evolution-folder-tree-server.gob"
-
-+#if EDS_CHECK_VERSION(2,29,0)
-+ selfp->tree = em_folder_tree_new();
-+#else
- EMFolderTreeModel *model;
-
- model = mail_component_peek_tree_model(mail_component_peek());
- selfp->tree = em_folder_tree_new_with_model(model);
-+#endif
-
- selfp->plug = gtk_plug_new((GdkNativeWindow) selfp->id);
- gtk_container_add(GTK_CONTAINER(selfp->plug), selfp->tree);
-diff -Nrbu build/src/mn-evolution-server.c build/src/mn-evolution-server.c
---- build/src/mn-evolution-server.c 2008-05-22 19:47:48.000000000 +0400
-+++ build/src/mn-evolution-server.c 2010-09-17 17:45:32.000000000 +0400
-@@ -27,10 +27,16 @@
- #include <stdio.h>
- #include <libintl.h>
- #include <gobject/gvaluecollector.h>
-+#include <libedataserver/eds-version.h>
- #include <camel/camel-folder.h>
-+#if EDS_CHECK_VERSION(2,29,0)
-+#include <shell/e-shell.h>
-+#include <mail/e-mail-browser.h>
-+#else
- #include <mail/em-folder-view.h>
- #include <mail/em-format.h>
- #include <mail/em-message-browser.h>
-+#endif
- #include <mail/em-utils.h>
- #include <mail/mail-session.h>
- #include <mail/mail-tools.h>
-@@ -391,10 +397,18 @@
- info = g_new0(FolderInfo, 1);
- info->uri = g_strdup(uri);
- info->folder = folder;
-+#if EDS_CHECK_VERSION(2,31,0)
-+ g_object_ref(folder);
-+#else
- camel_object_ref(folder);
-+#endif
-
- /* uncache the folder when it is deleted */
-+#if EDS_CHECK_VERSION(2,31,0)
-+ g_signal_connect(folder, "deleted", G_CALLBACK(self_folder_deleted_cb), info);
-+#else
- camel_object_hook_event(folder, "deleted", self_folder_deleted_cb, info);
-+#endif
-
- g_hash_table_replace(folders, info->uri, info);
- }}
-@@ -413,8 +427,13 @@
- {
- #line 105 "src/mn-evolution-server.gob"
-
-+#if EDS_CHECK_VERSION(2,31,0)
-+ g_signal_handlers_disconnect_by_func(info->folder, self_folder_deleted_cb, info);
-+ g_object_unref(info->folder);
-+#else
- camel_object_unhook_event(info->folder, "deleted", self_folder_deleted_cb, info);
- camel_object_unref(info->folder);
-+#endif
- g_free(info->uri);
- g_free(info);
- }}
-@@ -461,7 +480,11 @@
- if (info)
- {
- folder = info->folder;
-+#if EDS_CHECK_VERSION(2,31,0)
-+ g_object_ref(folder);
-+#else
- camel_object_ref(folder);
-+#endif
- }
- }
- else
-@@ -595,14 +618,23 @@
-
- for (i = 0; i < summary->len; i++)
- {
-+#if EDS_CHECK_VERSION(2,23,5)
-+ char *uid = summary->pdata[i];
-+ CamelMessageInfo *info = camel_folder_get_message_info(folder, uid);
-+#else
- CamelMessageInfo *info = summary->pdata[i];
-+#endif
-
- if ((camel_message_info_flags(info) & CAMEL_MESSAGE_SEEN) == 0)
- g_ptr_array_add(*ret, self_camel_message_info_to_dbus_struct(info));
- }
-
- camel_folder_free_summary(folder, summary);
-+#if EDS_CHECK_VERSION(2,31,0)
-+ g_object_unref(folder);
-+#else
- camel_object_unref(folder);
-+#endif
- }
-
- GDK_THREADS_LEAVE();
-@@ -638,7 +670,11 @@
- if (folder)
- {
- *ret = g_strdup(camel_folder_get_name(folder));
-+#if EDS_CHECK_VERSION(2,31,0)
-+ g_object_unref(folder);
-+#else
- camel_object_unref(folder);
-+#endif
- }
-
- GDK_THREADS_LEAVE();
-@@ -673,6 +709,19 @@
- folder = self_lookup_folder(folder_uri, err);
- if (folder)
- {
-+#if EDS_CHECK_VERSION(2,29,0)
-+ EShell *shell;
-+ EShellBackend *shell_backend;
-+ GtkWidget *browser;
-+
-+ shell = e_shell_get_default ();
-+ shell_backend = e_shell_get_backend_by_name (shell, "mail");
-+
-+ browser = e_mail_browser_new (shell_backend);
-+ e_mail_reader_set_folder (E_MAIL_READER (browser), folder, folder_uri);
-+ e_mail_reader_set_message (E_MAIL_READER (browser), message_uid);
-+ gtk_widget_show (browser);
-+#else
- GtkWidget *browser;
-
- /* modelled after Evolution's handleuri_got_folder() */
-@@ -683,8 +732,13 @@
- em_folder_view_set_folder((EMFolderView *) browser, folder, folder_uri);
- em_folder_view_set_message((EMFolderView *) browser, message_uid, FALSE);
- gtk_widget_show(((EMMessageBrowser *) browser)->window);
-+#endif
-
-+#if EDS_CHECK_VERSION(2,31,0)
-+ g_object_unref(folder);
-+#else
- camel_object_unref(folder);
-+#endif
- }
-
- GDK_THREADS_LEAVE();
-@@ -721,7 +775,11 @@
- if (folder)
- {
- status = camel_folder_set_message_flags(folder, message_uid, flags, flags);
-+#if EDS_CHECK_VERSION(2,31,0)
-+ g_object_unref(folder);
-+#else
- camel_object_unref(folder);
-+#endif
-
- if (! status)
- g_set_error(err,
-diff -Nrbu src/mn-evolution-plugin.c src/mn-evolution-plugin.c
---- src/mn-evolution-plugin.c 2008-05-22 19:45:35.000000000 +0400
-+++ src/mn-evolution-plugin.c 2010-09-17 17:45:05.000000000 +0400
-@@ -204,7 +204,7 @@
- }
-
- int
--e_plugin_lib_enable (EPluginLib *ep, int enable)
-+e_plugin_lib_enable (EPlugin *ep, int enable)
- {
- static gboolean enabled = FALSE;
- GError *err = NULL;
diff --git a/mail/mail-notification/files/patch-52-sasl_encode64 b/mail/mail-notification/files/patch-52-sasl_encode64
deleted file mode 100644
index e9edbbb63a43..000000000000
--- a/mail/mail-notification/files/patch-52-sasl_encode64
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -up build/src/mn-pop3-mailbox.c build/src/mn-pop3-mailbox.c
---- build/src/mn-pop3-mailbox.c 2009-05-19 10:29:58.448201837 +0200
-+++ build/src/mn-pop3-mailbox.c 2009-05-19 10:23:29.356204287 +0200
-@@ -619,7 +619,7 @@ mn_pop3_mailbox_enter_auth_cb (MNClientS
-
- if (initial_clientoutlen > 0)
- {
-- char buf64[initial_clientoutlen * 2]; /* Base64 is 33% larger than the data it encodes */
-+ char buf64[initial_clientoutlen * 2 + 1]; /* Base64 is 33% larger than the data it encodes */
- unsigned int outlen;
- int result;
- char *str;
-diff -up src/mn-client-session.c src/mn-client-session.c
---- src/mn-client-session.c 2008-05-22 17:45:35.000000000 +0200
-+++ src/mn-client-session.c 2009-05-19 10:29:09.112211055 +0200
-@@ -1030,7 +1030,7 @@ mn_client_session_write (MNClientSession
- static int
- write_base64 (MNClientSession *session, const char *buf, unsigned int len)
- {
-- char buf64[len * 2]; /* Base64 is 33% larger than the data it encodes */
-+ char buf64[len * 2 + 1]; /* Base64 is 33% larger than the data it encodes */
- unsigned int outlen;
- int result;
- char *str;
diff --git a/mail/mail-notification/files/patch-53-evolution-gtkhtml b/mail/mail-notification/files/patch-53-evolution-gtkhtml
deleted file mode 100644
index 68f6ad39899c..000000000000
--- a/mail/mail-notification/files/patch-53-evolution-gtkhtml
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nrbu jbsrc/lib/src/extras/jb-evolution-plugin.c jbsrc/lib/src/extras/jb-evolution-plugin.c
---- jbsrc/lib/src/extras/jb-evolution-plugin.c 2008-04-27 18:47:43.000000000 +0400
-+++ jbsrc/lib/src/extras/jb-evolution-plugin.c 2009-08-21 19:48:22.000000000 +0400
-@@ -41,7 +41,7 @@
- if (! minversion)
- minversion = "2.12";
-
-- packages = g_strdup_printf("evolution-plugin >= %s", minversion);
-+ packages = g_strdup_printf("evolution-plugin >= %s libgtkhtml-3.14 gtkhtml-editor-3.14", minversion);
- result = jb_check_packages("Evolution", "evolution-plugin", packages);
- g_free(packages);
-
diff --git a/mail/mail-notification/files/patch-54-camel_headers b/mail/mail-notification/files/patch-54-camel_headers
deleted file mode 100644
index b647459f87ba..000000000000
--- a/mail/mail-notification/files/patch-54-camel_headers
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Nrbu build/src/mn-evolution-message.c build/src/mn-evolution-message.c
---- build/src/mn-evolution-message.c 2008-05-22 19:47:51.000000000 +0400
-+++ build/src/mn-evolution-message.c 2010-05-04 18:13:31.000000000 +0400
-@@ -25,7 +25,7 @@
- #line 24 "src/mn-evolution-message.gob"
-
- #include <glib/gi18n.h>
--#include <camel/camel-folder-summary.h>
-+#include <camel/camel.h>
- #include "mn-evolution-mailbox.h"
- #include "mn-message-private.h"
- #include "mn-evolution-client.h"
-diff -Nrbu build/src/mn-evolution-server.c build/src/mn-evolution-server.c
---- build/src/mn-evolution-server.c 2010-05-04 18:12:56.000000000 +0400
-+++ build/src/mn-evolution-server.c 2010-05-04 18:13:39.000000000 +0400
-@@ -28,7 +28,7 @@
- #include <libintl.h>
- #include <gobject/gvaluecollector.h>
- #include <libedataserver/eds-version.h>
--#include <camel/camel-folder.h>
-+#include <camel/camel.h>
- #if EDS_CHECK_VERSION(2,29,0)
- #include <shell/e-shell.h>
- #include <mail/e-mail-browser.h>
-diff -Nrbu src/mn-evolution-plugin.c src/mn-evolution-plugin.c
---- src/mn-evolution-plugin.c 2010-05-04 18:12:56.000000000 +0400
-+++ src/mn-evolution-plugin.c 2010-05-04 18:13:20.000000000 +0400
-@@ -24,7 +24,7 @@
- #include <dbus/dbus.h>
- #include <dbus/dbus-glib-lowlevel.h>
- #include <dbus/dbus-glib-bindings.h>
--#include <camel/camel-folder.h>
-+#include <camel/camel.h>
- #include <mail/em-event.h>
- #include <mail/mail-tools.h>
- #include "mn-evolution.h"
diff --git a/mail/mail-notification/files/patch-56-weak b/mail/mail-notification/files/patch-56-weak
deleted file mode 100644
index 1ffac2869538..000000000000
--- a/mail/mail-notification/files/patch-56-weak
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Nrbu build/src/mn-shell.c build/src/mn-shell.c
---- build/src/mn-shell.c 2008-05-22 19:47:49.000000000 +0400
-+++ build/src/mn-shell.c 2010-05-24 19:39:48.000000000 +0400
-@@ -1008,6 +1008,7 @@
- Self *self = user_data;
-
- /* The Notification Area applet has been terminated. Recreate the icon. */
-+ mn_remove_weak_pointer(&self->icon);
- self_init_icon(self);
- }}
- #line 1014 "mn-shell.c"
diff --git a/mail/mail-notification/files/patch-57-popup-attach b/mail/mail-notification/files/patch-57-popup-attach
deleted file mode 100644
index 8488ebf55d6a..000000000000
--- a/mail/mail-notification/files/patch-57-popup-attach
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Nrbu build/src/mn-popup.c build/src/mn-popup.c
---- build/src/mn-popup.c 2008-05-22 19:47:49.000000000 +0400
-+++ build/src/mn-popup.c 2010-10-11 17:42:32.000000000 +0400
-@@ -177,6 +177,29 @@
- #undef __GOB_FUNCTION__
-
- static void
-+mn_popup_wait_for_icon_to_become_ready (void)
-+{
-+ int x, y;
-+ int count = 0;
-+
-+ /* When the tray icon is created, it can still take some time before
-+ * it has arrived at the correct position. This is especially the case
-+ * on KDE environments. To work around this, add a little delay of at
-+ * most 2 seconds before showing a popup which is attached to the notification */
-+ do {
-+ gdk_window_get_origin (gtk_widget_get_window (mn_shell->icon), &x, &y);
-+
-+ if (x != 0 || y != 0) {
-+ break;
-+ }
-+
-+ g_usleep(G_USEC_PER_SEC / 10);
-+ count++;
-+ } while (count < 20);
-+}
-+
-+
-+static void
- mn_popup_init (MNPopup * o G_GNUC_UNUSED)
- {
- #define __GOB_FUNCTION__ "MN:Popup::init"
-@@ -299,8 +322,10 @@
- "icon-name", "stock_mail",
- NULL);
-
-- if (mn_conf_get_enum_value(MN_TYPE_POPUP_POSITION, MN_CONF_POPUPS_POSITION) == MN_POPUP_POSITION_ATTACHED)
-+ if (mn_conf_get_enum_value(MN_TYPE_POPUP_POSITION, MN_CONF_POPUPS_POSITION) == MN_POPUP_POSITION_ATTACHED) {
-+ mn_popup_wait_for_icon_to_become_ready();
- g_object_set(self, "attach-widget", mn_shell->icon, NULL);
-+ }
-
- g_string_free(body, TRUE);
-
diff --git a/mail/mail-notification/files/patch-58-kde-trayicon b/mail/mail-notification/files/patch-58-kde-trayicon
deleted file mode 100644
index 3429b48a6ed4..000000000000
--- a/mail/mail-notification/files/patch-58-kde-trayicon
+++ /dev/null
@@ -1,72 +0,0 @@
-diff -Nrbu build/src/mn-shell.c build/src/mn-shell.c
---- build/src/mn-shell.c 2010-10-11 17:45:23.000000000 +0400
-+++ build/src/mn-shell.c 2010-10-11 17:45:48.000000000 +0400
-@@ -313,6 +313,29 @@
- #undef __GOB_FUNCTION__
-
- static void
-+mn_shell_init_icon_base (MNShell * self)
-+{
-+ g_return_if_fail (self != NULL);
-+ g_return_if_fail (MN_IS_SHELL (self));
-+
-+ self->icon = MN_MAIL_ICON(mn_mail_icon_new());
-+ mn_add_weak_pointer(&self->icon);
-+
-+ g_object_connect(self->icon,
-+ "signal::activate", self_icon_activate_h, self,
-+ "signal::activate-mail-reader", self_icon_activate_mail_reader_h, self,
-+ "signal::activate-open-latest-message", self_icon_activate_open_latest_message_h, self,
-+ "swapped-signal::activate-consider-new-mail-as-read", self_consider_new_mail_as_read, self,
-+ "swapped-signal::activate-update", self_update, self,
-+ "signal::activate-properties", self_icon_activate_properties_h, self,
-+ "signal::activate-help", self_icon_activate_help_h, self,
-+ "signal::activate-about", self_icon_activate_about_h, self,
-+ "swapped-signal::activate-remove", self_quit, self,
-+ "signal::destroy", self_icon_destroy_h, self,
-+ NULL);
-+}
-+
-+static void
- mn_shell_init (MNShell * o G_GNUC_UNUSED)
- {
- #define __GOB_FUNCTION__ "MN:Shell::init"
-@@ -793,22 +816,7 @@
- {
- #line 360 "src/mn-shell.gob"
-
-- self->icon = MN_MAIL_ICON(mn_mail_icon_new());
-- mn_add_weak_pointer(&self->icon);
--
-- g_object_connect(self->icon,
-- "signal::activate", self_icon_activate_h, self,
-- "signal::activate-mail-reader", self_icon_activate_mail_reader_h, self,
-- "signal::activate-open-latest-message", self_icon_activate_open_latest_message_h, self,
-- "swapped-signal::activate-consider-new-mail-as-read", self_consider_new_mail_as_read, self,
-- "swapped-signal::activate-update", self_update, self,
-- "signal::activate-properties", self_icon_activate_properties_h, self,
-- "signal::activate-help", self_icon_activate_help_h, self,
-- "signal::activate-about", self_icon_activate_about_h, self,
-- "swapped-signal::activate-remove", self_quit, self,
-- "signal::destroy", self_icon_destroy_h, self,
-- NULL);
--
-+ mn_shell_init_icon_base(self);
- self_update_sensitivity(self);
- self_update_tooltip(self);
- self_update_icon(self);
-@@ -1094,7 +1102,13 @@
- }
- else
- {
-- gtk_widget_hide(GTK_WIDGET(self->icon));
-+ /* Re-create the icon as a regular gtk_widget_hide causes the
-+ * icon to remain visible on non-GNOME environments. We can't
-+ * use the callback self_icon_destroy_h here as it can cause an
-+ * endless recursion */
-+ g_signal_handlers_disconnect_by_func(self->icon, self_icon_destroy_h, self);
-+ gtk_widget_destroy(GTK_WIDGET(self->icon));
-+ mn_shell_init_icon_base(self);
- mn_mail_icon_set_blinking(self->icon, FALSE);
- }
- }}
diff --git a/mail/mail-notification/files/patch-jbsrc-jb.c b/mail/mail-notification/files/patch-jbsrc-jb.c
deleted file mode 100644
index 1b755b97f41a..000000000000
--- a/mail/mail-notification/files/patch-jbsrc-jb.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- jbsrc/jb.c.orig
-+++ jbsrc/jb.c
-@@ -444,6 +444,7 @@
- jb_compile_options_add_ldflags(object->compile_options, "-Wl,--export-dynamic");
-
- jb_compile_options_add_libs(object->compile_options, "-lm");
-+ jb_compile_options_add_libs(object->compile_options, "-lX11");
-
- jb_compile_options_add_package(object->compile_options, "gettext");
- jb_compile_options_add_package(object->compile_options, "gnome");
diff --git a/mail/mail-notification/files/patch-openssl-threads b/mail/mail-notification/files/patch-openssl-threads
deleted file mode 100644
index 8c935adef6b1..000000000000
--- a/mail/mail-notification/files/patch-openssl-threads
+++ /dev/null
@@ -1,11 +0,0 @@
---- jbsrc/lib/src/extras/jb-openssl.c.orig 2008-04-27 16:47:43.000000000 +0200
-+++ jbsrc/lib/src/extras/jb-openssl.c 2008-07-10 22:48:53.000000000 +0200
-@@ -91,7 +91,7 @@
- result = jb_test_compile_string("#define OPENSSL_THREAD_DEFINES\n"
- "#include <openssl/opensslconf.h>\n"
- "int main () {\n"
-- "#ifndef OPENSSL_THREADS\n"
-+ "#if !defined(OPENSSL_THREADS) && !defined(THREADS)\n"
- "#error \"no thread support\"\n"
- "#endif\n"
- "}\n",
diff --git a/mail/mail-notification/files/patch-po_pl.po b/mail/mail-notification/files/patch-po_pl.po
deleted file mode 100644
index 24bf6f9406e1..000000000000
--- a/mail/mail-notification/files/patch-po_pl.po
+++ /dev/null
@@ -1,15 +0,0 @@
---- po/pl.po.orig 2008-05-22 17:38:01.000000000 +0200
-+++ po/pl.po 2008-07-11 01:44:09.000000000 +0200
-@@ -777,9 +777,9 @@
- #, c-format
- msgid "feed retrieved successfully (%i byte)"
- msgid_plural "feed retrieved successfully (%i bytes)"
--msgstr[0] "nagłówek pobrany pomyślnie (%s bajt)"
--msgstr[1] "nagłówek pobrany pomyślnie (%s bajty)"
--msgstr[2] "nagłówek pobrany pomyślnie (%s bajtów)"
-+msgstr[0] "nagłówek pobrany pomyślnie (%i bajt)"
-+msgstr[1] "nagłówek pobrany pomyślnie (%i bajty)"
-+msgstr[2] "nagłówek pobrany pomyślnie (%i bajtów)"
-
- #: ../src/mn-gmail-mailbox.gob:203 ../src/mn-gmail-mailbox.gob:254
- msgid "unable to parse feed"
diff --git a/mail/mail-notification/files/patch-src-mn-stock.c b/mail/mail-notification/files/patch-src-mn-stock.c
deleted file mode 100644
index a2742d1ebe19..000000000000
--- a/mail/mail-notification/files/patch-src-mn-stock.c
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -Nrbu src/mn-stock.c.orig src/mn-stock.c
---- src/mn-stock.c.orig 2008-05-22 19:45:35.000000000 +0400
-+++ src/mn-stock.c 2010-05-24 19:36:03.000000000 +0400
-@@ -32,11 +32,11 @@
- const char *icon_name;
- const char *source_stock_id;
- } icons[] = {
-- { MN_STOCK_MAIL, NULL, "stock_mail" },
-- { MN_STOCK_NO_MAIL, NULL, "stock_inbox" },
-- { MN_STOCK_LOCAL, NULL, "stock_folder" },
-- { MN_STOCK_REMOTE, NULL, "stock_internet" },
-- { MN_STOCK_UNKNOWN, NULL, "stock_unknown" },
-+ { MN_STOCK_MAIL, NULL, "mail-message-new" },
-+ { MN_STOCK_NO_MAIL, NULL, "mail-notification" },
-+ { MN_STOCK_LOCAL, NULL, "folder" },
-+ { MN_STOCK_REMOTE, NULL, "applications-internet" },
-+ { MN_STOCK_UNKNOWN, NULL, "dialog-question" },
- { MN_STOCK_ERROR, NULL, NULL, GTK_STOCK_DIALOG_ERROR },
- #if WITH_GMAIL
- { MN_STOCK_GMAIL, PKGDATADIR G_DIR_SEPARATOR_S "gmail.png" },
-@@ -48,14 +48,14 @@
- { MN_STOCK_HOTMAIL, PKGDATADIR G_DIR_SEPARATOR_S "hotmail.png" },
- #endif
- #if WITH_MBOX || WITH_MOZILLA || WITH_MH || WITH_MAILDIR || WITH_SYLPHEED
-- { MN_STOCK_SYSTEM_MAILBOX, NULL, "system" },
-+ { MN_STOCK_SYSTEM_MAILBOX, NULL, "applications-system" },
- #endif
- #if WITH_EVOLUTION
- { MN_STOCK_EVOLUTION_MAILBOX, NULL, "evolution" },
- #endif
-- { MN_STOCK_MAIL_READER, NULL, "stock_mail-handling" },
-- { MN_STOCK_OPEN_MESSAGE, NULL, "stock_mail-open" },
-- { MN_STOCK_CONSIDER_NEW_MAIL_AS_READ, NULL, "stock_mark" }
-+ { MN_STOCK_MAIL_READER, NULL, "mail-unread" },
-+ { MN_STOCK_OPEN_MESSAGE, NULL, "mail-read" },
-+ { MN_STOCK_CONSIDER_NEW_MAIL_AS_READ, NULL, "mail-mark-read" }
- };
- GtkIconFactory *factory;
- GtkIconTheme *icon_theme;
diff --git a/mail/mail-notification/pkg-descr b/mail/mail-notification/pkg-descr
deleted file mode 100644
index a541ca1e6e47..000000000000
--- a/mail/mail-notification/pkg-descr
+++ /dev/null
@@ -1,22 +0,0 @@
-Mail Notification is a status icon (aka tray icon) that informs you if you
-have new mail.
-
-It works with system trays implementing the freedesktop.org System Tray
-Specification, such as the GNOME Panel Notification Area, the Xfce
-Notification Area and the KDE System Tray.
-
-Mail Notification features include:
-
- * multiple mailbox support
- * mbox, MH, Maildir, POP3, IMAP, Gmail, Evolution, Mozilla products
- (Mozilla, SeaMonkey, Thunderbird, ...) and Sylpheed support
- * SASL authentication support
- * APOP authentication support
- * SSL/TLS support
- * automatic detection of mailbox format
- * immediate notification (the status icon is updated immediately or
- within seconds after a mailbox changes)
- * message popups
- * HIG 2.0 compliance
-
-WWW: http://www.nongnu.org/mailnotify/
diff --git a/mail/mail-notification/pkg-plist b/mail/mail-notification/pkg-plist
deleted file mode 100644
index 7dc4013b6554..000000000000
--- a/mail/mail-notification/pkg-plist
+++ /dev/null
@@ -1,36 +0,0 @@
-bin/mail-notification
-etc/xdg/autostart/mail-notification.desktop
-share/applications/mail-notification-properties.desktop
-share/gnome/help/mail-notification/C/documentation-license.xml
-share/gnome/help/mail-notification/C/figures/mail.png
-share/gnome/help/mail-notification/C/mail-notification.xml
-share/gnome/help/mail-notification/C/software-license.xml
-%%GMAIL%%%%DATADIR%%/gmail.png
-%%DATADIR%%/logo.png
-%%DATADIR%%/new-mail.wav
-%%DATADIR%%/mailbox-properties-dialog.glade
-%%DATADIR%%/properties-dialog.glade
-share/omf/mail-notification/mail-notification-C.omf
-share/icons/hicolor/16x16/apps/mail-notification.png
-share/icons/hicolor/22x22/apps/mail-notification.png
-share/icons/hicolor/24x24/apps/mail-notification.png
-share/icons/hicolor/32x32/apps/mail-notification.png
-share/icons/hicolor/48x48/apps/mail-notification.png
-share/icons/hicolor/scalable/apps/mail-notification.svg
-share/locale/bg/LC_MESSAGES/mail-notification.mo
-share/locale/ca/LC_MESSAGES/mail-notification.mo
-share/locale/cs/LC_MESSAGES/mail-notification.mo
-share/locale/de/LC_MESSAGES/mail-notification.mo
-share/locale/es/LC_MESSAGES/mail-notification.mo
-share/locale/fr/LC_MESSAGES/mail-notification.mo
-share/locale/ja/LC_MESSAGES/mail-notification.mo
-share/locale/nl/LC_MESSAGES/mail-notification.mo
-share/locale/pl/LC_MESSAGES/mail-notification.mo
-share/locale/pt/LC_MESSAGES/mail-notification.mo
-share/locale/pt_BR/LC_MESSAGES/mail-notification.mo
-share/locale/ru/LC_MESSAGES/mail-notification.mo
-share/locale/sr/LC_MESSAGES/mail-notification.mo
-share/locale/sr@Latn/LC_MESSAGES/mail-notification.mo
-share/locale/sv/LC_MESSAGES/mail-notification.mo
-%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/liborg-jylefort-mail-notification.so
-%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/org-jylefort-mail-notification.eplug