aboutsummaryrefslogtreecommitdiff
path: root/mail/mail2sms
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-05-01 15:37:58 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-05-01 15:37:58 +0000
commit43af38e7a4913b703257adb575be8300345540ad (patch)
tree8b212272dd132a6a3efe58eeb950a55c2c4197ca /mail/mail2sms
parentdccaaa91de3e97ea07d2cabe6daa82b408b1db17 (diff)
downloadports-43af38e7a4913b703257adb575be8300345540ad.tar.gz
ports-43af38e7a4913b703257adb575be8300345540ad.zip
Notes
Diffstat (limited to 'mail/mail2sms')
-rw-r--r--mail/mail2sms/Makefile36
-rw-r--r--mail/mail2sms/distinfo1
-rw-r--r--mail/mail2sms/files/patch-aa70
-rw-r--r--mail/mail2sms/pkg-descr6
-rw-r--r--mail/mail2sms/pkg-plist5
5 files changed, 118 insertions, 0 deletions
diff --git a/mail/mail2sms/Makefile b/mail/mail2sms/Makefile
new file mode 100644
index 000000000000..ccfaa72023ca
--- /dev/null
+++ b/mail/mail2sms/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mail2sms
+# Date created: 2003-04-16
+# Whom: Gerhard Gonter <g.gonter@ieee.org>
+#
+# $FreeBSD$
+
+PORTNAME= mail2sms
+PORTVERSION= 1.3.5
+CATEGORIES= mail
+MASTER_SITES= http://www.contactor.se/~dast/stuff/
+DISTNAME= mail2sms-${PORTVERSION}
+
+MAINTAINER= g.gonter@ieee.org
+COMMENT= Mail to SMS converter
+
+GNU_CONFIGURE= yes
+
+MAN1= mail2sms.1
+MAN5= mail2sms.5
+
+post-patch:
+ ${CP} ${WRKSRC}/mail2sms.4 ${WRKSRC}/mail2sms.5
+ ${SED} -i.bak -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/mail2sms.5
+ ${SED} -i.bak -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/main.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mail2sms ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/${MAN5} ${PREFIX}/man/man5/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/mail2sms
+ ${INSTALL_MAN} ${WRKSRC}/README ${WRKSRC}/REGEX ${WRKSRC}/example.conf \
+ ${PREFIX}/share/doc/mail2sms
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/mail2sms/distinfo b/mail/mail2sms/distinfo
new file mode 100644
index 000000000000..d0782c2737d1
--- /dev/null
+++ b/mail/mail2sms/distinfo
@@ -0,0 +1 @@
+MD5 (mail2sms-1.3.5.tar.gz) = 6aa360998779bff1d3333c7a762d0e9e
diff --git a/mail/mail2sms/files/patch-aa b/mail/mail2sms/files/patch-aa
new file mode 100644
index 000000000000..a40c6e5cea6d
--- /dev/null
+++ b/mail/mail2sms/files/patch-aa
@@ -0,0 +1,70 @@
+--- main.c.orig Wed Apr 16 05:11:21 2003
++++ main.c Wed Apr 16 05:12:16 2003
+@@ -18,7 +18,7 @@
+ #ifdef AFS
+ #define CONFIGDIR "/var/mail2sms/"
+ #else
+-#define GLOBAL_CONFIG "/etc/mail/sms/mail2sms.conf"
++#define GLOBAL_CONFIG "%%PREFIX%%/etc/mail2sms.conf"
+ #endif
+
+ extern FILE *logfile; /* write logs to this file pointer */
+--- parse.c.orig Wed Apr 16 05:06:23 2003
++++ parse.c Wed Apr 16 05:45:31 2003
+@@ -48,8 +48,9 @@
+ /*
+ ** strcasestr() - case insensitive strstr()
+ */
+-
+-char *strcasestr(char *haystack, char *needle)
++
++/* FreeBSD defines this function a bit differently, so rename this version */
++char *mail2sms_strcasestr(char *haystack, char *needle)
+ {
+ int nlen = strlen(needle);
+ int hlen = strlen(haystack);
+--- mail2sms.1.orig Wed Apr 16 05:22:01 2003
++++ mail2sms.1 Wed Apr 16 05:22:57 2003
+@@ -32,7 +32,7 @@
+ .IP "-v"
+ Shows mail2sms' version number then quits.
+ .SH AUTHORS
+-mail2sms has been written by Daniel Stenberg <daniel@haxx.se> with lofs of
++mail2sms has been written by Daniel Stenberg <daniel@haxx.se> with lots of
+ help from friendly contributors, such as:
+
+ - Linus Nielsen <linus@haxx.se>
+@@ -48,4 +48,4 @@
+ .SH WWW
+ http://www.contactor.se/~dast/mail2sms/
+ .SH "SEE ALSO"
+-.BR mail2sms (4)
++.BR mail2sms (5)
+--- mail2sms.4.orig Wed Apr 16 05:11:35 2003
++++ mail2sms.4 Wed Apr 16 06:03:10 2003
+@@ -1,12 +1,12 @@
+ .\" You can view this file with:
+-.\" nroff -man mail2sms.4
++.\" nroff -man mail2sms.5
+ .\" Written by Daniel Stenberg
+ .\"
+-.TH mail2sms 4 "11 October 1999"
++.TH mail2sms 5 "11 October 1999"
+ .SH NAME
+ mail2sms \- reads a (MIME) mail and converts it to a short message.
+ .SH SYNOPSIS
+-.B /etc/mail/sms/mail2sms.conf
++.B %%PREFIX%%/etc/mail2sms.conf
+ .br
+ .B ~/.mail2sms
+ .SH DESCRIPTION
+@@ -67,7 +67,7 @@
+ http://www.contactor.se/~dast/mail2sms/
+ .SH "SEE ALSO"
+ .BR mail2sms (1),
+-.BR sendmail (1M),
++.BR sendmail (8),
+ .BR procmail (1),
+-.BR aliases (4)
++.BR aliases (5)
+
diff --git a/mail/mail2sms/pkg-descr b/mail/mail2sms/pkg-descr
new file mode 100644
index 000000000000..44e50db32e9a
--- /dev/null
+++ b/mail/mail2sms/pkg-descr
@@ -0,0 +1,6 @@
+mail2sms converts a single (large) mail to a tiny text with contents
+from the mail. Perfectly suitable to send as an SMS message to a
+GSM telephone.
+
+WWW: http://www.contactor.se/~dast/mail2sms/
+WWW: http://sourceforge.net/projects/mail2sms/
diff --git a/mail/mail2sms/pkg-plist b/mail/mail2sms/pkg-plist
new file mode 100644
index 000000000000..daf6c66f7d5d
--- /dev/null
+++ b/mail/mail2sms/pkg-plist
@@ -0,0 +1,5 @@
+bin/mail2sms
+%%PORTDOCS%%share/doc/mail2sms/README
+%%PORTDOCS%%share/doc/mail2sms/REGEX
+%%PORTDOCS%%share/doc/mail2sms/example.conf
+%%PORTDOCS%%@dirrm share/doc/mail2sms