aboutsummaryrefslogtreecommitdiff
path: root/mail/maildrop/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2006-05-02 22:54:36 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2006-05-02 22:54:36 +0000
commit0ea2a0b745c941b00cc256820c32b8be1bf79817 (patch)
tree0745b952fc6e48df27fda6d0d0a140563738f217 /mail/maildrop/Makefile
parent97425524854488589634b26832346e2e7c5ce465 (diff)
downloadports-0ea2a0b745c941b00cc256820c32b8be1bf79817.tar.gz
ports-0ea2a0b745c941b00cc256820c32b8be1bf79817.zip
Notes
Diffstat (limited to 'mail/maildrop/Makefile')
-rw-r--r--mail/maildrop/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index 5e2f0a3c554b..52b138ce75e9 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -6,6 +6,8 @@
#
# The following compile-time options are available:
+# WITH_AUTHLIB=yes Enable optional support for Courier Auth Library
+# WITH_FAM=yes Enable optional support for File Alteration Monitor
# WITH_GDBM=yes Enable database extensions using GDBM (default: off)
# MAILDROP_SUID=<uid>,
# MAILDROP_SGID=<gid> Maildrop will be installed with suid permissions for
@@ -13,10 +15,9 @@
# MAILDROP_TRUSTED_USERS=<user> Specify users allowed to use the -d option
# NO_MAILWRAPPER=yes If defined, let configure guess which sendmail binary
# to use
-# WITH_AUTHLIB=yes Enable optional support for Courier Auth Library
PORTNAME= maildrop
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= courier
@@ -24,6 +25,8 @@ MASTER_SITE_SUBDIR= courier
MAINTAINER= sergei@FreeBSD.org
COMMENT= Mail delivery agent (MDA) with filtering abilities
+USE_GPG= yes
+SIG_SUFFIX= .sig
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
@@ -69,8 +72,8 @@ CONFIGURE_ARGS+= --enable-maildrop-gid="${MAILDROP_SGID}"
CONFIGURE_ARGS+= --enable-sendmail=/usr/sbin/sendmail
.endif
-.if exists(${LOCALBASE}/lib/libfam.so.0)
-LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
+.if defined(WITH_FAM) || exists(${LOCALBASE}/lib/libfam.so.0)
+USE_FAM= yes
.endif
.if defined(MAILDROP_TRUSTED_USERS)
@@ -83,7 +86,6 @@ CONFIGURE_ARGS+= --enable-trusted-users="${MAILDROP_TRUSTED_USERS}"
.endif
BUILD_DEPENDS+= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS+= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
-USE_REINPLACE= yes
CONFIGURE_ARGS+= --enable-authlib
post-patch:
@@ -110,6 +112,8 @@ DOCS= AUTHORS INSTALL INSTALL.html README README.html README.postfix \
UPGRADE UPGRADE.html maildroptips.txt maildir/README.*
post-install:
+ ${INSTALL_DATA} ${WRKSRC}/maildir/quotawarnmsg \
+ ${PREFIX}/etc/quotawarnmsg.sample
.if !defined(NOPORTDOCS)
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif