aboutsummaryrefslogtreecommitdiff
path: root/mail/maildrop/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-02-21 21:39:34 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-02-21 21:39:34 +0000
commit7390d550df439469b939ac386790276dda6e4dc7 (patch)
treea3f8f9528a3f107b107848b64cf81372a850fb17 /mail/maildrop/Makefile
parent9f1ffed4ccc159ab2d1120ce0652b7ea19a97d6a (diff)
Notes
Diffstat (limited to 'mail/maildrop/Makefile')
-rw-r--r--mail/maildrop/Makefile28
1 files changed, 8 insertions, 20 deletions
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index 70d724478dd6..695507884f8e 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= maildrop
-PORTVERSION= 0.64
+PORTVERSION= 1.3.0
CATEGORIES= mail
-MASTER_SITES= http://www.flounder.net/~mrsam/maildrop/ \
- ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= system/mail/mailhandlers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= courier
MAINTAINER= tom@eborcom.com
@@ -21,7 +20,7 @@ MAINTAINER= tom@eborcom.com
BUILD_DEPENDS= ${LOCALBASE}/lib/libgdbm.a:${PORTSDIR}/databases/gdbm
.endif
-ALL_TARGET= config.h xconfig.h all
+ALL_TARGET= all
INSTALL_TARGET= install-strip
# Maildrop will be installed with suid permissions for MAILDROP_SUID,
@@ -42,26 +41,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" \
GNU_CONFIGURE= yes
.if defined(NOPORTDOCS)
-INSTALL_TARGET= install-exec all
+INSTALL_TARGET= install-maildrop install-man
.else
-MAN1= dotlock.1 maildrop.1 maildrop.makegdbm.1 reformail.1 reformime.1
+MAN1= dotlock.1 maildirmake.1 maildrop.1 makemime.1 reformail.1 reformime.1
MAN5= maildropex.5 maildropfilter.5 maildropgdbm.5
-MANCOMPRESSED= yes
+MAN8= maildirquota.8 deliverquota.8
.endif
.if defined(NO_GDBM)
-CONFIGURE_ARGS+= --without-gdbm
-.endif
-
-PLIST= ${WRKDIR}/PLIST
-
-post-patch:
- @${CP} ${PKGDIR}/pkg-plist ${PLIST}
-.if !defined(NO_GDBM)
- @${CAT} ${PKGDIR}/pkg-plist.gdbm >> ${PLIST}
-.endif
-.if !defined(NOPORTDOCS)
- @${CAT} ${PKGDIR}/pkg-plist.docs >> ${PLIST}
+CONFIGURE_ARGS+= --without-db
.endif
.include <bsd.port.mk>