aboutsummaryrefslogtreecommitdiff
path: root/mail/mailest
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2016-11-04 19:06:56 +0000
committerHiroki Sato <hrs@FreeBSD.org>2016-11-04 19:06:56 +0000
commitf1197dbcac2e8e8995157d05f9d9361b593b906a (patch)
tree1a658b54a3d4b6f837e667a33a4edf2576edaad7 /mail/mailest
parentbcb8f7277cd1395949cca42303ef43674171ab05 (diff)
downloadports-f1197dbcac2e8e8995157d05f9d9361b593b906a.tar.gz
ports-f1197dbcac2e8e8995157d05f9d9361b593b906a.zip
Notes
Diffstat (limited to 'mail/mailest')
-rw-r--r--mail/mailest/Makefile3
-rw-r--r--mail/mailest/distinfo5
-rw-r--r--mail/mailest/files/patch-mailestd-Makefile33
-rw-r--r--mail/mailest/files/patch-mailestd.c47
4 files changed, 21 insertions, 67 deletions
diff --git a/mail/mailest/Makefile b/mail/mailest/Makefile
index e2a10e638d6a..eadf968ec782 100644
--- a/mail/mailest/Makefile
+++ b/mail/mailest/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= mailest
-PORTVERSION= 0.9.20
+PORTVERSION= 0.9.22
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 1
CATEGORIES= mail
MAINTAINER= hrs@FreeBSD.org
diff --git a/mail/mailest/distinfo b/mail/mailest/distinfo
index 0181d457fcd3..0d9f13469553 100644
--- a/mail/mailest/distinfo
+++ b/mail/mailest/distinfo
@@ -1,2 +1,3 @@
-SHA256 (yasuoka-mailest-mailest-0.9.20_GH0.tar.gz) = f51cde2047422c993425eee8102e5f7a914094b60a1a039a0b84502e5d22c5f8
-SIZE (yasuoka-mailest-mailest-0.9.20_GH0.tar.gz) = 171958
+TIMESTAMP = 1473036362
+SHA256 (yasuoka-mailest-mailest-0.9.22_GH0.tar.gz) = 38979dd2ed5dee6e03c392721e113233959a4a2c558702340a326c632e6bdd70
+SIZE (yasuoka-mailest-mailest-0.9.22_GH0.tar.gz) = 172305
diff --git a/mail/mailest/files/patch-mailestd-Makefile b/mail/mailest/files/patch-mailestd-Makefile
index 0de943750c62..e4a003a8f86f 100644
--- a/mail/mailest/files/patch-mailestd-Makefile
+++ b/mail/mailest/files/patch-mailestd-Makefile
@@ -1,28 +1,29 @@
---- mailestd/Makefile.orig 2015-06-06 10:45:32 UTC
-+++ mailestd/Makefile
-@@ -2,9 +2,9 @@ MAILESTD_MT= #
+--- mailestd/Makefile.orig 2016-09-02 20:16:03.000000000 +0900
++++ mailestd/Makefile 2016-09-05 13:12:14.868757000 +0900
+@@ -1,10 +1,8 @@
+ MAILESTD_MT= #
+-.include <bsd.obj.mk>
+-
PROG= mailestd
SRCS= bytebuf.c mailestd.c mailestctl.c parse.y parser.c
-LINKS= ${BINDIR}/mailestd ${LOCALBASE}/bin/mailestctl
-+LINKS= ${BINDIR}/${PROG} ${BINDIR}/mailestctl
++LINKS= ${BINDIR}/mailestd ${BINDIR}/mailestctl
CFLAGS+= -DHAVE_LIBESTDRAFT -DMONITOR_KQUEUE
--LIBESTDRAFTOBJ!=cd ${.CURDIR}/../libestdraft; ${MAKE} _whereobj
-+LIBESTDRAFTOBJ!=cd ${.CURDIR}/../libestdraft; ${MAKE} -V.OBJDIR
- LDFLAGS= -L${LOCALBASE}/lib
- LDADD= -lestraier -levent -lqdbm
- DPADD= ${LIBESTRAIER} ${LIBEVENT} ${LIBQDBM}
-@@ -21,13 +21,7 @@ LDADD+= -lpthread
+ .if defined(__objdir) && exists(${.CURDIR}/../libestdraft/${__objdir})
+ LIBESTDRAFTOBJ= ${.CURDIR}/../libestdraft/${__objdir}
+@@ -27,13 +25,14 @@
DPADD+= ${LIBPTHREAD}
.endif
-beforeinstall:
-- ${INSTALL} ${INSTALL_COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
-- ${.CURDIR}/../mew-mailest.sh ${PREFIX}/bin/mew-mailest
-- ${INSTALL} ${INSTALL_COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
-- ${.CURDIR}/../cmew-mailest.sh ${PREFIX}/bin/cmew-mailest
-- ${INSTALL} ${INSTALL_COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
-- ${.CURDIR}/../smew-mailest.sh ${PREFIX}/bin/smew-mailest
++X-beforeinstall:
+ ${INSTALL} ${INSTALL_COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
+ ${.CURDIR}/../mew-mailest.sh ${PREFIX}/bin/mew-mailest
+ ${INSTALL} ${INSTALL_COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
+ ${.CURDIR}/../cmew-mailest.sh ${PREFIX}/bin/cmew-mailest
+ ${INSTALL} ${INSTALL_COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
+ ${.CURDIR}/../smew-mailest.sh ${PREFIX}/bin/smew-mailest
+SCRIPTS= mew-mailest.sh cmew-mailest.sh smew-mailest.sh
LDFLAGS+= -L${LIBESTDRAFTOBJ}
diff --git a/mail/mailest/files/patch-mailestd.c b/mail/mailest/files/patch-mailestd.c
deleted file mode 100644
index 4766928d0f99..000000000000
--- a/mail/mailest/files/patch-mailestd.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- mailestd.c.orig 2015-06-06 10:45:32 UTC
-+++ mailestd.c
-@@ -809,8 +809,6 @@ mailestd_gather(struct mailestd *_this,
-
- RB_INIT(&folders);
- ctx = mailestd_get_gather(_this, task->gather_id);
-- mailestd_log(LOG_DEBUG, "Gathering %s ...", mailestd_folder_name(
-- _this, folder, buf, sizeof(buf)));
- if (folder[0] == '/')
- strlcpy(rdir, folder, sizeof(rdir));
- else {
-@@ -818,6 +816,8 @@ mailestd_gather(struct mailestd *_this,
- strlcat(rdir, "/", sizeof(rdir));
- strlcat(rdir, folder, sizeof(rdir));
- }
-+ mailestd_log(LOG_DEBUG, "Gathering %s ...", mailestd_folder_name(
-+ _this, rdir, buf, sizeof(buf)));
- paths[0] = rdir;
- paths[1] = NULL;
- lrdir = strlen(rdir);
-@@ -853,7 +853,7 @@ mailestd_gather(struct mailestd *_this,
- }
-
- mailestd_log(LOG_DEBUG, "Gathered %s (Total: %d Remove: %d Update: %d)",
-- mailestd_folder_name(_this, folder, buf, sizeof(buf)),
-+ mailestd_folder_name(_this, rdir, buf, sizeof(buf)),
- total, delete, update);
- out:
- if (ctx != NULL) {
-@@ -2647,6 +2647,7 @@ static void
- mailestd_monitor_folder(struct mailestd *_this, const char *dirpath)
- {
- int fd = -1;
-+ char buf[PATH_MAX];
- struct folder *fld, fld0;
-
- MAILESTD_ASSERT(_thread_self() == _this->monitorworker.thread);
-@@ -2668,7 +2669,8 @@ mailestd_monitor_folder(struct mailestd
- fld->fd = fd;
- fld->path = xstrdup(dirpath);
- RB_INSERT(folder_tree, &_this->monitors, fld);
-- mailestd_log(LOG_DEBUG, "Start monitoring %s", dirpath);
-+ mailestd_log(LOG_DEBUG, "Start monitoring %s",
-+ mailestd_folder_name(_this, dirpath, buf, sizeof(buf)));
- }
-
- static void