aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-12-16 09:19:13 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-12-16 09:19:13 +0000
commit13dc720f4987fb2b4bd733e9f426a3990835ed15 (patch)
treea751452f634858cce2a593c38c8d3d17e0076e54 /mail/mailman/Makefile
parent5a3e63509d0684c94e811e40d2018b454f09ab7d (diff)
downloadports-13dc720f4987fb2b4bd733e9f426a3990835ed15.tar.gz
ports-13dc720f4987fb2b4bd733e9f426a3990835ed15.zip
Notes
Diffstat (limited to 'mail/mailman/Makefile')
-rw-r--r--mail/mailman/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 42da41de8b6b..3a7484f3aefb 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -20,17 +20,16 @@ EXTRACT_SUFX= .tgz
DIST_SUBDIR= mailman
.if defined(WITH_HTDIG)
-## this may be broken with mailman 2.1.6 -- someone send patches to $MAINTAINER
# see http://www.openinfo.co.uk/mailman/index.html
# Order of application of these patches is critical.
-PATCHFILES+= indexing-2.1.4-0.1.patch.gz:patch1 \
- htdig-2.1.4-0.1.patch.gz:patch2
+PATCHFILES+= indexing-2.1.6-0.1.patch.gz:patch1 \
+ htdig-2.1.6-0.1.patch.gz:patch2
PATCH_DIST_STRIP= -p1
-PATCH_SITES+= http://www.openinfo.co.uk/mailman/patches/444879/:patch1 \
- http://www.openinfo.co.uk/mailman/patches/444884/:patch2
+PATCH_SITES+= http://www.openinfo.co.uk/mm/patches/444879/:patch1 \
+ http://www.openinfo.co.uk/mm/patches/444884/:patch2
.endif
-MAINTAINER?= vivek@khera.org
+MAINTAINER?= ports@freebsd.org
COMMENT?= A mailing list manager (MLM) with a user-friendly web front-end
RUN_DEPENDS= lynx:${PORTSDIR}/www/lynx
@@ -72,7 +71,7 @@ MAIL_GID?= mailnull
MAIL_GID?= daemon
.endif
CGI_GID?= www
-IMGDIR= www/icons
+IMGDIR?= www/icons
#
# End of user-configurable variables.
@@ -133,7 +132,7 @@ post-configure:
# port system auditors complain if dir is created prior to install
# but configure demands it be there. we delete it now if empty,
# so it will be re-created. For existing installs, this is ignored
- @- rmdir ${MAILMANDIR} 2> /dev/null
+ @- ${RMDIR} ${MAILMANDIR} 2> /dev/null
pre-install:
@ ${SH} ${PKGREQ} INSTALL