aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman/Makefile
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2002-02-08 14:04:37 +0000
committerJohann Visagie <wjv@FreeBSD.org>2002-02-08 14:04:37 +0000
commitd2b58a6c5c170c5c80f102b81119137743070b2c (patch)
tree1b0d508aaf8561042380d63a5e0f2088b81a5fbb /mail/mailman/Makefile
parentd53fafc9a952a5871edd153081d9f1003d1c9222 (diff)
downloadports-d2b58a6c5c170c5c80f102b81119137743070b2c.tar.gz
ports-d2b58a6c5c170c5c80f102b81119137743070b2c.zip
Notes
Diffstat (limited to 'mail/mailman/Makefile')
-rw-r--r--mail/mailman/Makefile47
1 files changed, 32 insertions, 15 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index a19cde077ae8..2c6db0ff2391 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mailman
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.list.org/ \
${MASTER_SITE_GNU} \
@@ -24,31 +25,47 @@ CONFIGURE_ARGS= --prefix=${MAILMANDIR} \
--with-mail-gid=${MAIL_GID} --with-cgi-gid=${CGI_GID}
USE_PYTHON= yes
+# These variables may be tweaked if required. However, it is recommended
+# that the USERID and GROUPID not be changed.
+#
USERNAME?= mailman
-USERID?= 89
+USERID?= 91
+GROUPNAME?= ${USERNAME}
+GROUPID?= ${USERID}
+MMDIR?= mailman
-# The default value of '1' for MAIL_GID works with sendmail. If you're
-# using installed from ports, you should set MAIL_GID at build time
-# according to the following table:
+# The default value of '1' for MAIL_GID works with sendmail. If you're using
+# an alternative MTA installed from ports, you should set MAIL_GID at build
+# time according to the following table. (Please contact this port's
+# maintainer if you can fill in the blanks!)
+#
+# MTA | MAIL_GID
+# Exim | 6
+# Postfix | ???
+# Qmail | ???
#
-# MTA | MAIL_GID
-# Exim | 6
-# Postfix | ???
-
MAIL_GID?= 1
CGI_GID?= 80
-MMDIR?= mailman
+
MAILMANDIR= ${PREFIX}/${MMDIR}
PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGINSTALL= ${WRKDIR}/pkg-install
+PLIST_SUB= MMDIR=${MMDIR}
pre-configure:
- # Add the username, uid, group and gid
- ${SH} ${FILESDIR}/configure.sh ${USERNAME} ${USERID} ${MAILMANDIR}
+# Add the username, uid, group and gid
+# ${SH} ${FILESDIR}/configure.sh ${USERNAME} ${USERID} ${MAILMANDIR}
+
+ @ ${SED} -e 's#%%USER%%#${USERNAME}#g' -e 's#%%UID%%#${USERID}#g' \
+ -e 's#%%GROUP%%#${GROUPNAME}#g' -e 's#%%GID%%#${GROUPID}#g' \
+ -e 's#%%MAILMANDIR%%#${MAILMANDIR}#g' pkg-install > \
+ ${PKGINSTALL}
+ @ ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
- # Create the dir and the correct permissions for it.
- ${MKDIR} ${MAILMANDIR}
- ${CHOWN} ${USERNAME}:${USERNAME} ${MAILMANDIR}
- ${CHMOD} 2775 ${MAILMANDIR}
+# Create the dir and the correct permissions for it.
+#${MKDIR} ${MAILMANDIR}
+#${CHOWN} ${USERNAME}:${USERNAME} ${MAILMANDIR}
+#${CHMOD} 2775 ${MAILMANDIR}
post-configure:
@ ${SED} -e 's#%%MAILMANDIR%%#${MAILMANDIR}#g' \