aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-08-29 22:58:07 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-08-29 22:58:07 +0000
commit854b45ea77163a4c90018afbe8da286c269aa1ac (patch)
tree594a98f962c2e142165a6c328e58bd434f4be57a /mail/mailman
parentcedda4da28db540328ae921a4c14d14c201d677e (diff)
downloadports-854b45ea77163a4c90018afbe8da286c269aa1ac.tar.gz
ports-854b45ea77163a4c90018afbe8da286c269aa1ac.zip
Notes
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile68
-rw-r--r--mail/mailman/distinfo8
-rw-r--r--mail/mailman/files/FreeBSD-post-install-notes18
-rw-r--r--mail/mailman/files/mailman.in14
-rw-r--r--mail/mailman/files/patch-Mailman__Cgi__confirm.py29
-rw-r--r--mail/mailman/files/pkg-message.in19
-rw-r--r--mail/mailman/files/postfix-verp.diff10
-rw-r--r--mail/mailman/pkg-descr2
-rw-r--r--mail/mailman/pkg-plist171
9 files changed, 196 insertions, 143 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 89e5d7f1ded2..256889f4cc74 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -2,17 +2,17 @@
# $FreeBSD$
PORTNAME= mailman
-DISTVERSION= 2.1.14
-PORTREVISION= 6
+DISTVERSION= 2.1.15
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_GNU} \
- SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION}
+ SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
+ https://launchpad.net/mailman/${DISTVERSION:R}/${DISTVERSION}/+download/
MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= mailman
MAINTAINER= mandree@FreeBSD.org
-COMMENT= Mailing list manager (MLM) with a user-friendly web front-end
+COMMENT= Mailing list manager with user-friendly web front-end
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/gnu-COPYING-GPL
@@ -61,18 +61,17 @@ PORTDOCS= ACKNOWLEDGMENTS BUGS FAQ INSTALL NEWS README README-I18N.en \
mailman-member.txt \
FreeBSD-post-install-notes
-OPTIONS_RADIO= MTA
-OPTIONS_RADIO_MTA= SENDMAIL EXIM3 EXIM4 POSTFIX COURIER
-OPTIONS_DEFINE= HTDIG INTEGRATION NAMAZU2 NLS DOCS
+OPTIONS_SINGLE= MTA
+OPTIONS_SINGLE_MTA= SENDMAIL EXIM4 POSTFIX COURIER
+OPTIONS_DEFINE= HTDIG NAMAZU2 NLS DOCS
+OPTIONS_DEFAULT= SENDMAIL
SENDMAIL_DESC= for use with sendmail
-EXIM3_DESC= for use with exim3
EXIM4_DESC= for use with exim4
POSTFIX_DESC= for use with postfix
-COURIER_DESC= fr use with courier
-HTDIG_DESC= htdig integration patches
-INTEGRATION_DESC= integrating postfix and mailman
-NAMAZU2_DESC= make private archives searchable with namazu2
-MTA_DESC= integrate with an MTA
+COURIER_DESC= for use with courier
+HTDIG_DESC= - EXPERIMENTAL - htdig integration patches
+NAMAZU2_DESC= Make private archives searchable with namazu2
+MTA_DESC= Integrate with which MTA?
.include <bsd.port.options.mk>
@@ -81,26 +80,21 @@ USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
+MAKE_ARGS+= LANGUAGES=en
.endif
.if ${PORT_OPTIONS:MSENDMAIL}
MAIL_GID?= mailnull
.endif
-.if ${PORT_OPTIONS:MEXIM3}
-MAIL_GID?= nobody
-.endif
-
.if ${PORT_OPTIONS:MEXIM4}
MAIL_GID?= mail
.endif
.if ${PORT_OPTIONS:MPOSTFIX}
-.if ${PORT_OPTIONS:MINTEGRATION}
+RUN_DEPENDS+= ${LOCALBASE}/sbin/postconf:${PORTSDIR}/mail/postfix
+BUILD_DEPENDS+= ${LOCALBASE}/sbin/postconf:${PORTSDIR}/mail/postfix
MAIL_GID?= mailman
-.else
-MAIL_GID?= nobody
-.endif
EXTRA_PATCHES+= ${FILESDIR}/postfix-verp.diff
.endif
@@ -109,11 +103,10 @@ MAIL_GID?= courier
.endif
.if ${PORT_OPTIONS:MHTDIG}
-BROKEN= the HTDIG option is currently broken
PATCH_SITES+= http://www.openinfo.co.uk/mm/patches/444879/:patch1 \
http://www.openinfo.co.uk/mm/patches/444884/:patch2
-PATCHFILES+= indexing-${DISTVERSION}-0.1.patch.gz:patch1 \
- htdig-${DISTVERSION}-0.1.patch.gz:patch2
+PATCHFILES+= indexing-2.1.12-0.1.patch.gz:patch1 \
+ htdig-2.1.12-0.1.patch.gz:patch2
PATCH_DIST_STRIP= -p1
PKGNAMESUFFIX+= -with-htdig
RUN_DEPENDS+= htdig:${PORTSDIR}/textproc/htdig
@@ -127,16 +120,22 @@ RUN_DEPENDS+= mknmz:${PORTSDIR}/databases/namazu2
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Mailman-Cgi-private.py
.endif
-pre-fetch:
+pre-everything::
@${ECHO} ""
@${ECHO} "You may change the following build options:"
- @${ECHO} "MM_USERNAME=mailman The username of the Mailman user."
- @${ECHO} "MM_USERID=91 The user ID of the Mailman user."
- @${ECHO} "MM_GROUPNAME=mailman The group to which the Mailman user will belong."
- @${ECHO} "MM_GROUPID=MM_USERID The group ID for the Mailman user."
- @${ECHO} "MM_DIR=mailman Mailman will be installed in ${PREFIX}/${MM_DIR}."
- @${ECHO} "CGI_GID=www The group name or id under which your web server executes CGI scripts."
- @${ECHO} "IMGDIR=www/icons Icon images will be installed in ${PREFIX}/${IMGDIR}."
+ @${ECHO} ""
+ @${ECHO} "Option Default Value Description"
+ @${ECHO} "------------- --------------- ------------------------------------------------"
+ @${ECHO} "MM_USERNAME mailman The username of the Mailman user."
+ @${ECHO} "MM_USERID 91 The user ID of the Mailman user."
+ @${ECHO} "MM_GROUPNAME mailman The group to which the Mailman user will belong."
+ @${ECHO} "MM_GROUPID \$$MM_USERID The group ID for the Mailman user."
+ @${ECHO} "MM_DIR mailman Mailman will be installed in"
+ @${ECHO} " ${PREFIX}/${MM_DIR}."
+ @${ECHO} "CGI_GID www The group name or id under which your web"
+ @${ECHO} " server executes CGI scripts."
+ @${ECHO} "IMGDIR www/icons Icon images will be installed in""
+ @${ECHO} " ${PREFIX}/${IMGDIR}."
@${ECHO} ""
post-patch:
@@ -145,10 +144,9 @@ post-patch:
@${REINPLACE_CMD} -e 's/^0,5,10/#&/' ${WRKSRC}/cron/crontab.in.in
.if empty(PORT_OPTIONS:MNLS)
@${REINPLACE_CMD} -e 's/messages//' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's/templates//' ${WRKSRC}/Makefile.in
.endif
-.if ${PORT_OPTIONS:MPOSTFIX} && !empty(PORT_OPTIONS:MINTEGRATION)
+.if ${PORT_OPTIONS:MPOSTFIX}
pre-configure:
@${ECHO} "MTA = 'Postfix'" >> ${WRKSRC}/Mailman/mm_cfg.py.dist.in
.endif
@@ -173,6 +171,8 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
.endif
+ @${MKDIR} ${PYTHON_SITELIBDIR}
+ @${ECHO} "This marker file ensures that Python's upgrade-site-packages works." >${PYTHON_SITELIBDIR}/mailman-info.txt
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.if ${PORT_OPTIONS:MPOSTFIX}
diff --git a/mail/mailman/distinfo b/mail/mailman/distinfo
index e82923a07e6f..7921c8ea8c3f 100644
--- a/mail/mailman/distinfo
+++ b/mail/mailman/distinfo
@@ -1,2 +1,6 @@
-SHA256 (mailman/mailman-2.1.14.tgz) = 1d6be802b718639126c4069eb7f9cd3a347765e1cb199cc3bb14d71572d09523
-SIZE (mailman/mailman-2.1.14.tgz) = 8201150
+SHA256 (mailman/mailman-2.1.15.tgz) = f355fb3d31772b488449e6f5173dafd31edca93172c307244c791d25d9e2bec8
+SIZE (mailman/mailman-2.1.15.tgz) = 8468107
+SHA256 (mailman/indexing-2.1.12-0.1.patch.gz) = c9bb8398695d79bbaa1079063d8327f4b7208a1f3cde7766d2f39390da1d820e
+SIZE (mailman/indexing-2.1.12-0.1.patch.gz) = 8178
+SHA256 (mailman/htdig-2.1.12-0.1.patch.gz) = 4675fafe1ba978ec8ebfeb9306363d3ee0468bdbb32f204267ab54e0f15057d4
+SIZE (mailman/htdig-2.1.12-0.1.patch.gz) = 61296
diff --git a/mail/mailman/files/FreeBSD-post-install-notes b/mail/mailman/files/FreeBSD-post-install-notes
index 5e5c2cbf8bc6..c8f0ee7bfe34 100644
--- a/mail/mailman/files/FreeBSD-post-install-notes
+++ b/mail/mailman/files/FreeBSD-post-install-notes
@@ -21,6 +21,7 @@ VERY IMPORTANT NOTE
The Mailman port has a number of build time options. Getting the values of
some of these right is CRUCIAL if you want your Mailman installation to work!
+
1) General post-installation instructions
You should find two files named "INSTALL" and "README" in the same
@@ -37,7 +38,7 @@ some of these right is CRUCIAL if you want your Mailman installation to work!
Mailman port works well with either Apache 1.3.x or Apache 2.x as
installed from their respective ports (www/apache13 and www/apache2).
- If you're using Apache, you need to add at least two lines to your
+ If you are using Apache, you need to add at least two lines to your
httpd.conf. Assuming that you installed the Mailman port in the default
location (/usr/local/mailman), they are:
@@ -86,10 +87,6 @@ some of these right is CRUCIAL if you want your Mailman installation to work!
exim_user = mailnull
exim_group = mail
- For Exim 3.x, the value of MAIL_GID has to be set to 'nobody' (or 65534)
- when building the Mailman port, so you have to choose EXIM3 on build options
- to set it to you.
-
For Exim 4.x, the value of MAIL_GID has to be set to 'mail' (or 6) when
building the Mailman port, so you have to choose EXIM4 on build options to
set it to you.
@@ -117,8 +114,8 @@ some of these right is CRUCIAL if you want your Mailman installation to work!
# /usr/local/etc/rc.d/mailman start
Troubleshooting: If you ever see an error message such as the following
- in your Exim's mainlog, it's a sure sign that Exim and Mailman disagree
- about the GID under which mail is delivered:
+ in your Exim's mainlog, that is a sure sign that Exim and Mailman
+ disagree about the GID under which mail is delivered:
** testlist@your.host.com R=mailman_router T=mailman_transport:
Child process of mailman_transport transport returned 2 from command:
@@ -152,10 +149,11 @@ some of these right is CRUCIAL if you want your Mailman installation to work!
Mailman port with Qmail. Please submit any such information to the
maintainer of the Mailman port.
+
4) Apache configuration
- You should add the follow lines in you httpd.conf to mailman interface
- works correctly:
+ You should add the follow lines to your httpd.conf so
+ that the mailman interface works correctly:
<Directory "/usr/local/mailman">
Options FollowSymLinks ExecCGI
@@ -169,4 +167,4 @@ some of these right is CRUCIAL if you want your Mailman installation to work!
# apachectl restart.
-- Jean Milanez Melo <jmelo@FreeBSD.org>
- (Mailman port maintainer)
+ (former Mailman port maintainer)
diff --git a/mail/mailman/files/mailman.in b/mail/mailman/files/mailman.in
index 6efc839a273e..0ac5450c53d4 100644
--- a/mail/mailman/files/mailman.in
+++ b/mail/mailman/files/mailman.in
@@ -23,7 +23,8 @@ load_rc_config $name
start_cmd=${name}_start
stop_cmd=${name}_stop
-extra_commands="reload"
+status_cmd=${name}_status
+extra_commands="reload status"
mailman_start() {
%%MAILMANDIR%%/bin/mailmanctl -s -q start
@@ -35,4 +36,15 @@ mailman_stop() {
|| echo ${name} not running? \(check ${pidfile}\)
}
+mailman_status() {
+ local retcode=0
+ if [ -f $pidfile ] && ps -p $(cat $pidfile) > /dev/null; then
+ echo $name is running as pid $(cat $pidfile).
+ else
+ echo $name is not running.
+ retcode=1
+ fi
+ return $retcode
+}
+
run_rc_command "$1"
diff --git a/mail/mailman/files/patch-Mailman__Cgi__confirm.py b/mail/mailman/files/patch-Mailman__Cgi__confirm.py
deleted file mode 100644
index a3faad2cf7ee..000000000000
--- a/mail/mailman/files/patch-Mailman__Cgi__confirm.py
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./Mailman/Cgi/confirm.py.orig 2010-09-20 14:18:27.000000000 -0400
-+++ ./Mailman/Cgi/confirm.py 2011-03-10 09:33:04.506813466 -0500
-@@ -471,7 +471,7 @@
- if fullname is None:
- fullname = _('<em>Not available</em>')
- else:
-- fullname = Utils.uncanonstr(fullname, lang)
-+ fullname = Utils.websafe(Utils.uncanonstr(fullname, lang))
- table.AddRow([_("""Your confirmation is required in order to complete the
- unsubscription request from the mailing list <em>%(listname)s</em>. You
- are currently subscribed with
-@@ -573,7 +573,7 @@
- if fullname is None:
- fullname = _('<em>Not available</em>')
- else:
-- fullname = Utils.uncanonstr(fullname, lang)
-+ fullname = Utils.websafe(Utils.uncanonstr(fullname, lang))
- if globally:
- globallys = _('globally')
- else:
-@@ -814,7 +814,7 @@
- if username is None:
- username = _('<em>not available</em>')
- else:
-- username = Utils.uncanonstr(username, lang)
-+ username = Utils.websafe(Utils.uncanonstr(username, lang))
-
- table.AddRow([_("""Your membership in the %(realname)s mailing list is
- currently disabled due to excessive bounces. Your confirmation is
diff --git a/mail/mailman/files/pkg-message.in b/mail/mailman/files/pkg-message.in
index 11e07ab4e489..96ccb8d19042 100644
--- a/mail/mailman/files/pkg-message.in
+++ b/mail/mailman/files/pkg-message.in
@@ -7,23 +7,22 @@ extensive post-installation instructions may be found in:
%%DOCSDIR%%/FreeBSD-post-install-notes
-Note (1): If you use an alternate (non-Sendmail) MTA, you MUST be sure
-that the correct value of MAIL_GID was used when this port or package
-was built. Performing a "make config" in the Mailman port directory
-you can choose your MTA with the correct MAIL_GID.
+Note (1): If you use an alternate MTA (meaning "not Sendmail"), you MUST
+be sure that the correct value of MAIL_GID was used when this port or
+package was built. You can choose your MTA with the correct MAIL_GID by
+running "make config" in the Mailman port directory.
-Note (2): The entire Mailman installation resides under %%MAILMANDIR%%
+Note (2): The entire Mailman installation resides under %%MAILMANDIR%%.
The command-line scripts necessary to administer Mailman have been
-installed in %%MAILMANDIR%%/bin
+installed in %%MAILMANDIR%%/bin.
Note (3): As of version 2.1, Mailman's queue runner runs as a daemon and
is started by a script in %%LOCALBASE%%/etc/rc.d
In order to make private archives searchable with namazu2, you need copy
or link %%LOCALBASE%%/libexec/namazu.cgi to
-%%MAILMANDIR%%/archives/private/<ML name>/ and configure .namazurc
+%%MAILMANDIR%%/archives/private/<ML_name>/ and configure .namazurc
to refer to %%LOCALBASE%%/etc/namazu/namazu-sample.
-See also
-http://www.python.jp/pipermail/mailman-users-jp/2004-August/001008.html
-written in Japanese.
+You can also see the Japanese document in
+<http://www.python.jp/pipermail/mailman-users-jp/2004-August/001008.html>
----------------------------------------------------------------------------
diff --git a/mail/mailman/files/postfix-verp.diff b/mail/mailman/files/postfix-verp.diff
index 6db9c03c5035..604445664149 100644
--- a/mail/mailman/files/postfix-verp.diff
+++ b/mail/mailman/files/postfix-verp.diff
@@ -1,5 +1,5 @@
---- Mailman/Handlers/SMTPDirect.py.orig 2010-09-20 14:18:27.000000000 -0400
-+++ Mailman/Handlers/SMTPDirect.py 2010-10-16 20:26:51.913097648 -0400
+--- Mailman/Handlers/SMTPDirect.py.orig 2012-06-13 15:35:54.000000000 +0200
++++ Mailman/Handlers/SMTPDirect.py 2013-08-22 14:26:22.000000000 +0200
@@ -64,11 +64,11 @@
self.__conn.connect(mm_cfg.SMTPHOST, mm_cfg.SMTPPORT)
self.__numsessions = mm_cfg.SMTP_MAX_SESSIONS_PER_CONNECTION
@@ -23,17 +23,17 @@
chunks = [[recip] for recip in recips]
msgdata['personalize'] = 1
deliveryfunc = verpdeliver
-@@ -375,6 +375,9 @@
+@@ -376,6 +376,9 @@
if mlist.include_sender_header:
del msg['sender']
- msg['Sender'] = envsender
+ msg['Sender'] = '"%s" <%s>' % (mlist.real_name, envsender)
+ mailopts=[]
+ if msgdata.get('verp') and mm_cfg.VERP_STYLE == 'Postfix':
+ mailopts.append('XVERP=' + mm_cfg.POSTFIX_XVERP_OPTS)
# Get the plain, flattened text of the message, sans unixfrom
# using our as_string() method to not mangle From_ and not fold
# sub-part headers possibly breaking signatures.
-@@ -384,7 +387,7 @@
+@@ -385,7 +388,7 @@
msgid = msg['message-id']
try:
# Send the message
diff --git a/mail/mailman/pkg-descr b/mail/mailman/pkg-descr
index bb5df3d01195..59145985e3f8 100644
--- a/mail/mailman/pkg-descr
+++ b/mail/mailman/pkg-descr
@@ -18,4 +18,4 @@ mail transfer agents (mail servers). Mailman's documentation may be found on
its website.
Author: Barry Warsaw <barry@python.org> and the Mailman Cabal
-WWW: http://www.list.org/
+WWW: http://www.list.org/
diff --git a/mail/mailman/pkg-plist b/mail/mailman/pkg-plist
index 3bb55c06e8cf..2b79a3659e84 100644
--- a/mail/mailman/pkg-plist
+++ b/mail/mailman/pkg-plist
@@ -69,6 +69,8 @@
%%MMDIR%%/Mailman/Bouncers/Yale.pyc
%%MMDIR%%/Mailman/Bouncers/__init__.py
%%MMDIR%%/Mailman/Bouncers/__init__.pyc
+%%MMDIR%%/Mailman/CSRFcheck.py
+%%MMDIR%%/Mailman/CSRFcheck.pyc
%%MMDIR%%/Mailman/Cgi/Auth.py
%%MMDIR%%/Mailman/Cgi/Auth.pyc
%%MMDIR%%/Mailman/Cgi/__init__.py
@@ -387,6 +389,8 @@
%%MMDIR%%/icons/gnu-head-tiny.jpg
%%MMDIR%%/icons/mailman-large.jpg
%%MMDIR%%/icons/mailman.jpg
+%%MMDIR%%/icons/mm-icon-large.ico
+%%MMDIR%%/icons/mm-icon.ico
%%MMDIR%%/icons/mm-icon.png
%%MMDIR%%/mail/mailman
%%NLS%%%%MMDIR%%/messages/ar/LC_MESSAGES/mailman.mo
@@ -402,6 +406,8 @@
%%NLS%%%%MMDIR%%/messages/de/LC_MESSAGES/mailman.mo
%%NLS%%%%MMDIR%%/messages/de/LC_MESSAGES/mailman.po
%%NLS%%%%MMDIR%%/messages/de/README.de
+%%NLS%%%%MMDIR%%/messages/el/LC_MESSAGES/mailman.mo
+%%NLS%%%%MMDIR%%/messages/el/LC_MESSAGES/mailman.po
%%NLS%%%%MMDIR%%/messages/es/LC_MESSAGES/mailman.mo
%%NLS%%%%MMDIR%%/messages/es/LC_MESSAGES/mailman.po
%%NLS%%%%MMDIR%%/messages/es/README.es
@@ -713,80 +719,136 @@
%%NLS%%%%MMDIR%%/templates/de/adminunsubscribeack.txt
%%NLS%%%%MMDIR%%/templates/de/admlogin.html
%%NLS%%%%MMDIR%%/templates/de/approve.txt
+%%NLS%%%%MMDIR%%/templates/de/archidxentry.html
+%%NLS%%%%MMDIR%%/templates/de/archidxfoot.html
+%%NLS%%%%MMDIR%%/templates/de/archidxhead.html
+%%NLS%%%%MMDIR%%/templates/de/archlistend.html
+%%NLS%%%%MMDIR%%/templates/de/archliststart.html
+%%NLS%%%%MMDIR%%/templates/de/archtoc.html
+%%NLS%%%%MMDIR%%/templates/de/archtocentry.html
+%%NLS%%%%MMDIR%%/templates/de/archtocnombox.html
%%NLS%%%%MMDIR%%/templates/de/article.html
%%NLS%%%%MMDIR%%/templates/de/bounce.txt
%%NLS%%%%MMDIR%%/templates/de/checkdbs.txt
%%NLS%%%%MMDIR%%/templates/de/convert.txt
%%NLS%%%%MMDIR%%/templates/de/cronpass.txt
%%NLS%%%%MMDIR%%/templates/de/disabled.txt
+%%NLS%%%%MMDIR%%/templates/de/emptyarchive.html
%%NLS%%%%MMDIR%%/templates/de/headfoot.html
%%NLS%%%%MMDIR%%/templates/de/help.txt
%%NLS%%%%MMDIR%%/templates/de/invite.txt
%%NLS%%%%MMDIR%%/templates/de/listinfo.html
%%NLS%%%%MMDIR%%/templates/de/masthead.txt
%%NLS%%%%MMDIR%%/templates/de/newlist.txt
+%%NLS%%%%MMDIR%%/templates/de/nomoretoday.txt
%%NLS%%%%MMDIR%%/templates/de/options.html
%%NLS%%%%MMDIR%%/templates/de/postack.txt
%%NLS%%%%MMDIR%%/templates/de/postauth.txt
%%NLS%%%%MMDIR%%/templates/de/postheld.txt
%%NLS%%%%MMDIR%%/templates/de/private.html
+%%NLS%%%%MMDIR%%/templates/de/probe.txt
%%NLS%%%%MMDIR%%/templates/de/refuse.txt
%%NLS%%%%MMDIR%%/templates/de/roster.html
%%NLS%%%%MMDIR%%/templates/de/subauth.txt
%%NLS%%%%MMDIR%%/templates/de/subscribe.html
%%NLS%%%%MMDIR%%/templates/de/subscribeack.txt
%%NLS%%%%MMDIR%%/templates/de/unsub.txt
+%%NLS%%%%MMDIR%%/templates/de/unsubauth.txt
%%NLS%%%%MMDIR%%/templates/de/userpass.txt
%%NLS%%%%MMDIR%%/templates/de/verify.txt
-%%NLS%%%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig.html
-%%NLS%%%%SUB_HTDIG%%%%MMDIR%%/templates/en/TOC_htsearch.html
-%%NLS%%%%MMDIR%%/templates/en/admindbdetails.html
-%%NLS%%%%MMDIR%%/templates/en/admindbpreamble.html
-%%NLS%%%%MMDIR%%/templates/en/admindbsummary.html
-%%NLS%%%%MMDIR%%/templates/en/adminsubscribeack.txt
-%%NLS%%%%MMDIR%%/templates/en/adminunsubscribeack.txt
-%%NLS%%%%MMDIR%%/templates/en/admlogin.html
-%%NLS%%%%MMDIR%%/templates/en/approve.txt
-%%NLS%%%%MMDIR%%/templates/en/archidxentry.html
-%%NLS%%%%MMDIR%%/templates/en/archidxfoot.html
-%%NLS%%%%MMDIR%%/templates/en/archidxhead.html
-%%NLS%%%%MMDIR%%/templates/en/archlistend.html
-%%NLS%%%%MMDIR%%/templates/en/archliststart.html
-%%NLS%%%%MMDIR%%/templates/en/archtoc.html
-%%NLS%%%%MMDIR%%/templates/en/archtocentry.html
-%%NLS%%%%MMDIR%%/templates/en/archtocnombox.html
-%%NLS%%%%MMDIR%%/templates/en/article.html
-%%NLS%%%%MMDIR%%/templates/en/bounce.txt
-%%NLS%%%%MMDIR%%/templates/en/checkdbs.txt
-%%NLS%%%%MMDIR%%/templates/en/convert.txt
-%%NLS%%%%MMDIR%%/templates/en/cronpass.txt
-%%NLS%%%%MMDIR%%/templates/en/disabled.txt
-%%NLS%%%%MMDIR%%/templates/en/emptyarchive.html
-%%NLS%%%%MMDIR%%/templates/en/headfoot.html
-%%NLS%%%%MMDIR%%/templates/en/help.txt
-%%NLS%%%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_access_error.html
-%%NLS%%%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_auth_failure.html
-%%NLS%%%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_conf.txt
-%%NLS%%%%MMDIR%%/templates/en/invite.txt
-%%NLS%%%%MMDIR%%/templates/en/listinfo.html
-%%NLS%%%%MMDIR%%/templates/en/masthead.txt
-%%NLS%%%%MMDIR%%/templates/en/newlist.txt
-%%NLS%%%%MMDIR%%/templates/en/nomoretoday.txt
-%%NLS%%%%MMDIR%%/templates/en/options.html
-%%NLS%%%%MMDIR%%/templates/en/postack.txt
-%%NLS%%%%MMDIR%%/templates/en/postauth.txt
-%%NLS%%%%MMDIR%%/templates/en/postheld.txt
-%%NLS%%%%MMDIR%%/templates/en/private.html
-%%NLS%%%%MMDIR%%/templates/en/probe.txt
-%%NLS%%%%MMDIR%%/templates/en/refuse.txt
-%%NLS%%%%MMDIR%%/templates/en/roster.html
-%%NLS%%%%MMDIR%%/templates/en/subauth.txt
-%%NLS%%%%MMDIR%%/templates/en/subscribe.html
-%%NLS%%%%MMDIR%%/templates/en/subscribeack.txt
-%%NLS%%%%MMDIR%%/templates/en/unsub.txt
-%%NLS%%%%MMDIR%%/templates/en/unsubauth.txt
-%%NLS%%%%MMDIR%%/templates/en/userpass.txt
-%%NLS%%%%MMDIR%%/templates/en/verify.txt
+%%NLS%%%%MMDIR%%/templates/el/admindbdetails.html
+%%NLS%%%%MMDIR%%/templates/el/admindbpreamble.html
+%%NLS%%%%MMDIR%%/templates/el/admindbsummary.html
+%%NLS%%%%MMDIR%%/templates/el/admlogin.html
+%%NLS%%%%MMDIR%%/templates/el/archidxentry.html
+%%NLS%%%%MMDIR%%/templates/el/archidxfoot.html
+%%NLS%%%%MMDIR%%/templates/el/archidxhead.html
+%%NLS%%%%MMDIR%%/templates/el/archlistend.html
+%%NLS%%%%MMDIR%%/templates/el/archliststart.html
+%%NLS%%%%MMDIR%%/templates/el/archtoc.html
+%%NLS%%%%MMDIR%%/templates/el/archtocentry.html
+%%NLS%%%%MMDIR%%/templates/el/archtocnombox.html
+%%NLS%%%%MMDIR%%/templates/el/article.html
+%%NLS%%%%MMDIR%%/templates/el/emptyarchive.html
+%%NLS%%%%MMDIR%%/templates/el/headfoot.html
+%%NLS%%%%MMDIR%%/templates/el/listinfo.html
+%%NLS%%%%MMDIR%%/templates/el/options.html
+%%NLS%%%%MMDIR%%/templates/el/private.html
+%%NLS%%%%MMDIR%%/templates/el/roster.html
+%%NLS%%%%MMDIR%%/templates/el/subscribe.html
+%%NLS%%%%MMDIR%%/templates/el/adminsubscribeack.txt
+%%NLS%%%%MMDIR%%/templates/el/adminunsubscribeack.txt
+%%NLS%%%%MMDIR%%/templates/el/approve.txt
+%%NLS%%%%MMDIR%%/templates/el/bounce.txt
+%%NLS%%%%MMDIR%%/templates/el/checkdbs.txt
+%%NLS%%%%MMDIR%%/templates/el/convert.txt
+%%NLS%%%%MMDIR%%/templates/el/cronpass.txt
+%%NLS%%%%MMDIR%%/templates/el/disabled.txt
+%%NLS%%%%MMDIR%%/templates/el/help.txt
+%%NLS%%%%MMDIR%%/templates/el/invite.txt
+%%NLS%%%%MMDIR%%/templates/el/masthead.txt
+%%NLS%%%%MMDIR%%/templates/el/newlist.txt
+%%NLS%%%%MMDIR%%/templates/el/nomoretoday.txt
+%%NLS%%%%MMDIR%%/templates/el/postack.txt
+%%NLS%%%%MMDIR%%/templates/el/postauth.txt
+%%NLS%%%%MMDIR%%/templates/el/postheld.txt
+%%NLS%%%%MMDIR%%/templates/el/probe.txt
+%%NLS%%%%MMDIR%%/templates/el/refuse.txt
+%%NLS%%%%MMDIR%%/templates/el/subauth.txt
+%%NLS%%%%MMDIR%%/templates/el/subscribeack.txt
+%%NLS%%%%MMDIR%%/templates/el/unsub.txt
+%%NLS%%%%MMDIR%%/templates/el/unsubauth.txt
+%%NLS%%%%MMDIR%%/templates/el/userpass.txt
+%%NLS%%%%MMDIR%%/templates/el/verify.txt
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig.html
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/TOC_htsearch.html
+%%MMDIR%%/templates/en/admindbdetails.html
+%%MMDIR%%/templates/en/admindbpreamble.html
+%%MMDIR%%/templates/en/admindbsummary.html
+%%MMDIR%%/templates/en/adminsubscribeack.txt
+%%MMDIR%%/templates/en/adminunsubscribeack.txt
+%%MMDIR%%/templates/en/admlogin.html
+%%MMDIR%%/templates/en/approve.txt
+%%MMDIR%%/templates/en/archidxentry.html
+%%MMDIR%%/templates/en/archidxfoot.html
+%%MMDIR%%/templates/en/archidxhead.html
+%%MMDIR%%/templates/en/archlistend.html
+%%MMDIR%%/templates/en/archliststart.html
+%%MMDIR%%/templates/en/archtoc.html
+%%MMDIR%%/templates/en/archtocentry.html
+%%MMDIR%%/templates/en/archtocnombox.html
+%%MMDIR%%/templates/en/article.html
+%%MMDIR%%/templates/en/bounce.txt
+%%MMDIR%%/templates/en/checkdbs.txt
+%%MMDIR%%/templates/en/convert.txt
+%%MMDIR%%/templates/en/cronpass.txt
+%%MMDIR%%/templates/en/disabled.txt
+%%MMDIR%%/templates/en/emptyarchive.html
+%%MMDIR%%/templates/en/headfoot.html
+%%MMDIR%%/templates/en/help.txt
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_access_error.html
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_auth_failure.html
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_conf.txt
+%%MMDIR%%/templates/en/invite.txt
+%%MMDIR%%/templates/en/listinfo.html
+%%MMDIR%%/templates/en/masthead.txt
+%%MMDIR%%/templates/en/newlist.txt
+%%MMDIR%%/templates/en/nomoretoday.txt
+%%MMDIR%%/templates/en/options.html
+%%MMDIR%%/templates/en/postack.txt
+%%MMDIR%%/templates/en/postauth.txt
+%%MMDIR%%/templates/en/postheld.txt
+%%MMDIR%%/templates/en/private.html
+%%MMDIR%%/templates/en/probe.txt
+%%MMDIR%%/templates/en/refuse.txt
+%%MMDIR%%/templates/en/roster.html
+%%MMDIR%%/templates/en/subauth.txt
+%%MMDIR%%/templates/en/subscribe.html
+%%MMDIR%%/templates/en/subscribeack.txt
+%%MMDIR%%/templates/en/unsub.txt
+%%MMDIR%%/templates/en/unsubauth.txt
+%%MMDIR%%/templates/en/userpass.txt
+%%MMDIR%%/templates/en/verify.txt
%%NLS%%%%MMDIR%%/templates/es/admindbdetails.html
%%NLS%%%%MMDIR%%/templates/es/admindbpreamble.html
%%NLS%%%%MMDIR%%/templates/es/admindbsummary.html
@@ -2076,6 +2138,7 @@
%%MMDIR%%/tests/bounces/qmail_04.txt
%%MMDIR%%/tests/bounces/qmail_05.txt
%%MMDIR%%/tests/bounces/qmail_06.txt
+%%MMDIR%%/tests/bounces/qmail_07.txt
%%MMDIR%%/tests/bounces/sendmail_01.txt
%%MMDIR%%/tests/bounces/simple_01.txt
%%MMDIR%%/tests/bounces/simple_02.txt
@@ -2114,6 +2177,7 @@
%%MMDIR%%/tests/bounces/simple_35.txt
%%MMDIR%%/tests/bounces/simple_36.txt
%%MMDIR%%/tests/bounces/simple_37.txt
+%%MMDIR%%/tests/bounces/simple_38.txt
%%MMDIR%%/tests/bounces/sina_01.txt
%%MMDIR%%/tests/bounces/smtp32_01.txt
%%MMDIR%%/tests/bounces/smtp32_02.txt
@@ -2147,6 +2211,8 @@
%%MMDIR%%/tests/test_security_mgr.py
%%MMDIR%%/tests/test_smtp.py
%%MMDIR%%/tests/testall.py
+%%PYTHON_SITELIBDIR%%/mailman-info.txt
+@dirrmtry %%PYTHON_SITELIBDIR%%
@dirrm %%MMDIR%%/tests/msgs
@dirrm %%MMDIR%%/tests/bounces
@dirrm %%MMDIR%%/tests
@@ -2180,14 +2246,15 @@
%%NLS%%@dirrm %%MMDIR%%/templates/eu
%%NLS%%@dirrm %%MMDIR%%/templates/et
%%NLS%%@dirrm %%MMDIR%%/templates/es
-%%NLS%%@dirrm %%MMDIR%%/templates/en
+@dirrm %%MMDIR%%/templates/en
+%%NLS%%@dirrm %%MMDIR%%/templates/el
%%NLS%%@dirrm %%MMDIR%%/templates/de
%%NLS%%@dirrm %%MMDIR%%/templates/da
%%NLS%%@dirrm %%MMDIR%%/templates/cs
%%NLS%%@dirrm %%MMDIR%%/templates/ca
%%NLS%%@dirrm %%MMDIR%%/templates/ast
%%NLS%%@dirrm %%MMDIR%%/templates/ar
-%%NLS%%@dirrm %%MMDIR%%/templates
+@dirrm %%MMDIR%%/templates
@dirrm %%MMDIR%%/scripts
%%NLS%%@dirrm %%MMDIR%%/messages/ast/LC_MESSAGES
%%NLS%%@dirrm %%MMDIR%%/messages/ast
@@ -2251,6 +2318,8 @@
%%NLS%%@dirrm %%MMDIR%%/messages/et
%%NLS%%@dirrm %%MMDIR%%/messages/es/LC_MESSAGES
%%NLS%%@dirrm %%MMDIR%%/messages/es
+%%NLS%%@dirrm %%MMDIR%%/messages/el/LC_MESSAGES
+%%NLS%%@dirrm %%MMDIR%%/messages/el
%%NLS%%@dirrm %%MMDIR%%/messages/de/LC_MESSAGES
%%NLS%%@dirrm %%MMDIR%%/messages/de
%%NLS%%@dirrm %%MMDIR%%/messages/da/LC_MESSAGES