aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-02-26 09:13:49 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-02-26 09:13:49 +0000
commit3d13fb15fe8f6032c16b92987fcaa9937fa1584f (patch)
treee66b0216db07832004ee5f73b22da63501f01797 /mail/mailman
parent3b14d66efb0649d3828b48db6e8dffd5bacabffb (diff)
downloadports-3d13fb15fe8f6032c16b92987fcaa9937fa1584f.tar.gz
ports-3d13fb15fe8f6032c16b92987fcaa9937fa1584f.zip
Notes
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile1
-rw-r--r--mail/mailman/files/patch-aa26
2 files changed, 27 insertions, 0 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index afa7bcdcda70..2fafb7c3f46e 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mailman
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mailman
diff --git a/mail/mailman/files/patch-aa b/mail/mailman/files/patch-aa
new file mode 100644
index 000000000000..ec6b5df8cca3
--- /dev/null
+++ b/mail/mailman/files/patch-aa
@@ -0,0 +1,26 @@
+*** Mailman/Utils.py.orig Thu Nov 16 22:43:11 2000
+--- Mailman/Utils.py Thu Feb 15 19:42:10 2001
+***************
+*** 407,413 ****
+ f = open(mm_cfg.SITE_PW_FILE)
+ pw2 = f.read()
+ f.close()
+! return Crypt.crypt(pw1, pw2[:2]) == pw2
+ # There probably is no site admin password if there was an exception
+ except IOError:
+ return 0
+--- 407,420 ----
+ f = open(mm_cfg.SITE_PW_FILE)
+ pw2 = f.read()
+ f.close()
+! # First we check for the Modular Crypt Format
+! mcf = re.match(r'\$\d\$(\w+)\$', pw2)
+! if mcf: # Is it MCF?
+! salt=mcf.group(1)
+! else: # No, it's traditional DES.
+! salt=pw2[:2]
+!
+! return Crypt.crypt(pw1, salt) == pw2
+ # There probably is no site admin password if there was an exception
+ except IOError:
+ return 0 \ No newline at end of file