aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-10-18 18:34:09 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-10-18 18:34:09 +0000
commit86b3563dc7b359aefa62ac57d8d983cdb35d8972 (patch)
treef32981bc0e3eccf71a96350f40714cbbdef87ff0 /mail/mailman
parent9ea54126191bd5454210035cec4feced9a89c1ff (diff)
Notes
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile9
-rw-r--r--mail/mailman/files/patch-Makefile.in12
2 files changed, 16 insertions, 5 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 597de52c6712..8359a67d9b2d 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.16
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_GNU} \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
@@ -142,7 +143,6 @@ post-patch:
@${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
${WRKSRC}/Mailman/Defaults.py.in
@${REINPLACE_CMD} -e 's/^0,5,10/#&/' ${WRKSRC}/cron/crontab.in.in
- @${REINPLACE_CMD} -e '/PYTHON.*compileall/d' ${WRKSRC}/Makefile.in
.if empty(PORT_OPTIONS:MNLS)
@${REINPLACE_CMD} -e 's/messages//' ${WRKSRC}/Makefile.in
.endif
@@ -163,12 +163,11 @@ post-install:
.endfor
.endif
${STRIP_CMD} ${STAGEDIR}${MAILMANDIR}/mail/mailman
-# Recompile Python scripts to get the real paths in,
-# rather than the staged paths:
-.for dir in bin Mailman
+# Compile additional Python scripts:
+.for dir in bin
(cd ${STAGEDIR}${MAILMANDIR} \
&& ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
- -d ${MAILMANDIR} -f -q ${dir})
+ -d ${MAILMANDIR}/${dir} ${dir})
.endfor
@${RM} -f ${STAGEDIR}${MAILMANDIR}/pythonlib/*.egg-info
@${RM} -f ${STAGEDIR}${MAILMANDIR}/Mailman/mm_cfg.pyc
diff --git a/mail/mailman/files/patch-Makefile.in b/mail/mailman/files/patch-Makefile.in
new file mode 100644
index 000000000000..cd91e30207e7
--- /dev/null
+++ b/mail/mailman/files/patch-Makefile.in
@@ -0,0 +1,12 @@
+--- ./Makefile.in.orig 2013-10-17 06:11:34.000000000 +0200
++++ ./Makefile.in 2013-10-18 19:18:05.000000000 +0200
+@@ -124,7 +124,8 @@
+ do \
+ (cd $$d; $(MAKE) DESTDIR=$(DESTDIR) install); \
+ done
+- $(PYTHON) -c 'from compileall import *; compile_dir("$(DESTDIR)$(prefix)/Mailman")'
++ (cd "$(DESTDIR)$(prefix)" \
++ && $(PYTHON) -c 'from compileall import *; compile_dir("Mailman", ddir="$(prefix)/Mailman")')
+
+ # Only run bin/update if we aren't installing in DESTDIR, as this
+ # means there are probably no lists to deal with, and it wouldn't