aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-12 23:50:02 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-12 23:50:02 +0000
commited3595754bd1a529d81636193210fc027c4552df (patch)
tree5165e8678432fadb05c4a83316040bbb4ff9363c /mail/mailman
parentddb1c152a9c851e92d20f22747dbfb33560b4dd5 (diff)
downloadports-ed3595754bd1a529d81636193210fc027c4552df.tar.gz
ports-ed3595754bd1a529d81636193210fc027c4552df.zip
Notes
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile22
-rw-r--r--mail/mailman/distinfo4
-rw-r--r--mail/mailman/files/pkg-opts3
-rw-r--r--mail/mailman/pkg-plist69
4 files changed, 71 insertions, 27 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 2ed7b5c0ae14..fea68bac9fa4 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -12,7 +12,20 @@ MASTER_SITES= http://www.list.org/ \
${MASTER_SITE_GNU} \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mailman
+.if defined(WITH_HTDIG)
+PKGNAMESUFFIX= -with-htdig
+.endif
EXTRACT_SUFX= .tgz
+DIST_SUBDIR= mailman
+
+.if defined(WITH_HTDIG)
+# Order of application of these patches is critical.
+PATCHFILES= download.php\?group_id=103\&atid=300103\&file_id=63029\&aid=444879:patch1 \
+ htdig-2.1.3-0.3.patch.gz:patch2
+PATCH_DIST_STRIP= -p1
+PATCH_SITES= http://sourceforge.net/tracker/:patch1 \
+ http://www.openinfo.co.uk/mailman/patches/444884/:patch2
+.endif
MAINTAINER= vivek@khera.org
COMMENT= A mailing list manager (MLM) with a user-friendly web front-end
@@ -21,6 +34,9 @@ RUN_DEPENDS= lynx:${PORTSDIR}/www/lynx
.if defined(WITH_CHINESE)
RUN_DEPENDS+= ${PYTHONPREFIX_SITELIBDIR}/cjkcodecs.pth:${PORTSDIR}/converters/py-cjkcodecs
.endif
+.if defined(WITH_HTDIG)
+RUN_DEPENDS+= htdig:${PORTSDIR}/textproc/htdig
+.endif
HAS_CONFIGURE= yes
USE_PYTHON= yes
@@ -30,6 +46,12 @@ CONFIGURE_ARGS= --prefix=${MAILMANDIR} --with-python=${PYTHON_CMD} \
--with-groupname=${MM_GROUPNAME} \
--with-mail-gid=${MAIL_GID} --with-cgi-gid=${CGI_GID}
+.if defined(WITH_HTDIG)
+PLIST_SUB+= SUB_HTDIG=""
+.else
+PLIST_SUB+= SUB_HTDIG="@comment "
+.endif
+
.include <bsd.port.pre.mk>
# The Mailman port supports a number of variables that may be tweaked at
diff --git a/mail/mailman/distinfo b/mail/mailman/distinfo
index bb0833826b1d..52191bc5da61 100644
--- a/mail/mailman/distinfo
+++ b/mail/mailman/distinfo
@@ -1 +1,3 @@
-MD5 (mailman-2.1.3.tgz) = 1c9ec97b340ad1f802bce3f6b2dd9430
+MD5 (mailman/mailman-2.1.3.tgz) = 1c9ec97b340ad1f802bce3f6b2dd9430
+MD5 (mailman/download.php?group_id=103&atid=300103&file_id=63029&aid=444879) = f2b110c6be38f5aebee95a1119cd6e74
+MD5 (mailman/htdig-2.1.3-0.3.patch.gz) = 1a4135f81fef3f1c83308b7a843cfda3
diff --git a/mail/mailman/files/pkg-opts b/mail/mailman/files/pkg-opts
index 20cccda21eaa..c80524e10a8e 100644
--- a/mail/mailman/files/pkg-opts
+++ b/mail/mailman/files/pkg-opts
@@ -53,3 +53,6 @@
* WITH_CHINESE [undefined]
Define to include support for Chinese mailing lists
+* WITH_HTDIG [undefined]
+ Define to include the htdig integration patches.
+
diff --git a/mail/mailman/pkg-plist b/mail/mailman/pkg-plist
index 4151cc2b64c1..d65b829c04f4 100644
--- a/mail/mailman/pkg-plist
+++ b/mail/mailman/pkg-plist
@@ -1,8 +1,10 @@
+@comment $FreeBSD$
@unexec if cmp -s %D/%%MMDIR%%/Mailman/mm_cfg.py %D/%%MMDIR%%/Mailman/mm_cfg.py.dist; then rm -f %D/%%MMDIR%%/Mailman/mm_cfg.py; fi
@unexec rm -f %D/%%MMDIR%%/Mailman/mm_cfg.pyc
+@exec mkdir -p %D/%%MMDIR%%/archives
+%%SUB_HTDIG%%@exec mkdir -p %D/%%MMDIR%%/archives/htdig
@exec mkdir -p %D/%%MMDIR%%/archives/private
@exec mkdir -p %D/%%MMDIR%%/archives/public
-@exec mkdir -p %D/%%MMDIR%%/archives
@exec mkdir -p %D/%%MMDIR%%/lists
@exec mkdir -p %D/%%MMDIR%%/locks
@exec mkdir -p %D/%%MMDIR%%/logs
@@ -78,8 +80,12 @@
%%MMDIR%%/Mailman/Cgi/create.pyc
%%MMDIR%%/Mailman/Cgi/edithtml.py
%%MMDIR%%/Mailman/Cgi/edithtml.pyc
+%%SUB_HTDIG%%%%MMDIR%%/Mailman/Cgi/htdig.py
+%%SUB_HTDIG%%%%MMDIR%%/Mailman/Cgi/htdig.pyc
%%MMDIR%%/Mailman/Cgi/listinfo.py
%%MMDIR%%/Mailman/Cgi/listinfo.pyc
+%%SUB_HTDIG%%%%MMDIR%%/Mailman/Cgi/mmsearch.py
+%%SUB_HTDIG%%%%MMDIR%%/Mailman/Cgi/mmsearch.pyc
%%MMDIR%%/Mailman/Cgi/options.py
%%MMDIR%%/Mailman/Cgi/options.pyc
%%MMDIR%%/Mailman/Cgi/private.py
@@ -305,6 +311,7 @@
%%MMDIR%%/bin/add_members
%%MMDIR%%/bin/arch
%%MMDIR%%/bin/b4b5-archfix
+%%SUB_HTDIG%%%%MMDIR%%/bin/blow_away_htdig
%%MMDIR%%/bin/change_pw
%%MMDIR%%/bin/check_db
%%MMDIR%%/bin/check_perms
@@ -331,8 +338,8 @@
%%MMDIR%%/bin/qrunner
%%MMDIR%%/bin/remove_members
%%MMDIR%%/bin/rmlist
-%%MMDIR%%/bin/sync_members
%%MMDIR%%/bin/show_qfiles
+%%MMDIR%%/bin/sync_members
%%MMDIR%%/bin/transcheck
%%MMDIR%%/bin/unshunt
%%MMDIR%%/bin/update
@@ -343,7 +350,9 @@
%%MMDIR%%/cgi-bin/confirm
%%MMDIR%%/cgi-bin/create
%%MMDIR%%/cgi-bin/edithtml
+%%SUB_HTDIG%%%%MMDIR%%/cgi-bin/htdig
%%MMDIR%%/cgi-bin/listinfo
+%%SUB_HTDIG%%%%MMDIR%%/cgi-bin/mmsearch
%%MMDIR%%/cgi-bin/options
%%MMDIR%%/cgi-bin/private
%%MMDIR%%/cgi-bin/rmlist
@@ -356,8 +365,12 @@
%%MMDIR%%/cron/gate_news
%%MMDIR%%/cron/mailpasswds
%%MMDIR%%/cron/nightly_gzip
+%%SUB_HTDIG%%%%MMDIR%%/cron/nightly_htdig
%%MMDIR%%/cron/paths.py
%%MMDIR%%/cron/paths.pyc
+%%SUB_HTDIG%%%%MMDIR%%/cron/remote_nightly_htdig
+%%SUB_HTDIG%%%%MMDIR%%/cron/remote_nightly_htdig.pl
+%%SUB_HTDIG%%%%MMDIR%%/cron/remote_nightly_htdig_noshare
%%MMDIR%%/cron/senddigests
%%MMDIR%%/data/last_mailman_version
%%MMDIR%%/data/sitelist.cfg
@@ -374,14 +387,14 @@
%%MMDIR%%/messages/de/LC_MESSAGES/mailman.mo
%%MMDIR%%/messages/de/LC_MESSAGES/mailman.po
%%MMDIR%%/messages/de/README.de
-%%MMDIR%%/messages/eu/LC_MESSAGES/mailman.mo
-%%MMDIR%%/messages/eu/LC_MESSAGES/mailman.po
-%%MMDIR%%/messages/eu/README.eu
%%MMDIR%%/messages/es/LC_MESSAGES/mailman.mo
%%MMDIR%%/messages/es/LC_MESSAGES/mailman.po
%%MMDIR%%/messages/es/README.es
%%MMDIR%%/messages/et/LC_MESSAGES/mailman.mo
%%MMDIR%%/messages/et/LC_MESSAGES/mailman.po
+%%MMDIR%%/messages/eu/LC_MESSAGES/mailman.mo
+%%MMDIR%%/messages/eu/LC_MESSAGES/mailman.po
+%%MMDIR%%/messages/eu/README.eu
%%MMDIR%%/messages/fi/LC_MESSAGES/mailman.mo
%%MMDIR%%/messages/fi/LC_MESSAGES/mailman.po
%%MMDIR%%/messages/fi/README.fi
@@ -693,6 +706,7 @@
%%MMDIR%%/templates/de/unsub.txt
%%MMDIR%%/templates/de/userpass.txt
%%MMDIR%%/templates/de/verify.txt
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/TOC_htsearch.html
%%MMDIR%%/templates/en/admindbdetails.html
%%MMDIR%%/templates/en/admindbpreamble.html
%%MMDIR%%/templates/en/admindbsummary.html
@@ -716,6 +730,9 @@
%%MMDIR%%/templates/en/emptyarchive.html
%%MMDIR%%/templates/en/headfoot.html
%%MMDIR%%/templates/en/help.txt
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_access_error.html
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_auth_failure.html
+%%SUB_HTDIG%%%%MMDIR%%/templates/en/htdig_conf.txt
%%MMDIR%%/templates/en/invite.txt
%%MMDIR%%/templates/en/listinfo.html
%%MMDIR%%/templates/en/masthead.txt
@@ -1574,23 +1591,24 @@
%%MMDIR%%/tests/test_security_mgr.py
%%MMDIR%%/tests/test_smtp.py
%%MMDIR%%/tests/testall.py
-%%PORTDOCS%%share/doc/mailman/ACKNOWLEDGMENTS
-%%PORTDOCS%%share/doc/mailman/BUGS
-%%PORTDOCS%%share/doc/mailman/FAQ
-%%PORTDOCS%%share/doc/mailman/FreeBSD-post-install-notes
-%%PORTDOCS%%share/doc/mailman/INSTALL
-%%PORTDOCS%%share/doc/mailman/NEWS
-%%PORTDOCS%%share/doc/mailman/README
-%%PORTDOCS%%share/doc/mailman/README-I18N.en
-%%PORTDOCS%%share/doc/mailman/README.CONTRIB
-%%PORTDOCS%%share/doc/mailman/README.EXIM
-%%PORTDOCS%%share/doc/mailman/README.NETSCAPE
-%%PORTDOCS%%share/doc/mailman/README.POSTFIX
-%%PORTDOCS%%share/doc/mailman/README.QMAIL
-%%PORTDOCS%%share/doc/mailman/README.SENDMAIL
-%%PORTDOCS%%share/doc/mailman/README.USERAGENT
-%%PORTDOCS%%share/doc/mailman/TODO
-%%PORTDOCS%%share/doc/mailman/UPGRADING
+%%PORTDOCS%%%%DOCSDIR%%/ACKNOWLEDGMENTS
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/FreeBSD-post-install-notes
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README-I18N.en
+%%PORTDOCS%%%%DOCSDIR%%/README.CONTRIB
+%%PORTDOCS%%%%DOCSDIR%%/README.EXIM
+%%PORTDOCS%%%%DOCSDIR%%/README.NETSCAPE
+%%PORTDOCS%%%%DOCSDIR%%/README.POSTFIX
+%%PORTDOCS%%%%DOCSDIR%%/README.QMAIL
+%%PORTDOCS%%%%DOCSDIR%%/README.SENDMAIL
+%%PORTDOCS%%%%DOCSDIR%%/README.USERAGENT
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
etc/rc.d/mailman.sh
@dirrm %%MMDIR%%/tests/msgs
@dirrm %%MMDIR%%/tests/bounces
@@ -1667,10 +1685,10 @@ etc/rc.d/mailman.sh
@dirrm %%MMDIR%%/messages/fr
@dirrm %%MMDIR%%/messages/fi/LC_MESSAGES
@dirrm %%MMDIR%%/messages/fi
-@dirrm %%MMDIR%%/messages/et/LC_MESSAGES
-@dirrm %%MMDIR%%/messages/et
@dirrm %%MMDIR%%/messages/eu/LC_MESSAGES
@dirrm %%MMDIR%%/messages/eu
+@dirrm %%MMDIR%%/messages/et/LC_MESSAGES
+@dirrm %%MMDIR%%/messages/et
@dirrm %%MMDIR%%/messages/es/LC_MESSAGES
@dirrm %%MMDIR%%/messages/es
@dirrm %%MMDIR%%/messages/de/LC_MESSAGES
@@ -1694,8 +1712,6 @@ etc/rc.d/mailman.sh
@dirrm %%MMDIR%%/Mailman/Cgi
@dirrm %%MMDIR%%/Mailman/Bouncers
@dirrm %%MMDIR%%/Mailman/Archiver
-@dirrm %%MMDIR%%/Mailman
-%%PORTDOCS%%@dirrm share/doc/mailman
@unexec rmdir %D/%%MMDIR%%/spam 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/qfiles 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/logs 2>/dev/null || true
@@ -1704,6 +1720,7 @@ etc/rc.d/mailman.sh
@unexec rmdir %D/%%MMDIR%%/data 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/archives/public 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/archives/private 2>/dev/null || true
+%%SUB_HTDIG%%@unexec rmdir %D/%%MMDIR%%/archives/htdig 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/archives 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/Mailman 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/ 2>/dev/null || true