aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2004-08-31 17:27:06 +0000
committerMichael Haro <mharo@FreeBSD.org>2004-08-31 17:27:06 +0000
commitbe3ac29f18d44f465226bbd269e41bc8aaa8707e (patch)
treeb2b991ef9b506956385ac30bf90c3c59e2be5b13 /mail/mailman
parentfaebe3e77cc713c6b5e8cfa4a21749e5959f8fd4 (diff)
downloadports-be3ac29f18d44f465226bbd269e41bc8aaa8707e.tar.gz
ports-be3ac29f18d44f465226bbd269e41bc8aaa8707e.zip
Notes
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile1
-rw-r--r--mail/mailman/files/patch-Mailman::ListAdmin.py20
2 files changed, 21 insertions, 0 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 153253c0f9c1..7ae3d023512d 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mailman
PORTVERSION= 2.1.5
+PORTREVISION= 1
CATEGORIES?= mail
MASTER_SITES= http://www.list.org/ \
${MASTER_SITE_GNU} \
diff --git a/mail/mailman/files/patch-Mailman::ListAdmin.py b/mail/mailman/files/patch-Mailman::ListAdmin.py
new file mode 100644
index 000000000000..699193b55451
--- /dev/null
+++ b/mail/mailman/files/patch-Mailman::ListAdmin.py
@@ -0,0 +1,20 @@
+--- /usr/local/src/mailman-2.1.5/Mailman/ListAdmin.py-2.1.5 2004-02-29 12:55:27.000000000 +0900
++++ Mailman/ListAdmin.py 2004-06-10 22:44:39.373711240 +0900
+@@ -83,6 +83,8 @@
+ except IOError, e:
+ if e.errno <> errno.ENOENT: raise
+ self.__db = {}
++ # put version number in new database
++ self.__db['version'] = IGN, mm_cfg.REQUESTS_FILE_SCHEMA_VERSION
+
+ def __closedb(self):
+ if self.__db is not None:
+@@ -122,7 +124,7 @@
+
+ def NumRequestsPending(self):
+ self.__opendb()
+- # Subtrace one for the version pseudo-entry
++ # Subtract one for the version pseudo-entry
+ return len(self.__db) - 1
+
+ def __getmsgids(self, rtype):