aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-09-10 16:53:56 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-09-10 16:53:56 +0000
commit4412b821218f19603d201c4696cb7e015ad1814a (patch)
treec001f7feeb3e8873f3549f0e084b7bdeed52c4ce /mail/mailman
parentde97c5e9a7bb53f84a70c67aef753ed2668b475a (diff)
downloadports-4412b821218f19603d201c4696cb7e015ad1814a.tar.gz
ports-4412b821218f19603d201c4696cb7e015ad1814a.zip
Notes
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile5
-rw-r--r--mail/mailman/files/pkg-install.in3
2 files changed, 7 insertions, 1 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 0f7f05bf7409..be9dfb25387c 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.24
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= GNU \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
@@ -34,7 +35,9 @@ CONFIGURE_ARGS+=--with-python=${PYTHON_CMD} \
--with-username=${MM_USERNAME} \
--with-groupname=${MM_GROUPNAME} \
--with-mail-gid=${MAIL_GID} --with-cgi-gid=${CGI_GID} \
- --with-permcheck=no
+ --with-permcheck=no \
+ --with-mailhost=// \
+ --with-urlhost=//
# The Mailman port supports a number of variables that may be tweaked at
# build time. Getting the values of some of them right is crucial!
diff --git a/mail/mailman/files/pkg-install.in b/mail/mailman/files/pkg-install.in
index 90d4f0584318..ce9bbd6474c0 100644
--- a/mail/mailman/files/pkg-install.in
+++ b/mail/mailman/files/pkg-install.in
@@ -106,6 +106,9 @@ POST-INSTALL)
echo "---> rcfile sets mailman_fix_perms to no, skipping check_perms"
fi
+ echo "---> Fixing up default host names (MAILHOST, URLHOST)"
+ sed -Ee "s}^(DEFAULT_(EMAIL|URL)_HOST) = '//'}\1 = '`hostname -f`'}" -i '' "%%MAILMANDIR%%/Mailman/Defaults.py"
+
echo "---> Running assorted other checks"
if egrep -q "^[ \t]*MTA.*=.*Postfix" "%%MAILMANDIR%%/Mailman/mm_cfg.py" ; then
# run Postfix-specific checks