aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2018-11-28 14:18:08 +0000
committerBen Woods <woodsb02@FreeBSD.org>2018-11-28 14:18:08 +0000
commit898fbce0b327fe15e5cdfdb3dac025143be2eca7 (patch)
treecd971911963b89eb50a90cfb30c8016f8d835962 /mail/mailman
parenta853ac642cb1f8cc0564d12533ce4f34b00c4b84 (diff)
downloadports-898fbce0b327fe15e5cdfdb3dac025143be2eca7.tar.gz
ports-898fbce0b327fe15e5cdfdb3dac025143be2eca7.zip
Notes
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile2
-rw-r--r--mail/mailman/files/pkg-install.in19
-rw-r--r--mail/mailman/files/pkg-message.in16
-rw-r--r--mail/mailman/pkg-plist2
4 files changed, 37 insertions, 2 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 575e9ffabcb7..1e26d96268b3 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.29
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= GNU \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
diff --git a/mail/mailman/files/pkg-install.in b/mail/mailman/files/pkg-install.in
index 5d75ccce52c6..c3f5b5340557 100644
--- a/mail/mailman/files/pkg-install.in
+++ b/mail/mailman/files/pkg-install.in
@@ -30,6 +30,23 @@ add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)
_EOF
}
+move_newsyslog_conf() {
+ oldfile=${PKG_PREFIX}/etc/newsyslog.conf.d/mailman.newsyslog
+ newfile=${PKG_PREFIX}/etc/newsyslog.conf.d/mailman.conf
+ samplefile=${PKG_PREFIX}/share/examples/mailman/mailman.newsyslog.sample
+ if [ -f ${oldfile} ]; then
+ echo "Configuration file found in old location: ${oldfile}"
+ if cmp -s ${samplefile} ${newfile} > /dev/null; then
+ echo "Configuration file in new location has not been modified from the default: ${newfile}"
+ echo " => Moving old configuration file to new location"
+ mv -f ${oldfile} ${newfile}
+ else
+ echo "Configuration file in new location has been modified from the default: ${newfile}"
+ echo " => You should either delete the old file, or move it to the new location"
+ fi
+ fi
+}
+
set -e
MYTMP="$(mktemp -d "${TMPDIR-/tmp}/mminstall.XXXXXXXXXX")"
trap "rm -rf \"$MYTMP\"" EXIT
@@ -40,6 +57,8 @@ POST-INSTALL)
LC_ALL=C
export LC_ALL
+ move_newsyslog_conf
+
# fix up permissions - this is under investigation; pkg or libarchive
# goof up the group writable and/or setgid bits
/usr/bin/find "%%MAILMANDIR%%/qfiles" -maxdepth 1 -type d -exec \
diff --git a/mail/mailman/files/pkg-message.in b/mail/mailman/files/pkg-message.in
index 37bac1f067a1..eee539fe16ca 100644
--- a/mail/mailman/files/pkg-message.in
+++ b/mail/mailman/files/pkg-message.in
@@ -63,3 +63,19 @@ UPDATE INFORMATION FOR UPDATES OF 2.1.18/OLDER TO VERSION 2.1.19 AND NEWER:
have a logrotate process that creates new log files instead of letting
Mailman create them, you will need to address that. (LP: #1327404)
----------------------------------------------------------------------------
+
+********************************************************************
+The mailman newsyslog.conf(5) filename has been changed:
+ OLD: ${PREFIX}/etc/newsyslog.conf.d/mailman.newsyslog
+ NEW: ${PREFIX}/etc/newsyslog.conf.d/mailman.conf
+
+Any file found at the old location has been automatically moved to
+the new location. This was done to ensure log rotation continued to
+work after change r340318 made to FreeBSD base, where the default
+newsyslog configuration now only includes filenames that end with
+'.conf' and do not begin with '.'.
+
+If you use provisioning/configuration management tools to create or
+edit this file, you will need to change their configuration to use
+the new filename.
+********************************************************************
diff --git a/mail/mailman/pkg-plist b/mail/mailman/pkg-plist
index fd7cc2cb979e..f04a4b9a55f4 100644
--- a/mail/mailman/pkg-plist
+++ b/mail/mailman/pkg-plist
@@ -1,7 +1,7 @@
@postunexec if cmp -s %D/%%MMDIR%%/Mailman/mm_cfg.py %D/%%MMDIR%%/Mailman/mm_cfg.py.dist; then rm -f %D/%%MMDIR%%/Mailman/mm_cfg.py; fi
@postunexec rm -f %D/%%MMDIR%%/Mailman/mm_cfg.pyc
@dir etc/newsyslog.conf.d
-@sample %%EXAMPLESDIR%%/mailman.newsyslog.sample etc/newsyslog.conf.d/mailman.newsyslog
+@sample %%EXAMPLESDIR%%/mailman.newsyslog.sample etc/newsyslog.conf.d/mailman.conf
%%IMGDIR%%/mailman-large.jpg
%%IMGDIR%%/gnu-head-tiny.jpg
%%IMGDIR%%/mailman.jpg