aboutsummaryrefslogtreecommitdiff
path: root/mail/mailmgr/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-02-18 09:17:04 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-02-18 09:17:04 +0000
commit75a39de023017024ce43c21b6c95554091f051ac (patch)
tree4fcea31992cc0d7b3c24ff90887c6d0841bd7c76 /mail/mailmgr/Makefile
parent58a0882a1b8a016a9f51091f7daeb51c95debb17 (diff)
downloadports-75a39de023017024ce43c21b6c95554091f051ac.tar.gz
ports-75a39de023017024ce43c21b6c95554091f051ac.zip
Notes
Diffstat (limited to 'mail/mailmgr/Makefile')
-rw-r--r--mail/mailmgr/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/mail/mailmgr/Makefile b/mail/mailmgr/Makefile
index 4b3bdeb6e0db..ac87f20bb154 100644
--- a/mail/mailmgr/Makefile
+++ b/mail/mailmgr/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: mailmgr
# Date created: 14 August 2003
-# Whom: Hsin-HSIUNG CHANG
+# Whom: Hsin-Hsiung Chang
#
# $FreeBSD$
#
@@ -14,9 +14,13 @@ MAINTAINER= sexbear@tmu.edu.tw
COMMENT= Sendmail Analisys Report Generator
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX}
do-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_DATA} ${WRKSRC}/mailmgr.conf ${PREFIX}/etc/mailmgr.conf.default
+.if !exists(${PREFIX}/etc/mailmgr.conf)
+ ${INSTALL_DATA} ${WRKSRC}/mailmgr.conf ${PREFIX}/etc/mailmgr.conf
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/mailmgr ${PREFIX}/bin
+ @${SED} -e 's,PREFIX,${PREFIX},g' ${PKGMESSAGE}
.include <bsd.port.mk>