aboutsummaryrefslogtreecommitdiff
path: root/mail/mailscanner-devel
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-01-09 17:33:15 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-01-09 17:33:15 +0000
commit1fceb8877412b01c52e144a13d64452d360738b2 (patch)
tree049ce5d7defc89ee059bcc86ed407b4dbe00ecf0 /mail/mailscanner-devel
parent4fa0c4f4d11d6fd169013c8d54cc2718c5c6aade (diff)
downloadports-1fceb8877412b01c52e144a13d64452d360738b2.tar.gz
ports-1fceb8877412b01c52e144a13d64452d360738b2.zip
Notes
Diffstat (limited to 'mail/mailscanner-devel')
-rw-r--r--mail/mailscanner-devel/Makefile18
-rw-r--r--mail/mailscanner-devel/distinfo2
-rw-r--r--mail/mailscanner-devel/files/Sophos.install.freebsd92
-rw-r--r--mail/mailscanner-devel/files/patch-docs:man:MailScanner.82
-rw-r--r--mail/mailscanner-devel/files/patch-docs:man:MailScanner.conf.52
-rw-r--r--mail/mailscanner-devel/pkg-message3
-rw-r--r--mail/mailscanner-devel/pkg-plist3
7 files changed, 116 insertions, 6 deletions
diff --git a/mail/mailscanner-devel/Makefile b/mail/mailscanner-devel/Makefile
index 954c1d56ad6d..9d22d9bf3eb1 100644
--- a/mail/mailscanner-devel/Makefile
+++ b/mail/mailscanner-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= MailScanner
-PORTVERSION= 4.26.1
-PORTREVISION= 1
+PORTVERSION= 4.26.4
CATEGORIES= mail
MASTER_SITES= http://www.sng.ecs.soton.ac.uk/mailscanner/files/4/tar/
PKGNAMESUFFIX= -devel
@@ -29,7 +28,9 @@ BUILD_DEPENDS= \
RUN_DEPENDS= ${BUILD_DEPENDS} \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2 \
- ${LOCALBASE}/bin/tnef:${PORTSDIR}/converters/tnef
+ ${LOCALBASE}/bin/tnef:${PORTSDIR}/converters/tnef \
+ ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
CONFLICTS= MailScanner-[0-9]*
@@ -82,6 +83,15 @@ do-build:
${WRKSRC}/lib/MailScanner/ConfigDefs.pl
${PERL} -pi \
-e 's,/bin/sed,/usr/bin/sed,g;' ${WRKSRC}/lib/MailScanner/SystemDefs.pm
+ ${PERL} -pi -e \
+ 's,/usr/bin/clamscan,${LOCALBASE}/bin/clamscan,g;' \
+ ${WRKSRC}/lib/clamav-wrapper
+ ${PERL} -pi -e \
+ 's,/usr/bin/wget,${LOCALBASE}/bin/wget,g;' \
+ ${WRKSRC}/lib/sophos-autoupdate
+ ${PERL} -pi -e \
+ 's,/usr/bin/unzip,${LOCALBASE}/bin/unzip,g;' \
+ ${WRKSRC}/lib/sophos-autoupdate
do-install:
# Step 1: Install libexec files
@@ -148,6 +158,8 @@ do-install:
cd ${WRKSRC}/docs/man && \
${INSTALL_MAN} ${MAN5} ${MAN5PREFIX}/man/man5 && \
${INSTALL_MAN} ${MAN8} ${MAN8PREFIX}/man/man8
+ # Sophos install script
+ ${INSTALL_SCRIPT} ${FILESDIR}/Sophos.install.freebsd ${DOCSDIR}
.if exists(${PREFIX}/etc/MailScanner/MailScanner.conf)
# Upgrading MailScanner.conf file... Please wait
@${WRKSRC}/bin/upgrade_MailScanner_conf \
diff --git a/mail/mailscanner-devel/distinfo b/mail/mailscanner-devel/distinfo
index 0b0b0d310bdf..54429feb7913 100644
--- a/mail/mailscanner-devel/distinfo
+++ b/mail/mailscanner-devel/distinfo
@@ -1 +1 @@
-MD5 (MailScanner-4.26-1.tar.gz) = 96efae6f60d1cff764151a6c10298088
+MD5 (MailScanner-4.26-4.tar.gz) = 6c7ef8fe632f9f490bc63ef5a8972c43
diff --git a/mail/mailscanner-devel/files/Sophos.install.freebsd b/mail/mailscanner-devel/files/Sophos.install.freebsd
new file mode 100644
index 000000000000..f1df49606e82
--- /dev/null
+++ b/mail/mailscanner-devel/files/Sophos.install.freebsd
@@ -0,0 +1,92 @@
+#!/usr/local/bin/bash
+#
+# $Id: Sophos.install,v 1.13.2.3 2003/06/07 17:20:39 jkf Exp $
+#
+# Run this script to install Sophos in the right place, with the right
+# options for the MailScanner.
+# Run this script from inside the directory in which you have copied
+# and unpacked the Sophos distribution.
+# Tweaked for FreeBSD.
+
+SOPHOS=/usr/local/Sophos
+SCRIPTS=/usr/local/libexec/MailScanner
+COMPD=freebsd.elf.tar.Z
+DISTRIB=freebsd.elf.tar
+
+mkdir -p ${SOPHOS}
+chown -R root ${SOPHOS}
+chmod -R go+rX ${SOPHOS}
+
+# Clear out any old libs from /usr/local/lib which is where
+# a default SAVI installation will have left them
+echo Clearing out old default Sophos installation libraries
+rm -f /usr/local/lib/libsavi.so*
+
+# Have we got to uncompress the distribution for them?
+if [ -f $COMPD ]; then
+ echo Uncompressing Sophos distribution
+ uncompress $COMPD
+fi
+
+# Have we got to unpack the distribution for them?
+if [ -f $DISTRIB ]; then
+ # Is there an old unpacked distribution here too??
+ if [ -d sav-install ]; then
+ echo Clearing out unpacked distribution
+ rm -rf sav-install
+ fi
+ # Unpack the distribution
+ echo Unpacking distribution
+ tar xBf $DISTRIB
+fi
+
+# JKF 31/08/2001 Remove any existing vdl.dat files
+if [ -f ${SOPHOS}/lib/vdl.dat ]; then
+ rm -f ${SOPHOS}/lib/vdl*
+fi
+if [ -f ${SOPHOS}/lib/vdln.dat ]; then
+ rm -f ${SOPHOS}/lib/vdl*
+fi
+if [ -f ${SOPHOS}/lib/vdl01.vdb ]; then
+ rm -f ${SOPHOS}/lib/vdl*
+fi
+
+# Are we in the right directory, or one above it?
+if [ -d sav-install ]; then
+ cd sav-install
+fi
+
+# Check we have found the install.sh script
+if [ \! -f install.sh ]; then
+ echo Please cd into the directory containing the Sophos install.sh
+ echo script and run this command again.
+ exit 1
+fi
+
+echo Installing Sophos for MailScanner
+./install.sh -v -d ${SOPHOS} -s lib -ni
+
+if [ -f /etc/sav.conf ]; then
+ echo Removing troublesome and useless configuration file /etc/sav.conf
+ rm -f /etc/sav.conf
+fi
+
+echo Creating links so Perl-SAVI module compiles
+[ -e ${SOPHOS}/lib/libsavi.so.2 ] && ln -sf libsavi.so.2 ${SOPHOS}/lib/libsavi.so
+[ -e ${SOPHOS}/lib/libsavi.so.3 ] && ln -sf libsavi.so.3 ${SOPHOS}/lib/libsavi.so
+
+echo
+echo Fetching latest IDE virus identities from www.sophos.com
+${SCRIPTS}/sophos-autoupdate
+
+if [ -f ${SCRIPTS}/sophos-wrapper ]; then
+ chmod a=rx ${SCRIPTS}/sophos-wrapper
+ echo Done.
+else
+ echo Something has gone wrong. There should be a copy of the
+ echo script sophos-wrapper in the directory ${SCRIPTS}.
+ echo Please re-install the MailScanner or fetch another copy of
+ echo sophoswrapper from the distribution web site.
+fi
+
+exit 0
diff --git a/mail/mailscanner-devel/files/patch-docs:man:MailScanner.8 b/mail/mailscanner-devel/files/patch-docs:man:MailScanner.8
index 4eab5bbb1e9b..676b7c4a1b72 100644
--- a/mail/mailscanner-devel/files/patch-docs:man:MailScanner.8
+++ b/mail/mailscanner-devel/files/patch-docs:man:MailScanner.8
@@ -2,7 +2,7 @@
+++ docs/man/MailScanner.8 Tue Dec 2 22:23:08 2003
@@ -1,4 +1,4 @@
-.TH "MailScanner" "8" "4.25-10" "Julian Field" "Mail"
-+.TH "MailScanner" "8" "4.26-1" "Julian Field" "Mail"
++.TH "MailScanner" "8" "4.26-3" "Julian Field" "Mail"
.SH "NAME"
.LP
MailScanner \- Virus/Spam Scanner for Sendmail and Exim
diff --git a/mail/mailscanner-devel/files/patch-docs:man:MailScanner.conf.5 b/mail/mailscanner-devel/files/patch-docs:man:MailScanner.conf.5
index 4c10c32bb3d7..8e03c558f9c1 100644
--- a/mail/mailscanner-devel/files/patch-docs:man:MailScanner.conf.5
+++ b/mail/mailscanner-devel/files/patch-docs:man:MailScanner.conf.5
@@ -2,7 +2,7 @@
+++ docs/man/MailScanner.conf.5 Tue Dec 2 22:23:08 2003
@@ -1,4 +1,4 @@
-.TH "MailScanner.conf" "5" "4.25-10" "Julian Field" "Mail"
-+.TH "MailScanner.conf" "5" "4.26-1" "Julian Field" "Mail"
++.TH "MailScanner.conf" "5" "4.26-3" "Julian Field" "Mail"
.SH "NAME"
.LP
MailScanner.conf \- Main configuration for MailScanner
diff --git a/mail/mailscanner-devel/pkg-message b/mail/mailscanner-devel/pkg-message
index 7c4e356d71a7..125ed173ca23 100644
--- a/mail/mailscanner-devel/pkg-message
+++ b/mail/mailscanner-devel/pkg-message
@@ -31,4 +31,7 @@
to update your virus-wrappers, autoupdates, reports and
languages.conf
+ Sophos users: Please take a look at the Sophos install
+ script %%PREFIX%%/share/doc/MailScanner/Sophos.install.freebsd
+
*************************************************************************
diff --git a/mail/mailscanner-devel/pkg-plist b/mail/mailscanner-devel/pkg-plist
index cc28dd827e3f..2fd7f3b670f4 100644
--- a/mail/mailscanner-devel/pkg-plist
+++ b/mail/mailscanner-devel/pkg-plist
@@ -380,6 +380,7 @@ libexec/MailScanner/update_virus_scanners
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD.port
%%PORTDOCS%%%%DOCSDIR%%/README.sql-logging
+%%PORTDOCS%%%%DOCSDIR%%/Sophos.install.freebsd
%%PORTDOCS%%%%DOCSDIR%%/building.txt
%%PORTDOCS%%%%DOCSDIR%%/donations.shtml
%%PORTDOCS%%%%DOCSDIR%%/downloadgraphs.shtml
@@ -410,8 +411,10 @@ libexec/MailScanner/update_virus_scanners
%%PORTDOCS%%%%DOCSDIR%%/install/mcafee.shtml
%%PORTDOCS%%%%DOCSDIR%%/install/mcp/Conf.pm.patch.2.55
%%PORTDOCS%%%%DOCSDIR%%/install/mcp/Conf.pm.patch.2.60
+%%PORTDOCS%%%%DOCSDIR%%/install/mcp/Conf.pm.patch.2.61
%%PORTDOCS%%%%DOCSDIR%%/install/mcp/PerMsgStatus.pm.patch.2.55
%%PORTDOCS%%%%DOCSDIR%%/install/mcp/PerMsgStatus.pm.patch.2.60
+%%PORTDOCS%%%%DOCSDIR%%/install/mcp/PerMsgStatus.pm.patch.2.61
%%PORTDOCS%%%%DOCSDIR%%/install/mcp/index.html
%%PORTDOCS%%%%DOCSDIR%%/install/mime-tools-patch.txt
%%PORTDOCS%%%%DOCSDIR%%/install/mime-tools-patch2.txt