aboutsummaryrefslogtreecommitdiff
path: root/mail/mailscanner/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-05 15:34:38 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-05 15:34:38 +0000
commitd7195690d7a6dd8ff01e9b444e4d37d23d0e8377 (patch)
treefbf5c83202a671063c89b7d5c5ad647d7299dad7 /mail/mailscanner/Makefile
parenta72d9a77dfdb71a9d61c6cb325e3d1b6f5fd55df (diff)
downloadports-d7195690d7a6dd8ff01e9b444e4d37d23d0e8377.tar.gz
ports-d7195690d7a6dd8ff01e9b444e4d37d23d0e8377.zip
Notes
Diffstat (limited to 'mail/mailscanner/Makefile')
-rw-r--r--mail/mailscanner/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/mail/mailscanner/Makefile b/mail/mailscanner/Makefile
index 1deb5655fcb7..c0098f299199 100644
--- a/mail/mailscanner/Makefile
+++ b/mail/mailscanner/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= mailscanner
-PORTVERSION= 4.24.5
+PORTVERSION= 4.25.14
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.sng.ecs.soton.ac.uk/mailscanner/files/4/tar/
-DISTNAME= MailScanner-4.24-5
+DISTNAME= MailScanner-4.25-14
MAINTAINER= j.koopmann@seceidos.de
COMMENT= Powerful virus/spam scanning framework for Sendmail/Exim
@@ -22,9 +23,13 @@ BUILD_DEPENDS= \
${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
- ${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF
+ ${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
+ ${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net/p5-Net-CIDR
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2
+
+CONFLICTS= MailScanner-devel-*
USE_PERL5= yes
@@ -65,7 +70,7 @@ do-build:
's,/opt/MailScanner/lib,'${PREFIX}'/libexec/MailScanner,g; \
s,/bin/false,/usr/bin/false,;' ${WRKSRC}/etc/virus.scanners.conf
${PERL} -pi -e \
- 's,/bin/bash,'${PREFIX}'/bash,g; \
+ 's,/bin/bash,'${LOCALBASE}'/bin/bash,g; \
s,/opt/MailScanner/etc,'${PREFIX}'/etc/MailScanner,g;' \
${WRKSRC}/bin/update_virus_scanners
${PERL} -pi -e \