aboutsummaryrefslogtreecommitdiff
path: root/mail/mairix
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-27 11:49:20 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-27 11:49:20 +0000
commit1309964973f4ed252a01d8db81bea67008657f64 (patch)
tree09aa54b9c72633a9d6712b56ae82fdf470c1337b /mail/mairix
parentc831bf23e4bc70dde9a2bfe3675a536fd09a8610 (diff)
downloadports-1309964973f4ed252a01d8db81bea67008657f64.tar.gz
ports-1309964973f4ed252a01d8db81bea67008657f64.zip
Notes
Diffstat (limited to 'mail/mairix')
-rw-r--r--mail/mairix/Makefile50
1 files changed, 26 insertions, 24 deletions
diff --git a/mail/mairix/Makefile b/mail/mairix/Makefile
index 1e6cb5cbf8a0..f057b1478657 100644
--- a/mail/mairix/Makefile
+++ b/mail/mairix/Makefile
@@ -9,40 +9,42 @@ MASTER_SITES= SF
MAINTAINER= jjuanino@gmail.com
COMMENT= Indexing and searching in Maildir, MH, or mbox folders
-USE_GMAKE= yes
+LICENSE= GPLv2
+
+USES= bison gmake
HAS_CONFIGURE= yes
-USES= bison
-MAN1= mairix.1
-MAN5= mairixrc.5
-PLIST_FILES= bin/mairix %%EXAMPLESDIR%%/dotmairixrc.eg
-PLIST_DIRS= %%EXAMPLESDIR%%
+MAN1= mairix.1
+MAN5= mairixrc.5
+PORTDOCS= NEWS README
+PORTEXAMPLES= dotmairixrc.eg
+PLIST_FILES= bin/mairix
-OPTIONS_DEFINE= GZIP BZIP
-GZIP_DESC= Enable gzip mbox support
-BZIP_DESC= Enable bzip2 mbox support
+OPTIONS_DEFINE= GZIP BZIP2 EXAMPLES DOCS
+GZIP_DESC= gzip compressed mbox support
+BZIP2_DESC= bzip2 compressed mbox support
-OPTIONS_DEFAULT=
+GZIP_CONFIGURE_ENABLE= gzip-mbox
+BZIP2_CONFIGURE_ENABLE= bzip-mbox
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGZIP}
-CONFIGURE_ARGS+= --enable-gzip-mbox
-.else
-CONFIGURE_ARGS+= --disable-gzip-mbox
-.endif
-
-.if ${PORT_OPTIONS:MBZIP}
-CONFIGURE_ARGS+= --enable-bzip-mbox
-.else
-CONFIGURE_ARGS+= --disable-bzip-mbox
-.endif
+# Do not hardcode make(1) binary name and fix atomicity to allow -jX builds
+post-patch:
+ @${REINPLACE_CMD} -E 's|cd (.+) ; make|$$(MAKE) -C \1|' \
+ ${WRKSRC}/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mairix ${PREFIX}/bin
- ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/mairix.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/mairixrc.5 ${MANPREFIX}/man/man5
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${WRKSRC}/README ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/dotmairixrc.eg ${EXAMPLESDIR}
- ${INSTALL_MAN} ${WRKSRC}/mairix.1 ${PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/mairixrc.5 ${PREFIX}/man/man5
+.endif
.include <bsd.port.mk>