aboutsummaryrefslogtreecommitdiff
path: root/mail/masqmail-devel/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-02 20:38:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-02 20:38:48 +0000
commit4931ba8bee0f6be3855b5446443afd3ee4650212 (patch)
tree10d2b30e729421f3b1c44d4ec3c115fbcf0cf830 /mail/masqmail-devel/Makefile
parentdabf5e1b03331f616f0e64ed0bffd9ae36a7b82e (diff)
Notes
Diffstat (limited to 'mail/masqmail-devel/Makefile')
-rw-r--r--mail/masqmail-devel/Makefile73
1 files changed, 73 insertions, 0 deletions
diff --git a/mail/masqmail-devel/Makefile b/mail/masqmail-devel/Makefile
new file mode 100644
index 000000000000..bf4ac5298286
--- /dev/null
+++ b/mail/masqmail-devel/Makefile
@@ -0,0 +1,73 @@
+# Ports collection makefile for: masqmail-devel
+# Date created: 4 Apr 2004
+# Whom: Andrey Slusar <vasallia@ukr.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= masqmail
+PORTVERSION= 0.2.20
+CATEGORIES= mail
+MASTER_SITES= http://innominate.org/kurth/masqmail/download/
+
+MAINTAINER= vasallia@ukr.net
+COMMENT= Mail server for hosts, not permanently connected to the internet
+
+MAN5= masqmail.aliases.5 masqmail.conf.5 masqmail.get.5 masqmail.route.5
+MAN8= masqmail.8 mservdetect.8
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --mandir=${PREFIX}/man --with-user=mailnull --with-group=mail \
+ --with-confdir=${PREFIX}/etc/masqmail --with-logdir=/var/log/masqmail
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.if defined(WITH_LIBCRYPTO)
+CONFIGURE_ARGS+= --with-libcrypto
+.endif
+.if defined(WITHOUT_POP3)
+CONFIGURE_ARGS+= --disable-pop3
+.endif
+.if defined(WITHOUT_SMTP)
+CONFIGURE_ARGS+= --disable-smtp-server
+.endif
+.if defined(WITHOUT_RESOLVER)
+CONFIGURE_ARGS+= --disable-resolver
+.endif
+.if defined(WITH_MAILDIR)
+CONFIGURE_ARGS+= --enable-maildir
+.endif
+.if defined(WITH_MSERVER)
+CONFIGURE_ARGS+= --enable-mserver
+.endif
+.if defined(WITH_AUTH)
+CONFIGURE_ARGS+= --enable-auth
+.endif
+.if defined(WITH_IDENT)
+CONFIGURE_ARGS+= --enable-ident
+.endif
+
+USE_GNOME= glib12
+USE_RC_SUBR= yes
+NO_LATEST_LINK= yes
+
+post-build:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
+ ${FILESDIR}/masqmail.sh > ${WRKDIR}/masqmail.sh
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/masqmail.sh ${PREFIX}/etc/rc.d/masqmail.sh
+ ${MKDIR} ${PREFIX}/etc/masqmail
+ ${CHOWN} mailnull:mail ${PREFIX}/etc/masqmail
+ ${INSTALL_DATA} -o mailnull -g mail ${WRKSRC}/examples/masqmail.conf ${PREFIX}/etc/masqmail/masqmail.conf-dist
+ ${INSTALL_DATA} -o mailnull -g mail ${WRKSRC}/examples/example.get ${PREFIX}/etc/masqmail/masqmail.get-dist
+ ${INSTALL_DATA} -o mailnull -g mail ${WRKSRC}/examples/example.route ${PREFIX}/etc/masqmail/masqmail.route-dist
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in AUTHORS COPYING INSTALL NEWS README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>