aboutsummaryrefslogtreecommitdiff
path: root/mail/masqmail
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2009-05-24 08:43:21 +0000
committerAndrey Slusar <anray@FreeBSD.org>2009-05-24 08:43:21 +0000
commit84cbeab72e8ca1e0c29c028f684a610aa4ee261e (patch)
tree57511c685544a266b1b74a7333329d559b2610df /mail/masqmail
parente587f586818e7feffc64dd1333ecd9dd43b46adb (diff)
downloadports-84cbeab72e8ca1e0c29c028f684a610aa4ee261e.tar.gz
ports-84cbeab72e8ca1e0c29c028f684a610aa4ee261e.zip
Notes
Diffstat (limited to 'mail/masqmail')
-rw-r--r--mail/masqmail/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/mail/masqmail/Makefile b/mail/masqmail/Makefile
index 2f4e6d73a881..b4a4ece2de99 100644
--- a/mail/masqmail/Makefile
+++ b/mail/masqmail/Makefile
@@ -20,6 +20,8 @@ MAN5= masqmail.aliases.5 masqmail.conf.5 masqmail.get.5 masqmail.route.5
MAN8= masqmail.8 mservdetect.8
.endif
+USE_GNOME= glib20
+USE_RC_SUBR= masqmail
GNU_CONFIGURE= yes
CFLAGS+= -Wno-trigraphs
CONFIGURE_ARGS+= --with-user=mailnull --with-group=mail \
@@ -30,6 +32,17 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= AUTHORS COPYING INSTALL NEWS README TODO
.endif
+OPTIONS += LIBCRYPTO "Use libcrypto" on
+OPTIONS += POP3 "Enable POP3" on
+OPTIONS += SMTP "Enable SMTP server" on
+OPTIONS += Resolver "Resolver" on
+OPTIONS += MAILDIR "Maildir support" on
+OPTIONS += MSERVER "Enable mserver support" off
+OPTIONS += AUTH "SMTP AUTH (RFC2554) support" on
+OPTIONS += IDENT "Ident (RFC 1413) support" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_LIBCRYPTO)
CONFIGURE_ARGS+= --with-libcrypto
.endif
@@ -55,9 +68,6 @@ CONFIGURE_ARGS+= --enable-auth
CONFIGURE_ARGS+= --enable-ident
.endif
-USE_GNOME= glib20
-USE_RC_SUBR= masqmail
-
post-install:
${MKDIR} ${PREFIX}/etc/masqmail
${CHOWN} mailnull:mail ${PREFIX}/etc/masqmail
@@ -72,4 +82,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>