aboutsummaryrefslogtreecommitdiff
path: root/mail/mboxgrep/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-30 22:49:54 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-30 22:49:54 +0000
commit60d0e9fd8dd627e2fa08e68f8d94004c37576993 (patch)
tree4dfc3b273f29f8d63ce582fb7e60307fee4a65f0 /mail/mboxgrep/Makefile
parent2dda46c5dd85bb5d8ae6d864c3ca2f35d02b36c8 (diff)
downloadports-60d0e9fd8dd627e2fa08e68f8d94004c37576993.tar.gz
ports-60d0e9fd8dd627e2fa08e68f8d94004c37576993.zip
Notes
Diffstat (limited to 'mail/mboxgrep/Makefile')
-rw-r--r--mail/mboxgrep/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/mail/mboxgrep/Makefile b/mail/mboxgrep/Makefile
new file mode 100644
index 000000000000..c8b1f1b5b49a
--- /dev/null
+++ b/mail/mboxgrep/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mboxgrep
+# Date created: 28 October 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mboxgrep
+PORTVERSION= 0.7.0
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= anders@fix.no
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= mboxgrep.1
+
+DOCS= ChangeLog NEWS README TODO
+
+post-install:
+ install-info ${PREFIX}/info/mboxgrep.info ${PREFIX}/info/dir
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>