aboutsummaryrefslogtreecommitdiff
path: root/mail/mess822
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-02-05 07:23:54 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-02-05 07:23:54 +0000
commit66a8bdb9289e743c2ee77709b4ddfb4d55e92534 (patch)
treeea514d5bfb5f6f16c5db1820d58b669c3c5b4e9b /mail/mess822
parent7fde131c0ac5bc14a3d92d09652bd525a523ae1d (diff)
downloadports-66a8bdb9289e743c2ee77709b4ddfb4d55e92534.tar.gz
ports-66a8bdb9289e743c2ee77709b4ddfb4d55e92534.zip
Notes
Diffstat (limited to 'mail/mess822')
-rw-r--r--mail/mess822/Makefile49
-rw-r--r--mail/mess822/distinfo1
-rw-r--r--mail/mess822/files/patch-aa53
-rw-r--r--mail/mess822/pkg-comment1
-rw-r--r--mail/mess822/pkg-descr23
-rw-r--r--mail/mess822/pkg-plist12
6 files changed, 139 insertions, 0 deletions
diff --git a/mail/mess822/Makefile b/mail/mess822/Makefile
new file mode 100644
index 000000000000..54eef2f5c8a3
--- /dev/null
+++ b/mail/mess822/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: mess822
+# Date created: 4 February 2001
+# Whom: David Siebörger <drs@rucus.ru.ac.za>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mess822
+PORTVERSION= 0.58
+CATEGORIES= mail
+MASTER_SITES= http://cr.yp.to/software/ \
+ ftp://ftp.qmail.org/pub/software/
+
+MAINTAINER= drs@rucus.ru.ac.za
+
+RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
+
+NO_PACKAGE= Violates djb\'s license
+
+ALL_TARGET= it
+INSTALL_TARGET= setup check
+
+MAN1= 822date.1 822field.1 822header.1 822print.1 822received.1 \
+ iftocc.1 new-inject.1
+MAN3= mess822.3 mess822_addr.3 mess822_date.3 mess822_fold.3 \
+ mess822_quote.3 mess822_token.3 mess822_when.3
+MAN5= rewriting.5
+MAN8= ofmipd.8 ofmipname.8
+
+.if exists(${PREFIX}/qmail/bin/qmail-send)
+QMAIL_DIR?= ${PREFIX}/qmail
+.else
+QMAIL_DIR?= /var/qmail
+.endif
+
+NO_MTREE= yes
+
+post-patch:
+ @perl -pi.bak -e "s|-O2|${CFLAGS}|" ${WRKSRC}/conf-cc
+ @perl -pi.bak -e "s|.var.qmail|${QMAIL_DIR}|" ${WRKSRC}/conf-qmail
+ @echo '${PREFIX}' > ${WRKSRC}/conf-home
+
+#do-build:
+# @cd ${WRKSRC} && make ${ALL_TARGET}
+#
+#do-install:
+# @cd ${WRKSRC} && make ${INSTALL_TARGET}
+
+.include <bsd.port.mk>
diff --git a/mail/mess822/distinfo b/mail/mess822/distinfo
new file mode 100644
index 000000000000..452d7137685b
--- /dev/null
+++ b/mail/mess822/distinfo
@@ -0,0 +1 @@
+MD5 (mess822-0.58.tar.gz) = 8ce4c29c994a70dcaa30140601213dbe
diff --git a/mail/mess822/files/patch-aa b/mail/mess822/files/patch-aa
new file mode 100644
index 000000000000..e1c86d5ee3df
--- /dev/null
+++ b/mail/mess822/files/patch-aa
@@ -0,0 +1,53 @@
+*** hier.c.orig Sun Feb 4 16:12:16 2001
+--- hier.c Sun Feb 4 16:13:07 2001
+***************
+*** 12,21 ****
+ d(auto_home,"man/man3",-1,-1,02755);
+ d(auto_home,"man/man5",-1,-1,02755);
+ d(auto_home,"man/man8",-1,-1,02755);
+! d(auto_home,"man/cat1",-1,-1,02755);
+! d(auto_home,"man/cat3",-1,-1,02755);
+! d(auto_home,"man/cat5",-1,-1,02755);
+! d(auto_home,"man/cat8",-1,-1,02755);
+
+ c(auto_home,"lib","mess822.a",-1,-1,0644);
+ c(auto_home,"include","mess822.h",-1,-1,0644);
+--- 12,18 ----
+ d(auto_home,"man/man3",-1,-1,02755);
+ d(auto_home,"man/man5",-1,-1,02755);
+ d(auto_home,"man/man8",-1,-1,02755);
+! d(auto_home,"etc",-1,-1,02755);
+
+ c(auto_home,"lib","mess822.a",-1,-1,0644);
+ c(auto_home,"include","mess822.h",-1,-1,0644);
+***************
+*** 48,70 ****
+ c(auto_home,"man/man3","mess822_token.3",-1,-1,0644);
+ c(auto_home,"man/man3","mess822_when.3",-1,-1,0644);
+
+! c(auto_home,"man/cat1","iftocc.0",-1,-1,0644);
+! c(auto_home,"man/cat1","new-inject.0",-1,-1,0644);
+! c(auto_home,"man/cat1","822field.0",-1,-1,0644);
+! c(auto_home,"man/cat1","822header.0",-1,-1,0644);
+! c(auto_home,"man/cat1","822date.0",-1,-1,0644);
+! c(auto_home,"man/cat1","822received.0",-1,-1,0644);
+! c(auto_home,"man/cat1","822print.0",-1,-1,0644);
+! c(auto_home,"man/cat5","rewriting.0",-1,-1,0644);
+! c(auto_home,"man/cat8","ofmipd.0",-1,-1,0644);
+! c(auto_home,"man/cat8","ofmipname.0",-1,-1,0644);
+! c(auto_home,"man/cat3","mess822.0",-1,-1,0644);
+! c(auto_home,"man/cat3","mess822_addr.0",-1,-1,0644);
+! c(auto_home,"man/cat3","mess822_date.0",-1,-1,0644);
+! c(auto_home,"man/cat3","mess822_fold.0",-1,-1,0644);
+! c(auto_home,"man/cat3","mess822_quote.0",-1,-1,0644);
+! c(auto_home,"man/cat3","mess822_token.0",-1,-1,0644);
+! c(auto_home,"man/cat3","mess822_when.0",-1,-1,0644);
+!
+! c("/etc",".","leapsecs.dat",-1,-1,0644);
+ }
+--- 45,49 ----
+ c(auto_home,"man/man3","mess822_token.3",-1,-1,0644);
+ c(auto_home,"man/man3","mess822_when.3",-1,-1,0644);
+
+! c(auto_home,"etc","leapsecs.dat",-1,-1,0644);
+ }
diff --git a/mail/mess822/pkg-comment b/mail/mess822/pkg-comment
new file mode 100644
index 000000000000..322407fc6d47
--- /dev/null
+++ b/mail/mess822/pkg-comment
@@ -0,0 +1 @@
+RFC 822 mail message parsing library and rewriting utilities
diff --git a/mail/mess822/pkg-descr b/mail/mess822/pkg-descr
new file mode 100644
index 000000000000..11b7e665c20a
--- /dev/null
+++ b/mail/mess822/pkg-descr
@@ -0,0 +1,23 @@
+mess822 is a library for parsing Internet mail messages. The mess822
+package contains several applications that work with qmail:
+ * ofmipd rewrites messages from dumb clients. It supports a database
+ of recognized senders and From lines, using cdb for fast lookups.
+ * new-inject is an experimental new version of qmail-inject. It
+ includes a flexible user-controlled hostname rewriting mechanism.
+ * iftocc can be used in .qmail files. It checks whether a known
+ address is listed in To or Cc.
+ * 822header, 822field, 822date, and 822received extract various
+ pieces of information from a mail message.
+ * 822print converts a message into an easier-to-read format.
+
+mess822 supports the full complexity of RFC 822 address lists, including
+address groups, source routes, spaces around dots, etc. It also supports
+common RFC 822 extensions: backslashes in atoms, dots in phrases,
+addresses without host names, etc. It extracts each address as an
+easy-to-use string, with a separate string for the accompanying comment.
+
+mess822 converts RFC 822 dates into libtai's struct caltime format. It
+supports numeric time zones, the standard old-fashioned time zones, and
+many nonstandard time zones.
+
+WWW: http://cr.yp.to/mess822.html
diff --git a/mail/mess822/pkg-plist b/mail/mess822/pkg-plist
new file mode 100644
index 000000000000..6861e98fdd30
--- /dev/null
+++ b/mail/mess822/pkg-plist
@@ -0,0 +1,12 @@
+lib/mess822.a
+bin/ofmipd
+bin/ofmipname
+bin/iftocc
+bin/new-inject
+bin/822field
+bin/822header
+bin/822date
+bin/822received
+bin/822print
+include/mess822.h
+etc/leapsecs.dat