aboutsummaryrefslogtreecommitdiff
path: root/mail/metamail/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-06-12 09:08:46 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-06-12 09:08:46 +0000
commit5ffabe9ffb95eb65d2e1c30b93b993e09dea15d1 (patch)
tree7aaea5c8be77e038029bd7089622da28c0271285 /mail/metamail/Makefile
parenta758c254986484172108d30932b07bc14aa36152 (diff)
downloadports-5ffabe9ffb95eb65d2e1c30b93b993e09dea15d1.tar.gz
ports-5ffabe9ffb95eb65d2e1c30b93b993e09dea15d1.zip
Notes
Diffstat (limited to 'mail/metamail/Makefile')
-rw-r--r--mail/metamail/Makefile25
1 files changed, 19 insertions, 6 deletions
diff --git a/mail/metamail/Makefile b/mail/metamail/Makefile
index 88d1d06e1305..07c5f4ee3a59 100644
--- a/mail/metamail/Makefile
+++ b/mail/metamail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= metamail
PORTVERSION= 2.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= http://ftp.funet.fi/pub/unix/mail/metamail/ \
ftp://ftp.research.telcordia.com/pub/nsb/
@@ -17,11 +17,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= jean-francois.dockes@wanadoo.fr
COMMENT= Implementation of MIME, the Multipurpose Internet Mail Extensions
-BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
-RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage \
- mkfontdir:${X_CLIENTS_PORT}
+OPTIONS= X11 "X11 hebrew font support" on
-USE_XLIB= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
MAN1= audiocompose.1 audiosend.1 extcompose.1 \
getfilename.1 mailto-hebrew.1 mailto.1 metamail.1 \
@@ -31,7 +28,23 @@ MAN1= audiocompose.1 audiosend.1 extcompose.1 \
showpicture.1 splitmail.1
MAN4= mailcap.4
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_X11)
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+USE_XLIB= yes
+PLIST_SUB+= X11=""
+.else
+PLIST_SUB+= X11="@comment "
+.endif
+
post-patch:
+.if defined(WITHOUT_X11)
+ @${REINPLACE_CMD} -e '/fonts/d' ${WRKSRC}/Makefile
+.endif
@${RM} ${WRKSRC}/bin/*.orig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>