aboutsummaryrefslogtreecommitdiff
path: root/mail/mew/files
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2008-06-23 18:53:31 +0000
committerAndrey Slusar <anray@FreeBSD.org>2008-06-23 18:53:31 +0000
commitc8338dd7652002d347c1b189798737c04874c4b5 (patch)
treee2b46cc53e930509c47c474db0b2f03cbef5ec26 /mail/mew/files
parent71c12f78ad55d1723b5b6f9973e7993136620f53 (diff)
downloadports-c8338dd7652002d347c1b189798737c04874c4b5.tar.gz
ports-c8338dd7652002d347c1b189798737c04874c4b5.zip
Notes
Diffstat (limited to 'mail/mew/files')
-rw-r--r--mail/mew/files/patch-bin_Makefile.in14
-rw-r--r--mail/mew/files/patch-mew-key.el23
-rw-r--r--mail/mew/files/pkg-message.in15
3 files changed, 26 insertions, 26 deletions
diff --git a/mail/mew/files/patch-bin_Makefile.in b/mail/mew/files/patch-bin_Makefile.in
index 6552f363cd28..ecad3a7e387c 100644
--- a/mail/mew/files/patch-bin_Makefile.in
+++ b/mail/mew/files/patch-bin_Makefile.in
@@ -1,5 +1,5 @@
---- bin/Makefile.in.orig Mon Oct 23 08:18:23 2006
-+++ bin/Makefile.in Sun Jan 14 19:30:35 2007
+--- bin/Makefile.in.orig 2008-02-18 19:24:27.000000000 +0900
++++ bin/Makefile.in 2008-05-28 15:37:21.000000000 +0900
@@ -25,7 +25,9 @@
COFLAG = -o $@
LIBS = @LIBS@
@@ -11,7 +11,7 @@
LN = ln
RM = rm -f
MKDIR = mkdir -p
-@@ -101,27 +103,27 @@
+@@ -105,31 +107,31 @@
-@if [ ! -d $(DESTDIR)$(bindir) ]; then \
$(MKDIR) $(DESTDIR)$(bindir); \
fi
@@ -25,10 +25,14 @@
- $(INSTALL) -m 555 $(PRG3) $(DESTDIR)$(bindir)
- $(INSTALL) -m 555 $(PRG4) $(DESTDIR)$(bindir)
- $(INSTALL) -m 555 $(PRG5) $(DESTDIR)$(bindir)
+- $(INSTALL) -m 555 $(PRG6) $(DESTDIR)$(bindir)
+- $(INSTALL) -m 555 $(PRG7) $(DESTDIR)$(bindir)
+ ${INSTALL_PROGRAM} $(PRG2) $(DESTDIR)$(bindir)
+ ${INSTALL_PROGRAM} $(PRG3) $(DESTDIR)$(bindir)
+ ${INSTALL_SCRIPT} $(PRG4) $(DESTDIR)$(bindir)
+ ${INSTALL_SCRIPT} $(PRG5) $(DESTDIR)$(bindir)
++ ${INSTALL_SCRIPT} $(PRG6) $(DESTDIR)$(bindir)
++ ${INSTALL_SCRIPT} $(PRG7) $(DESTDIR)$(bindir)
-@if [ ! -d $(DESTDIR)$(mandir) ]; then \
$(MKDIR) $(DESTDIR)$(mandir); \
fi
@@ -42,10 +46,14 @@
- $(INSTALL) -m 444 $(MAN3) $(DESTDIR)$(mandir)
- $(INSTALL) -m 444 $(MAN4) $(DESTDIR)$(mandir)
- $(INSTALL) -m 444 $(MAN5) $(DESTDIR)$(mandir)
+- $(INSTALL) -m 444 $(MAN6) $(DESTDIR)$(mandir)
+- $(INSTALL) -m 444 $(MAN7) $(DESTDIR)$(mandir)
+ ${INSTALL_DATA} $(MAN2) $(DESTDIR)$(mandir)
+ ${INSTALL_DATA} $(MAN3) $(DESTDIR)$(mandir)
+ ${INSTALL_DATA} $(MAN4) $(DESTDIR)$(mandir)
+ ${INSTALL_DATA} $(MAN5) $(DESTDIR)$(mandir)
++ ${INSTALL_DATA} $(MAN6) $(DESTDIR)$(mandir)
++ ${INSTALL_DATA} $(MAN7) $(DESTDIR)$(mandir)
##
## End of Makefile
diff --git a/mail/mew/files/patch-mew-key.el b/mail/mew/files/patch-mew-key.el
deleted file mode 100644
index df2c157c46a3..000000000000
--- a/mail/mew/files/patch-mew-key.el
+++ /dev/null
@@ -1,23 +0,0 @@
---- mew-key.el.orig Thu Jan 4 15:49:11 2007
-+++ mew-key.el Sun Jan 14 19:19:22 2007
-@@ -610,13 +610,16 @@
- ;;;
-
- (defun mew-which-mew-etc ()
-- (let ((file "mew.el")
-- (path load-path))
-+ (let ((file1 "mew.el")
-+ (file2 "Mew.png")
-+ (path (list "%%MEWICONDIR%%" load-path)))
- (catch 'loop
- (while path
-- (if (file-exists-p (expand-file-name file (car path)))
-+ (if (file-exists-p (expand-file-name file1 (car path)))
- (throw 'loop (expand-file-name "etc" (car path)))
-- (setq path (cdr path)))))))
-+ (if (file-exists-p (expand-file-name file2 (car path)))
-+ (throw 'loop (expand-file-name (car path)))
-+ (setq path (cdr path))))))))
-
- (defvar mew-icon-directory (mew-which-mew-etc))
-
diff --git a/mail/mew/files/pkg-message.in b/mail/mew/files/pkg-message.in
new file mode 100644
index 000000000000..c4f6e754fb2f
--- /dev/null
+++ b/mail/mew/files/pkg-message.in
@@ -0,0 +1,15 @@
+*************************************************************************
+You may want to add following lines to your ~/.emacs and/or ~/.mew.el.
+
+ (autoload 'mew "mew" nil t)
+ (autoload 'mew-send "mew" nil t)
+ (setq mew-mail-domain "domain of e-mail address")
+ (setq mew-pop-server "your POP server") ;; if not localhost
+ (setq mew-smtp-server "your SMTP server") ;; if not localhost
+ ;; using fetch for PGP instead of wget
+ (setq mew-prog-pgpkey "fetch")
+ (setq mew-prog-pgpkey-arg '("-q" "-o" "-"))
+
+Please consult sample files %%DOCSDIR%%/mew.dot.{emacs,mew}.
+See also %%DOCSDIR%%/00diff for the changes from previous versions.
+*************************************************************************