aboutsummaryrefslogtreecommitdiff
path: root/mail/milter-manager/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-08 17:59:31 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-08 17:59:31 +0000
commitca49e69edd8ee5b10a8a8491642ac6a67e056383 (patch)
tree94f0d347e12656fea0f84c5c05aca5c9196af99d /mail/milter-manager/Makefile
parentb63a3d31456cd0a641cdae249fafa38e6e9124ac (diff)
Notes
Diffstat (limited to 'mail/milter-manager/Makefile')
-rw-r--r--mail/milter-manager/Makefile47
1 files changed, 27 insertions, 20 deletions
diff --git a/mail/milter-manager/Makefile b/mail/milter-manager/Makefile
index 65fe6f95f7d0..9d5983ec619c 100644
--- a/mail/milter-manager/Makefile
+++ b/mail/milter-manager/Makefile
@@ -2,15 +2,18 @@
# $FreeBSD$
PORTNAME= milter-manager
-PORTVERSION= 1.8.5
+PORTVERSION= 1.8.6
CATEGORIES= mail ruby
MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/-/%20/}/${PORTVERSION}
MAINTAINER= umq@ueo.co.jp
COMMENT= A super milter that can invoke several milters selectively
+LICENSE= AGPLv3 GFDL GPLv3 LGPL3
+LICENSE_COMB= multi
+
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
-LIB_DEPENDS= ev.4:${PORTSDIR}/devel/libev
+LIB_DEPENDS= ev:${PORTSDIR}/devel/libev
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
USE_RC_SUBR= milter-manager
@@ -25,27 +28,31 @@ USE_LDCONFIG= yes
USE_RUBY= yes
MAKE_JOBS_SAFE= yes
-## YET TO BE DONE
-#OPTIONS_DEFINE= LOG_ANALYZER MILTER_MANAGER_ADMIN
-#LOG_ANALYZER_DESC= Setup log analyzer
-#MILTER_MANAGER_ADMIN_DESC= Setup admin tool
-#
-#.include <bsd.port.options.mk>
-#
-#.if ${PORT_OPTIONS:MLOG_ANALYZER}
-#USE_APACHE= 22
-#BUILD_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/RRD.so:${PORTSDIR}/databases/rrdtool
-#.endif
-#.if ${PORT_OPTIONS:MMILTER_MANAGER_ADMIN}
-#USE_APACHE= 22
-#RUN_DEPENDS+= rubygem-passenger>=2.0.0:${PORTSDIR}/www/rubygem-passenger \
-# rubygem-rails>=2.3.2:${PORTSDIR}/www/rubygem-rails \
-# rubygem-sqlite3>=1.2.0:${PORTSDIR}/databases/rubygem-sqlite3
-#USE_RUBY_FEATURES= iconv
-#.endif
+.include <bsd.port.options.mk>
MANLANG= "" ja
MAN1= milter-manager-log-analyzer.1 milter-manager.1 milter-performance-check.1 \
milter-report-statistics.1 milter-test-client.1 milter-test-server.1
+PORTDOCS= *
+PORTEXAMPLES= *
+PORTDATA= *
+
+.if ${PORT_OPTIONS:MDOCS}
+CONFIGURE_ARGS+=--with-html-dir=${DOCSDIR}
+.else
+CONFIGURE_ARGS+=--with-html-dir=${WRKDIR}/doc
+.endif
+.ifdef NOPORTEXAMPLES
+EXAMPLESDIR= ${WRKDIR}/examples
+.endif
+.ifdef NOPORTDATA
+DATADIR= ${WRKDIR}/data
+.endif
+
+post-patch:
+ ${FIND} ${WRKSRC} -type f -name Makefile.in -exec \
+ ${REINPLACE_CMD} -e "s#\$$(datadir)/@PACKAGE@#${DATADIR}#" \
+ -e "s#\$$(datarootdir)/\$$(PACKAGE)#${DATADIR}#" {} +
+ ${REINPLACE_CMD} -e "s#\\\\\$$(pkgdatadir)/sample#${EXAMPLESDIR}#" ${WRKSRC}/configure
.include <bsd.port.mk>