aboutsummaryrefslogtreecommitdiff
path: root/mail/milter-regex
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2019-04-03 20:15:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2019-04-03 20:15:52 +0000
commitc83237a2d90ac7e11ce8574cf29fce7a15425f9a (patch)
treeb435bdfa80d7b700e0da91fc00a5a77f96e8a5ee /mail/milter-regex
parente21011696a381aa146cb9a111650d021d59af5ea (diff)
downloadports-c83237a2d90ac7e11ce8574cf29fce7a15425f9a.tar.gz
ports-c83237a2d90ac7e11ce8574cf29fce7a15425f9a.zip
Notes
Diffstat (limited to 'mail/milter-regex')
-rw-r--r--mail/milter-regex/Makefile2
-rw-r--r--mail/milter-regex/distinfo6
-rw-r--r--mail/milter-regex/files/patch-milter-regex.810
-rw-r--r--mail/milter-regex/files/patch-milter-regex.c22
4 files changed, 20 insertions, 20 deletions
diff --git a/mail/milter-regex/Makefile b/mail/milter-regex/Makefile
index 3c367068ef50..ca1b6c7893e0 100644
--- a/mail/milter-regex/Makefile
+++ b/mail/milter-regex/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= milter-regex
-PORTVERSION= 2.2
+PORTVERSION= 2.4
CATEGORIES= mail
MASTER_SITES= https://www.benzedrine.ch/
diff --git a/mail/milter-regex/distinfo b/mail/milter-regex/distinfo
index 22db17bba117..65ea2cff865a 100644
--- a/mail/milter-regex/distinfo
+++ b/mail/milter-regex/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1546371034
-SHA256 (milter-regex-2.2.tar.gz) = 67b7cbe04be7aff111750648ea4004927de9c40c53959cab32101833e7ecccdd
-SIZE (milter-regex-2.2.tar.gz) = 20496
+TIMESTAMP = 1554320086
+SHA256 (milter-regex-2.4.tar.gz) = e6cafefa4d9f103a7b831afb8a0e99a3b8436be4367be6da3d0df5dad5429df9
+SIZE (milter-regex-2.4.tar.gz) = 20347
diff --git a/mail/milter-regex/files/patch-milter-regex.8 b/mail/milter-regex/files/patch-milter-regex.8
index 36cf7965b5b8..c304bc2f8a89 100644
--- a/mail/milter-regex/files/patch-milter-regex.8
+++ b/mail/milter-regex/files/patch-milter-regex.8
@@ -1,4 +1,4 @@
---- milter-regex.8.orig 2018-09-25 20:51:47 UTC
+--- milter-regex.8.orig 2019-04-02 15:47:26 UTC
+++ milter-regex.8
@@ -36,7 +36,9 @@
.Sh SYNOPSIS
@@ -7,10 +7,10 @@
+.Op Fl q
.Op Fl c Ar config
+.Op Fl r Ar pid-file
+ .Op Fl f Ar facility
.Op Fl j Ar dirname
.Op Fl l Ar loglevel
- .Op Fl m Ar number
-@@ -58,9 +60,14 @@ The options are as follows:
+@@ -59,9 +61,14 @@ The options are as follows:
.It Fl d
Don't detach from controlling terminal and produce verbose debug
output on stdout.
@@ -22,6 +22,6 @@
+.It Fl r Ar pid-file
+Use the specified pid file to write to. Default is:
+/var/spool/milter-regex/milter-regex.pid
+ .It Fl f Ar facility
+ Use the specified syslog facility instead of the default, daemon.
.It Fl j Ar dirname
- Change root to the specified directory.
- .It Fl l Ar loglevel
diff --git a/mail/milter-regex/files/patch-milter-regex.c b/mail/milter-regex/files/patch-milter-regex.c
index 749178ce15f5..f414c1420712 100644
--- a/mail/milter-regex/files/patch-milter-regex.c
+++ b/mail/milter-regex/files/patch-milter-regex.c
@@ -1,6 +1,6 @@
---- milter-regex.c.orig 2018-09-25 20:31:25 UTC
+--- milter-regex.c.orig 2019-04-02 15:47:26 UTC
+++ milter-regex.c
-@@ -61,6 +61,7 @@ extern int parse_ruleset(const char *,
+@@ -62,6 +62,7 @@ extern int parse_ruleset(const char *,
static const char *rule_file_name = "/etc/milter-regex.conf";
static int debug = 0;
@@ -8,7 +8,7 @@
static unsigned maxlines = 0;
static pthread_mutex_t mutex;
-@@ -98,6 +99,7 @@ static void msg(int, struct context *,
+@@ -99,6 +100,7 @@ static void msg(int, struct context *,
#define USER "_milter-regex"
#define OCONN "unix:/var/spool/milter-regex/sock"
@@ -16,7 +16,7 @@
#define RCODE_REJECT "554"
#define RCODE_TEMPFAIL "451"
#define XCODE_REJECT "5.7.1"
-@@ -646,6 +648,9 @@ msg(int priority, struct context *contex
+@@ -647,6 +649,9 @@ msg(int priority, struct context *contex
va_list ap;
char msg[8192];
@@ -26,7 +26,7 @@
va_start(ap, fmt);
if (context != NULL)
snprintf(msg, sizeof(msg), "%s [%s]: ", context->host_name,
-@@ -684,6 +689,7 @@ main(int argc, char **argv)
+@@ -685,6 +690,7 @@ main(int argc, char **argv)
{
int ch, maskpri = LOG_INFO;
const char *oconn = OCONN;
@@ -34,19 +34,19 @@
const char *user = USER;
const char *jail = NULL;
sfsistat r = MI_FAILURE;
-@@ -691,8 +697,10 @@ main(int argc, char **argv)
- const char *pgroup = NULL;
+@@ -693,8 +699,10 @@ main(int argc, char **argv)
const char *puser = NULL;
mode_t pperm = 0600;
+ int facility = LOG_DAEMON;
+ pid_t pid;
+ FILE *pid_fd = NULL;
-- while ((ch = getopt(argc, argv, "c:dj:l:m:p:u:G:P:U:")) != -1) {
-+ while ((ch = getopt(argc, argv, "c:dj:l:m:p:qr:u:G:P:U:")) != -1) {
+- while ((ch = getopt(argc, argv, "c:df:j:l:m:p:u:G:P:U:")) != -1) {
++ while ((ch = getopt(argc, argv, "c:df:j:l:m:p:qr:u:G:P:U:")) != -1) {
switch (ch) {
case 'c':
rule_file_name = optarg;
-@@ -712,6 +720,12 @@ main(int argc, char **argv)
+@@ -724,6 +732,12 @@ main(int argc, char **argv)
case 'p':
oconn = optarg;
break;
@@ -59,7 +59,7 @@
case 'u':
user = optarg;
break;
-@@ -833,6 +847,20 @@ main(int argc, char **argv)
+@@ -845,6 +859,20 @@ main(int argc, char **argv)
}
msg(LOG_INFO, NULL, "started: %s", rcsid);