aboutsummaryrefslogtreecommitdiff
path: root/mail/mime-construct
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:26:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:26:17 +0000
commite2f3e3062f931de6d2d15f1bc04a9383ae3292f9 (patch)
treec2793b414c6e6e4e350f537f9d259c9ccfb8f06e /mail/mime-construct
parent66d03de0d86bb2dc2df2c1bb2648f8fb40c469c8 (diff)
downloadports-e2f3e3062f931de6d2d15f1bc04a9383ae3292f9.tar.gz
ports-e2f3e3062f931de6d2d15f1bc04a9383ae3292f9.zip
Notes
Diffstat (limited to 'mail/mime-construct')
-rw-r--r--mail/mime-construct/Makefile26
-rw-r--r--mail/mime-construct/distinfo3
-rw-r--r--mail/mime-construct/pkg-descr5
-rw-r--r--mail/mime-construct/pkg-plist3
4 files changed, 37 insertions, 0 deletions
diff --git a/mail/mime-construct/Makefile b/mail/mime-construct/Makefile
new file mode 100644
index 000000000000..4289d534d7d4
--- /dev/null
+++ b/mail/mime-construct/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mime-construct
+# Date created: Tue 02 Mar 2010
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mime-construct
+PORTVERSION= 1.10
+CATEGORIES= mail
+MASTER_SITES= http://www.argon.org/~roderick/ \
+ ftp://renatasystems.org/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Construct and optionally send MIME messages from command line
+
+BUILD_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-MIME-Types>=0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-Proc-WaitStat>=0:${PORTSDIR}/devel/p5-Proc-WaitStat
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= mime-construct.1
+
+.include <bsd.port.mk>
diff --git a/mail/mime-construct/distinfo b/mail/mime-construct/distinfo
new file mode 100644
index 000000000000..f33fd4f4cbd5
--- /dev/null
+++ b/mail/mime-construct/distinfo
@@ -0,0 +1,3 @@
+MD5 (mime-construct-1.10.tar.gz) = a8060188ed35dccd5c5aac85f5b6a094
+SHA256 (mime-construct-1.10.tar.gz) = 529cd41050787aa1a5c387104ab4df8a734061c23a5dcedd5f12fe37ff8a71e9
+SIZE (mime-construct-1.10.tar.gz) = 12452
diff --git a/mail/mime-construct/pkg-descr b/mail/mime-construct/pkg-descr
new file mode 100644
index 000000000000..a39d62ea5afb
--- /dev/null
+++ b/mail/mime-construct/pkg-descr
@@ -0,0 +1,5 @@
+mime-construct constructs and (by default) mails MIME messages. It is entirely
+driven from the command line, it is designed to be used by other programs, or
+people who act like programs.
+
+WWW: http://www.argon.org/~roderick/
diff --git a/mail/mime-construct/pkg-plist b/mail/mime-construct/pkg-plist
new file mode 100644
index 000000000000..89b5c25ff85d
--- /dev/null
+++ b/mail/mime-construct/pkg-plist
@@ -0,0 +1,3 @@
+bin/mime-construct
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/mime-construct/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/mime-construct