aboutsummaryrefslogtreecommitdiff
path: root/mail/mimedefang
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2007-02-17 07:45:53 +0000
committerMartin Blapp <mbr@FreeBSD.org>2007-02-17 07:45:53 +0000
commit60ce6b9fdeacfbbfc399d0da655ffc03b86f1248 (patch)
tree64d59ddc9c6635910ff2ab2ed6272ccba87cd582 /mail/mimedefang
parentd6d35657389916f5d02c895f8daaba98318e216e (diff)
downloadports-60ce6b9fdeacfbbfc399d0da655ffc03b86f1248.tar.gz
ports-60ce6b9fdeacfbbfc399d0da655ffc03b86f1248.zip
Notes
Diffstat (limited to 'mail/mimedefang')
-rw-r--r--mail/mimedefang/Makefile1
-rw-r--r--mail/mimedefang/files/patch-mimedefang.pl.in44
2 files changed, 45 insertions, 0 deletions
diff --git a/mail/mimedefang/Makefile b/mail/mimedefang/Makefile
index f2e0269a6614..992ba1a05d55 100644
--- a/mail/mimedefang/Makefile
+++ b/mail/mimedefang/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mimedefang
PORTVERSION= 2.61
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.mimedefang.org/static/
diff --git a/mail/mimedefang/files/patch-mimedefang.pl.in b/mail/mimedefang/files/patch-mimedefang.pl.in
index df69d945552d..19be7a949f9c 100644
--- a/mail/mimedefang/files/patch-mimedefang.pl.in
+++ b/mail/mimedefang/files/patch-mimedefang.pl.in
@@ -9,3 +9,47 @@
$TrophieSock = "@SPOOLDIR@/trophie";
package MIME::Parser::ParanoidFiler;
+@@ -3669,7 +3669,7 @@
+
+ # Run clamscan
+ my($code, $category, $action) =
+- run_virus_scanner($Features{'Virus:CLAMAV'} . " --mbox --stdout --disable-summary --infected $path 2>&1");
++ run_virus_scanner($Features{'Virus:CLAMAV'} . " --stdout --disable-summary --infected $path 2>&1");
+ if ($action ne 'proceed') {
+ return (wantarray ? ($code, $category, $action) : $code);
+ }
+@@ -3693,7 +3693,7 @@
+
+ # Run clamscan
+ my($code, $category, $action) =
+- run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --mbox --stdout --disable-summary --infected ./Work 2>&1");
++ run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --stdout --disable-summary --infected ./Work 2>&1");
+ if ($action ne 'proceed') {
+ return (wantarray ? ($code, $category, $action) : $code);
+ }
+@@ -4506,10 +4506,10 @@
+ md_syslog('err', "$MsgID: Clamd returned error: $err_detail");
+ # If it's a zip module failure, try falling back on clamscan.
+ # This is despicable, but it might work
+- if ($err_detail =~ /zip module failure/i &&
++ if ($err_detail =~ /(?:zip module failure|Not supported data format)/i &&
+ $Features{'Virus:CLAMAV'}) {
+ my ($code, $category, $action) =
+- run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --unzip --mbox --stdout --disable-summary --infected $CWD/Work 2>&1");
++ run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --unzip --stdout --disable-summary --infected $CWD/Work 2>&1");
+ if ($action ne 'proceed') {
+ return (wantarray ? ($code, $category, $action) : $code);
+ }
+@@ -4603,10 +4603,10 @@
+ md_syslog('err', "$MsgID: Clamd returned error: $err_detail");
+ # If it's a zip module failure, try falling back on clamscan.
+ # This is despicable, but it might work
+- if ($err_detail =~ /zip module failure/i &&
++ if ($err_detail =~ /(?:zip module failure|Not supported data format)/i &&
+ $Features{'Virus:CLAMAV'}) {
+ my ($code, $category, $action) =
+- run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --unzip --mbox --stdout --disable-summary --infected $CWD/Work 2>&1");
++ run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --unzip --stdout --disable-summary --infected $CWD/Work 2>&1");
+ if ($action ne 'proceed') {
+ return (wantarray ? ($code, $category, $action) : $code);
+ }