aboutsummaryrefslogtreecommitdiff
path: root/mail/mmc/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-07-21 14:06:25 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-07-21 14:06:25 +0000
commit7bcf1fe7b0b0a6b9d240d43488901fa9605c729d (patch)
treef6d5f79e5f8519845ad4ea3e7934fc64fa5b68dd /mail/mmc/files
parent9cd88528c2b8088762e05d158875c08c4fcff042 (diff)
downloadports-7bcf1fe7b0b0a6b9d240d43488901fa9605c729d.tar.gz
ports-7bcf1fe7b0b0a6b9d240d43488901fa9605c729d.zip
Notes
Diffstat (limited to 'mail/mmc/files')
-rw-r--r--mail/mmc/files/patch-ab11
-rw-r--r--mail/mmc/files/patch-ac13
-rw-r--r--mail/mmc/files/patch-ad10
-rw-r--r--mail/mmc/files/patch-ae10
4 files changed, 44 insertions, 0 deletions
diff --git a/mail/mmc/files/patch-ab b/mail/mmc/files/patch-ab
new file mode 100644
index 000000000000..537275ed1336
--- /dev/null
+++ b/mail/mmc/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/Makefile.in 2000/07/21 13:35:12 1.1
++++ src/Makefile.in 2000/07/21 13:35:38
+@@ -115,7 +115,7 @@
+ mmc_SOURCES = main.cc main.h msg.cc msg.h pop3.cc pop3.h mime.cc mime.h compose.cc compose.h smtp.cc smtp.h address.cc progressbar.cc protocols.h protocols.cc folders.cc folders.h address.h progress.h
+
+
+-mmc_LDADD = $(GNOMEUI_LIBS) $(GNOME_LIBDIR) $(INTLLIBS) -ldb
++mmc_LDADD = $(GNOMEUI_LIBS) $(GNOME_LIBDIR) $(INTLLIBS)
+
+ EXTRA_DIST = logo.png
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/mail/mmc/files/patch-ac b/mail/mmc/files/patch-ac
new file mode 100644
index 000000000000..28f201be2b53
--- /dev/null
+++ b/mail/mmc/files/patch-ac
@@ -0,0 +1,13 @@
+--- src/address.h 2000/07/21 13:28:27 1.1
++++ src/address.h 2000/07/21 13:30:50
+@@ -23,8 +23,8 @@
+ #ifndef __MMC_ADDRESS_H
+ #define __MMC_ADDRESS_H
+
+-#include <alloca.h>
+-#include <db1/db.h>
++/*#include <alloca.h>*/
++#include <db.h>
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <stdio.h>
diff --git a/mail/mmc/files/patch-ad b/mail/mmc/files/patch-ad
new file mode 100644
index 000000000000..ac391ca228e9
--- /dev/null
+++ b/mail/mmc/files/patch-ad
@@ -0,0 +1,10 @@
+--- src/pop3.cc 2000/07/21 13:31:58 1.1
++++ src/pop3.cc 2000/07/21 13:32:56
+@@ -26,6 +26,7 @@
+ */
+
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <sys/stat.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/mail/mmc/files/patch-ae b/mail/mmc/files/patch-ae
new file mode 100644
index 000000000000..a371e75d7962
--- /dev/null
+++ b/mail/mmc/files/patch-ae
@@ -0,0 +1,10 @@
+--- src/smtp.cc 2000/07/21 13:33:45 1.1
++++ src/smtp.cc 2000/07/21 13:34:24
+@@ -20,6 +20,7 @@
+ For the complete License see the file COPYING.
+ */
+
++#include <sys/types.h>
+ #include<sys/socket.h>
+ #include<gnome.h>
+