aboutsummaryrefslogtreecommitdiff
path: root/mail/moztraybiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-03-20 03:57:35 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-03-20 03:57:35 +0000
commitd5b0f72aa2b248653769674b8c1be2f7b04667a6 (patch)
tree3bc4d842375067f64529f8f9f44e028df14afeb2 /mail/moztraybiff
parentf125e5054ace1d07adbd77ce6dd05e534114ef5d (diff)
downloadports-d5b0f72aa2b248653769674b8c1be2f7b04667a6.tar.gz
ports-d5b0f72aa2b248653769674b8c1be2f7b04667a6.zip
Notes
Diffstat (limited to 'mail/moztraybiff')
-rw-r--r--mail/moztraybiff/Makefile36
-rw-r--r--mail/moztraybiff/distinfo2
-rw-r--r--mail/moztraybiff/files/patch-Makefile20
-rw-r--r--mail/moztraybiff/files/patch-components_Makefile14
-rw-r--r--mail/moztraybiff/pkg-descr6
-rw-r--r--mail/moztraybiff/pkg-message9
6 files changed, 87 insertions, 0 deletions
diff --git a/mail/moztraybiff/Makefile b/mail/moztraybiff/Makefile
new file mode 100644
index 000000000000..901b29bf1215
--- /dev/null
+++ b/mail/moztraybiff/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: moztraybiff
+# Date created: 19 March, 2005
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moztraybiff
+PORTVERSION= 1.0.7
+CATEGORIES= mail gnome
+MASTER_SITES= http://mozdev.oregonstate.edu/moztraybiff/
+DISTNAME= mozTrayBiff-${PORTVERSION}
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= New mail tray icon for Thunderbird
+
+BUILD_DEPENDS= ${X11BASE}/lib/thunderbird/lib/thunderbird-1.0/components/libwidget_gtk2.so:${PORTSDIR}/mail/thunderbird
+RUN_DEPENDS= ${X11BASE}/lib/thunderbird/lib/thunderbird-1.0/components/libwidget_gtk2.so:${PORTSDIR}/mail/thunderbird
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= libgnome
+MAKE_ARGS+= MOZILLA_PLATFORM=tbird
+
+FILENAME= mozTrayBiff-${PORTVERSION}-FreeBSD-tb1.0.xpi
+PLIST_FILES= ${DATADIR}/${FILENAME}
+PLIST_DIRS= ${DATADIR}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL} -m 644 ${WRKSRC}/${FILENAME} ${DATADIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/moztraybiff/distinfo b/mail/moztraybiff/distinfo
new file mode 100644
index 000000000000..b95d28727eca
--- /dev/null
+++ b/mail/moztraybiff/distinfo
@@ -0,0 +1,2 @@
+MD5 (mozTrayBiff-1.0.7.tar.gz) = 42905cec4b680ba888e6c8e32521fb66
+SIZE (mozTrayBiff-1.0.7.tar.gz) = 29267
diff --git a/mail/moztraybiff/files/patch-Makefile b/mail/moztraybiff/files/patch-Makefile
new file mode 100644
index 000000000000..5b8c43a334f6
--- /dev/null
+++ b/mail/moztraybiff/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Sat Mar 19 22:29:01 2005
++++ Makefile Sat Mar 19 22:30:04 2005
+@@ -1,7 +1,7 @@
+ SUBDIRS = components chrome
+ .PHONY: all clean subdirs ${SUBDIRS} content locale
+ VERSION = 1.0.7
+-PLATFORM := $(shell gcc -dumpmachine)
++PLATFORM := $(shell uname)
+ XPI_NAME = mozTrayBiff
+ XPI_VERSION := $(VERSION)-$(PLATFORM)
+ XPI_FILENAME = $(XPI_NAME)-$(XPI_VERSION).xpi
+@@ -15,7 +15,7 @@
+ XPI_EXTRA_FILES = install.js
+ endif
+ ifeq ($(MOZILLA_PLATFORM),tbird)
+-REAL_CONFIG = mozilla-thunderbird-config
++REAL_CONFIG = thunderbird-config
+ XPI_VERSION := $(XPI_VERSION)-tb$(shell $(REAL_CONFIG) --version)
+ XPI_EXTRA_FILES = install.rdf
+ endif
diff --git a/mail/moztraybiff/files/patch-components_Makefile b/mail/moztraybiff/files/patch-components_Makefile
new file mode 100644
index 000000000000..9d11441e4d9c
--- /dev/null
+++ b/mail/moztraybiff/files/patch-components_Makefile
@@ -0,0 +1,14 @@
+--- components/Makefile.orig Sat Mar 19 22:30:21 2005
++++ components/Makefile Sat Mar 19 22:32:11 2005
+@@ -17,7 +17,10 @@
+ $(shell pkg-config --libs $(GTK_PACKAGE))
+
+ MOZ_INCLUDES := \
+- $(shell $(MOZILLA_CONFIG) --cflags)
++ $(shell $(MOZILLA_CONFIG) --cflags) \
++ $(shell for i in \
++ `find $${X11BASE}/lib/thunderbird/include/thunderbird-1.0 -type d`; \
++ do echo -n "-I$$i "; done)
+
+ CXXFLAGS += \
+ -fno-rtti \
diff --git a/mail/moztraybiff/pkg-descr b/mail/moztraybiff/pkg-descr
new file mode 100644
index 000000000000..d2fb478d4f40
--- /dev/null
+++ b/mail/moztraybiff/pkg-descr
@@ -0,0 +1,6 @@
+Mozilla New Mail Icon is an extension which displays an icon in the
+system tray when new mail arrives in Mozilla Thunderbird. While it
+supports the standard (FreeDesktop.org) system tray, as used by GNOME,
+KDE and IceWM, it requires GNOME libraries to build and run.
+
+WWW: http://moztraybiff.mozdev.org/
diff --git a/mail/moztraybiff/pkg-message b/mail/moztraybiff/pkg-message
new file mode 100644
index 000000000000..ad853aa29869
--- /dev/null
+++ b/mail/moztraybiff/pkg-message
@@ -0,0 +1,9 @@
+The extension has been installed in /usr/X11R6/share/moztraybiff/
+
+To use this extension:
+ * Open up Thunderbird
+ * Choose Tools|Extensions from the menu
+ * Click the "Install" button
+ * Navigate to /usr/X11R6/share/moztraybiff/
+ * Select the file that appears in that directory
+ * Restart Thunderbird