aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-08-28 19:29:05 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-08-28 19:29:05 +0000
commit36ff99b31158462f5cd9955155230d72910d7db1 (patch)
tree9120f238e6974249b1fad3cfdb880cf0c40a756c /mail/mutt-devel
parente8c64a3ee70a663ad380f9554237d47cc4c1d6e4 (diff)
downloadports-36ff99b31158462f5cd9955155230d72910d7db1.tar.gz
ports-36ff99b31158462f5cd9955155230d72910d7db1.zip
Notes
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile13
-rw-r--r--mail/mutt-devel/files/extra-patch-pgp-outlook77
-rw-r--r--mail/mutt-devel/scripts/generate-plist3
3 files changed, 0 insertions, 93 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 685a46ea7b1a..8d3e35332e10 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -47,9 +47,6 @@
# If you want to enable extended quoting functions define:
# WITH_MUTT_QUOTE_PATCH
#
-# If you want to enable the pgp_outlook_compat function for use with pgp define:
-# WITH_MUTT_PGP_OUTLOOK_PATCH
-#
# If you want to disable a outlook_compat function for use with smime define:
# WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT
#
@@ -167,13 +164,6 @@ USE_OPENSSL= yes
.if defined(WITH_MUTT_CYRUS_SASL)
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
-.if exists(${LOCALBASE}/bin/pgp)
-WITH_MUTT_PGP_OUTLOOK_PATCH= yes
-.endif
-.if defined(WITH_MUTT_PGP_OUTLOOK_PATCH)
-pre-configure::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-pgp-outlook
-.endif
.if defined(WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT)
pre-configure::
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-no-outlook
@@ -243,9 +233,6 @@ SCRIPTS_ENV+= MUTT_COMPRESSED_FOLDERS="yes"
.if defined(WITH_MUTT_QUOTE_PATCH)
SCRIPTS_ENV+= MUTT_QUOTE_PATCH="yes"
.endif
-.if defined(WITH_MUTT_PGP_OUTLOOK_PATCH)
-SCRIPTS_ENV+= MUTT_PGP_OUTLOOK_PATCH="yes"
-.endif
.if defined(WITH_MUTT_EDIT_THREADS)
SCRIPTS_ENV+= MUTT_EDIT_THREADS="yes"
.endif
diff --git a/mail/mutt-devel/files/extra-patch-pgp-outlook b/mail/mutt-devel/files/extra-patch-pgp-outlook
deleted file mode 100644
index a6f589ddb59d..000000000000
--- a/mail/mutt-devel/files/extra-patch-pgp-outlook
+++ /dev/null
@@ -1,77 +0,0 @@
---- init.h.orig Mon Feb 12 08:54:57 2001
-+++ init.h Sat Feb 24 18:03:32 2001
-@@ -1227,6 +1227,13 @@
- ** \fBdeprecated\fP.
- */
-
-+ { "pgp_outlook_compat", DT_QUAD, R_NONE, OPT_PGPOUTLOOK, M_NO },
-+ /*
-+ ** .pp
-+ ** If pgp_create_traditional is defined above, this option causes mutt
-+ ** to generate messages readable by users of MS Outlook using PGP.
-+ */
-+
- /* XXX Default values! */
-
- { "pgp_decode_command", DT_STR, R_NONE, UL &PgpDecodeCommand, 0},
---- mutt.h.orig Tue Feb 26 22:40:16 2002
-+++ mutt.h Tue Feb 26 22:44:05 2002
-@@ -263,2 +263,3 @@
- OPT_PGPTRADITIONAL, /* create old-style PGP messages */
-+ OPT_PGPOUTLOOK, /* Create even older broken outlook compatible messages */
- #endif
---- pgp.c.orig Thu Apr 4 08:49:50 2002
-+++ pgp.c Sun May 5 13:57:57 2002
-@@ -1399,11 +1399,20 @@
-
- b->encoding = ENC7BIT;
-
-- b->type = TYPETEXT;
-- b->subtype = safe_strdup ("plain");
--
-- mutt_set_parameter ("x-action", flags & ENCRYPT ? "pgp-encrypted" : "pgp-signed",
-- &b->parameter);
-+ /* Outlook seems to work by scanning the message itself for PGP information, */
-+ /* not the headers. If the headers are anything but text/plain, it will */
-+ /* not recognize the message. */
-+ if (flags & PGPOUTLOOK) {
-+ b->type = TYPETEXT;
-+ b->subtype = safe_strdup ("plain");
-+ } else {
-+ b->type = TYPEAPPLICATION;
-+ b->subtype = safe_strdup ("pgp");
-+
-+ mutt_set_parameter ("format", "text", &b->parameter);
-+ mutt_set_parameter ("x-action", flags & ENCRYPT ? "pgp-encrypted" : "pgp-signed",
-+ &b->parameter);
-+ }
- mutt_set_parameter ("charset", send_charset, &b->parameter);
-
- b->filename = safe_strdup (pgpoutfile);
---- pgplib.h.orig Sun Feb 3 10:34:23 2002
-+++ pgplib.h Sun May 5 14:01:30 2002
-@@ -25,6 +25,7 @@
- #define PGPSIGN (APPLICATION_PGP | SIGN)
- #define PGPGOODSIGN (APPLICATION_PGP | GOODSIGN)
- #define PGPKEY (APPLICATION_PGP | (1 << 3))
-+#define PGPOUTLOOK (APPLICATION_PGP | (1 << 4))
-
- #define KEYFLAG_CANSIGN (1 << 0)
- #define KEYFLAG_CANENCRYPT (1 << 1)
---- crypt.c.orig Tue Mar 26 23:23:11 2002
-+++ crypt.c Sun May 5 13:53:52 2002
-@@ -184,8 +184,13 @@
- {
- if ((i = query_quadoption (OPT_PGPTRADITIONAL, _("Create an inline PGP message?"))) == -1)
- return -1;
-- else if (i == M_YES)
-+ else if (i == M_YES) {
- traditional = 1;
-+ if ((i = query_quadoption (OPT_PGPOUTLOOK, _("Create an Outlook compatible message?"))) == -1)
-+ return -1;
-+ else if (i == M_YES)
-+ flags |= PGPOUTLOOK;
-+ }
- }
- if (traditional)
- {
diff --git a/mail/mutt-devel/scripts/generate-plist b/mail/mutt-devel/scripts/generate-plist
index 4a576c17d460..795c505517b8 100644
--- a/mail/mutt-devel/scripts/generate-plist
+++ b/mail/mutt-devel/scripts/generate-plist
@@ -139,9 +139,6 @@ if [ "$MUTT_HTML" = "yes" ]; then
if [ "$MUTT_IFDEF_PATCH" = "yes" ]; then
html=$(($html + 1))
fi
- if [ "$MUTT_PGP_OUTLOOK_PATCH" = "yes" ]; then
- html=$(($html + 1))
- fi
echo "share/doc/mutt/html/manual.html" >> $tmp_first
echo "share/doc/mutt/html/manual_toc.html" >> $tmp_first
i=1