aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-03-25 01:26:45 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-03-25 01:26:45 +0000
commit03537866a4599759d1721a21fa947d2f48f3c62d (patch)
tree0dd1cf873bf297ca63555ac7f17537bc36358f88 /mail/mutt-devel
parent030101410d24759af90f03ae007bae42fef449eb (diff)
downloadports-03537866a4599759d1721a21fa947d2f48f3c62d.tar.gz
ports-03537866a4599759d1721a21fa947d2f48f3c62d.zip
Notes
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile1
-rw-r--r--mail/mutt-devel/scripts/generate-plist79
2 files changed, 38 insertions, 42 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 459b03b72589..706a7746fb67 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -314,7 +314,6 @@ pre-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/generate-plist > ${PLIST}
post-install:
- @strip ${PREFIX}/bin/mutt
.if !defined(NOPORTDOCS)
@${ECHO} "===> Installing Mutt documentation"
@${MKDIR} ${PREFIX}/share/doc/mutt && \
diff --git a/mail/mutt-devel/scripts/generate-plist b/mail/mutt-devel/scripts/generate-plist
index 6ad92ecdc73d..d14aac2fd153 100644
--- a/mail/mutt-devel/scripts/generate-plist
+++ b/mail/mutt-devel/scripts/generate-plist
@@ -59,7 +59,7 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
EOF
if [ "$MUTT_PORTDOCS" = "yes" ]; then
-cat >> $tmp_first <<EOF
+ cat >> $tmp_first <<EOF
share/doc/mutt/ABOUT-NLS
share/doc/mutt/COPYRIGHT
share/doc/mutt/ChangeLog
@@ -111,51 +111,48 @@ share/doc/mutt/samples/iconv/iconv.solaris-2.6-cjk.rc
share/doc/mutt/samples/iconv/iconv.solaris-2.6.rc
share/doc/mutt/samples/iconv/iconv.solaris-2.7.rc
EOF
-fi
-
-if [ "$MUTT_NNTP" = "yes" ]; then
-echo "share/doc/mutt/ChangeLog.nntp" >> $tmp_first
-fi
-if [ "$MUTT_SGML" = "yes" ]; then
-echo "share/doc/mutt/manual.latin1" >> $tmp_first
-echo "share/doc/mutt/manual.ps" >> $tmp_first
-fi
-if [ "$MUTT_HTML" = "yes" ]; then
- html=366
- if [ "$MUTT_COMPRESSED_FOLDERS" = "yes" ]; then
- html=$(($html + 5))
- fi
if [ "$MUTT_NNTP" = "yes" ]; then
- html=$(($html + 22))
- fi
- if [ "$MUTT_QUOTE_PATCH" = "yes" ]; then
- html=$(($html + 2))
+ echo "share/doc/mutt/ChangeLog.nntp" >> $tmp_first
fi
- if [ "$MUTT_EDIT_THREADS" = "yes" ]; then
- html=$(($html + 3))
+ if [ "$MUTT_SGML" = "yes" ]; then
+ echo "share/doc/mutt/manual.latin1" >> $tmp_first
+ echo "share/doc/mutt/manual.ps" >> $tmp_first
fi
- if [ "$MUTT_SIGNATURE_MENU" = "yes" ]; then
- html=$(($html + 1))
- fi
- if [ "$MUTT_IFDEF_PATCH" = "yes" ]; then
- html=$(($html + 1))
- fi
- if [ "$MUTT_PGP_PATCH" = "yes" ]; then
- html=$(($html + 2))
- fi
- echo "share/doc/mutt/html/manual.html" >> $tmp_first
- echo "share/doc/mutt/html/manual_toc.html" >> $tmp_first
- i=1
- while [ $i -le $html ]; do
- echo "share/doc/mutt/html/manual$i.html" >> $tmp_first
- i=$(($i + 1))
- done
- echo "@dirrm share/doc/mutt/html" >> $tmp_last
-fi
-if [ "$MUTT_PORTDOCS" = "yes" ]; then
-cat >> $tmp_last <<EOF
+ if [ "$MUTT_HTML" = "yes" ]; then
+ html=366
+ if [ "$MUTT_COMPRESSED_FOLDERS" = "yes" ]; then
+ html=$(($html + 5))
+ fi
+ if [ "$MUTT_NNTP" = "yes" ]; then
+ html=$(($html + 22))
+ fi
+ if [ "$MUTT_QUOTE_PATCH" = "yes" ]; then
+ html=$(($html + 2))
+ fi
+ if [ "$MUTT_EDIT_THREADS" = "yes" ]; then
+ html=$(($html + 3))
+ fi
+ if [ "$MUTT_SIGNATURE_MENU" = "yes" ]; then
+ html=$(($html + 1))
+ fi
+ if [ "$MUTT_IFDEF_PATCH" = "yes" ]; then
+ html=$(($html + 1))
+ fi
+ if [ "$MUTT_PGP_PATCH" = "yes" ]; then
+ html=$(($html + 2))
+ fi
+ echo "share/doc/mutt/html/manual.html" >> $tmp_first
+ echo "share/doc/mutt/html/manual_toc.html" >> $tmp_first
+ i=1
+ while [ $i -le $html ]; do
+ echo "share/doc/mutt/html/manual$i.html" >> $tmp_first
+ i=$(($i + 1))
+ done
+ echo "@dirrm share/doc/mutt/html" >> $tmp_last
+ fi
+ cat >> $tmp_last <<EOF
@dirrm share/doc/mutt/samples/iconv
@dirrm share/doc/mutt/samples
@dirrm share/doc/mutt