aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-01-12 18:41:03 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-01-12 18:41:03 +0000
commit113a446f9dfe22c8a6ae392e56f3d71f79d4eeb7 (patch)
tree534243508cb3dd04a7f599f0c14c24df5ab19a76 /mail/mutt-devel
parent1fcc73e2223e75e5a2d8b2c31e18109714d497e1 (diff)
downloadports-113a446f9dfe22c8a6ae392e56f3d71f79d4eeb7.tar.gz
ports-113a446f9dfe22c8a6ae392e56f3d71f79d4eeb7.zip
Notes
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile24
-rw-r--r--mail/mutt-devel/distinfo2
-rw-r--r--mail/mutt-devel/files/patch-crypt.c11
-rw-r--r--mail/mutt-devel/scripts/generate-plist3
4 files changed, 39 insertions, 1 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index bb6d33d2ae4a..0ff5860256dc 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -87,6 +87,10 @@
#
# If you want to have the Maildir mtime patch define:
# WITH_MUTT_MAILDIR_MTIME_PATCH
+#
+# If you want to have the Mailbox Sidebar patch define:
+# WITH_MUTT_SIDEBAR_PATCH
+#
PORTNAME= mutt-devel
PORTVERSION= 1.5.6
@@ -107,7 +111,8 @@ PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
ftp://ftp.mutt.org.ua/pub/mutt/mutt-${VVV_PATCH_VERSION}/:vvv \
ftp://ftp3.mutt.org.ua/pub/mutt/mutt-${VVV_PATCH_VERSION}/:vvv \
http://cedricduval.free.fr/mutt/patches/download/:cd \
- http://home.woolridge.ca/mutt/patches/:dw
+ http://home.woolridge.ca/mutt/patches/:dw \
+ http://thomer.com/mutt/:thomer
MAINTAINER?= udo.schweigert@siemens.com
COMMENT?= The Mongrel of Mail User Agents (part Elm, Pine, Mush, mh, etc.)
@@ -160,6 +165,17 @@ DW_MBOX_PATCH_VERSION= ${DW_PATCH_VERSION}
.if defined(WITH_MUTT_IMAP_HEADER_CACHE)
WITH_MUTT_MAILDIR_HEADER_CACHE= yes
.endif
+.if defined(WITH_MUTT_SIDEBAR_PATCH)
+.if defined(WITH_MUTT_NNTP)
+.error The WITH_MUTT_SIDEBAR_PATCH and WITH_MUTT_NNTP are not compatible
+.endif
+.if defined(WITH_MUTT_MAILDIR_MTIME_PATCH)
+.error The WITH_MUTT_SIDEBAR_PATCH and WITH_MUTT_MAILDIR_MTIME_PATCH are not compatible
+.endif
+.if defined(WITH_MUTT_SIGNATURE_MENU)
+.error The WITH_MUTT_SIDEBAR_PATCH and WITH_MUTT_SIGNATURE_MENU are not compatible
+.endif
+.endif
# XXX
# this should be done automagically by aclocal but ....
@@ -332,6 +348,9 @@ SGML_NEEDED= yes
.if defined(WITH_MUTT_MBOX_HOOK_PATCH)
PATCHFILES+= p0-patch-${DW_MBOX_PATCH_VERSION}.dw.mbox-hook.1:dw
.endif
+.if defined(WITH_MUTT_SIDEBAR_PATCH)
+PATCHFILES+= patch-1.5.6i.sidebar.20041122.txt:thomer
+.endif
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
MAN1= mutt.1 mutt_dotlock.1
@@ -362,6 +381,9 @@ SCRIPTS_ENV+= MUTT_QUOTE_PATCH="yes"
SCRIPTS_ENV+= MUTT_MAILDIR_HEADER_CACHE="yes"
CONFIGURE_ARGS+= --enable-hcache --without-gdbm --with-bdb
.endif
+.if defined(WITH_MUTT_SIDEBAR_PATCH)
+SCRIPTS_ENV+= MUTT_SIDEBAR_PATCH="yes"
+.endif
.if defined(WITH_MUTT_EDIT_THREADS)
SCRIPTS_ENV+= MUTT_EDIT_THREADS="yes"
.endif
diff --git a/mail/mutt-devel/distinfo b/mail/mutt-devel/distinfo
index 1389b92bbd31..bd2d8f724f7e 100644
--- a/mail/mutt-devel/distinfo
+++ b/mail/mutt-devel/distinfo
@@ -16,3 +16,5 @@ MD5 (mutt/patch-1.5.4.cd.ifdef.1) = a545036cdb55519154d0b35465f52daa
SIZE (mutt/patch-1.5.4.cd.ifdef.1) = 3545
MD5 (mutt/p0-patch-1.5.6.dw.mbox-hook.1) = 9e29a6778ab07a4de3442691e4573fea
SIZE (mutt/p0-patch-1.5.6.dw.mbox-hook.1) = 6405
+MD5 (mutt/patch-1.5.6i.sidebar.20041122.txt) = 3c5f1be18b9fb2be693c8c717f6b940c
+SIZE (mutt/patch-1.5.6i.sidebar.20041122.txt) = 46178
diff --git a/mail/mutt-devel/files/patch-crypt.c b/mail/mutt-devel/files/patch-crypt.c
new file mode 100644
index 000000000000..2b0eedf33cf0
--- /dev/null
+++ b/mail/mutt-devel/files/patch-crypt.c
@@ -0,0 +1,11 @@
+--- crypt.c.orig Tue Jan 11 16:20:48 2005
++++ crypt.c Tue Jan 11 16:21:10 2005
+@@ -596,6 +596,8 @@
+ }
+ else if (a->encoding == ENC8BIT)
+ a->encoding = ENCQUOTEDPRINTABLE;
++ else if (a->encoding == ENC7BIT)
++ /* empty */ ;
+ else if (a->encoding == ENCBINARY)
+ a->encoding = ENCBASE64;
+ else if (a->content && a->encoding != ENCBASE64 &&
diff --git a/mail/mutt-devel/scripts/generate-plist b/mail/mutt-devel/scripts/generate-plist
index fc3d8ac92a39..6077523e679a 100644
--- a/mail/mutt-devel/scripts/generate-plist
+++ b/mail/mutt-devel/scripts/generate-plist
@@ -147,6 +147,9 @@ EOF
if [ "$MUTT_MAILDIR_HEADER_CACHE" = "yes" ]; then
html=$(($html + 3))
fi
+ if [ "$MUTT_SIDEBAR_PATCH" = "yes" ]; then
+ html=$(($html + 2))
+ fi
if [ "$MUTT_SIGNATURE_MENU" = "yes" ]; then
html=$(($html + 1))
fi