aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorRuslan Ermilov <ru@FreeBSD.org>2003-03-23 18:38:17 +0000
committerRuslan Ermilov <ru@FreeBSD.org>2003-03-23 18:38:17 +0000
commitfe75923e2beeef373ba78263f6267a5d5356bd5f (patch)
tree9a57c3fc5fe66876717609fb43429a7c694d4406 /mail/mutt-devel
parentbd4a2ecdf341b4ab0176e1f6eee1b281b9741c0f (diff)
Notes
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile63
-rw-r--r--mail/mutt-devel/distinfo10
-rw-r--r--mail/mutt-devel/files/extra-patch-pgp-dw10
-rw-r--r--mail/mutt-devel/files/extra-patch-smime-outlook11
4 files changed, 58 insertions, 36 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 29748176653d..459b03b72589 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -47,6 +47,9 @@
# If you want to enable extended quoting functions define:
# WITH_MUTT_QUOTE_PATCH
#
+# If you want to make SMIME outlook compatible define:
+# WITH_MUTT_SMIME_OUTLOOK_COMPAT
+#
# If you want to use the rethreading functions define:
# WITH_MUTT_EDIT_THREADS
#
@@ -97,14 +100,23 @@ SCRIPTS_ENV= WRKDIR="${WRKDIR}"
.include <bsd.port.pre.mk>
-.if defined(WITH_MUTT_COMPRESSED_FOLDERS)
-PATCH_SITES+= http://www.spinnaker.de/mutt/compressed/:spinnaker
+CD_PATCH_VERSION= 1.5.3
+.if !defined(VVV_PATCH_VERSION)
+VVV_PATCH_VERSION= ${PORTVERSION}
+.endif
+.if !defined(CD_PATCH_VERSION)
+CD_PATCH_VERSION= ${PORTVERSION}
.endif
-.if defined(WITH_MUTT_NNTP) || defined(WITH_MUTT_QUOTE_PATCH)
-PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${PATCH_VERSION}/:vvv \
- http://www2.mutt.org.ua/download/mutt-${PATCH_VERSION}/:vvv \
- ftp://ftp.mutt.org.ua/pub/mutt/mutt-${PATCH_VERSION}/:vvv \
- ftp://ftp2.mutt.org.ua/pub/mutt/mutt-${PATCH_VERSION}/:vvv
+.if !defined(DW_PATCH_VERSION)
+DW_PATCH_VERSION= ${PORTVERSION}
+.endif
+
+.if defined(WITH_MUTT_COMPRESSED_FOLDERS) || defined(WITH_MUTT_NNTP) || \
+ defined(WITH_MUTT_QUOTE_PATCH)
+PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
+ http://www2.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
+ ftp://ftp.mutt.org.ua/pub/mutt/mutt-${VVV_PATCH_VERSION}/:vvv \
+ ftp://ftp2.mutt.org.ua/pub/mutt/mutt-${VVV_PATCH_VERSION}/:vvv
.endif
.if defined(WITH_MUTT_EDIT_THREADS) || defined(WITH_MUTT_SIGNATURE_MENU) || \
@@ -125,15 +137,14 @@ pre-build:
-e "s|^(AUTOHEADER = ).+|\1${AUTOHEADER}|" \
${BUILD_WRKSRC}/Makefile
-PATCH_VERSION= 1.5.3
-.if !defined(PATCH_VERSION)
-PATCH_VERSION= ${PORTVERSION}
-.endif
-
.if defined(PACKAGE_BUILDING)
-WITH_MUTT_SSL= yes
-WITH_MUTT_NCURSES= yes
-WITH_MUTT_HTML= yes
+WITH_MUTT_SSL= yes
+WITH_MUTT_NCURSES= yes
+WITH_MUTT_HTML= yes
+WITH_MUTT_COMPRESSED_FOLDERS= yes
+WITH_MUTT_QUOTE_PATCH= yes
+WITH_MUTT_SMIME_OUTLOOK_COMPAT= yes
+WITH_MUTT_PGP_PATCH= yes
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell \
urlview:${PORTSDIR}/textproc/urlview
@@ -178,6 +189,11 @@ USE_OPENSSL= yes
.if defined(WITH_MUTT_CYRUS_SASL)
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
+.if defined(WITH_MUTT_SMIME_OUTLOOK_COMPAT)
+pre-configure::
+ ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-outlook
+.endif
+
.if defined(WITH_MUTT_PGP_PATCH)
SGML_NEEDED= yes
pre-configure::
@@ -202,37 +218,36 @@ CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
PATCH_DIST_STRIP= -p1
.if defined(WITH_MUTT_COMPRESSED_FOLDERS)
-PATCHFILES+= patch-${PORTVERSION}.rr.compressed.1.gz:spinnaker
+PATCHFILES+= patch-${VVV_PATCH_VERSION}.rr.compressed.gz:vvv
CONFIGURE_ARGS+= --enable-compressed
SGML_NEEDED= yes
.endif
.if defined(WITH_MUTT_NNTP)
-.error The WITH_MUTT_NNTP is not available at the moment.
-PATCHFILES+= patch-${PATCH_VERSION}.vvv.nntp.gz:vvv
+PATCHFILES+= patch-${VVV_PATCH_VERSION}.vvv.nntp.gz:vvv
CONFIGURE_ARGS+= --enable-nntp
SGML_NEEDED= yes
.endif
.if defined(WITH_MUTT_QUOTE_PATCH)
-PATCHFILES+= patch-${PATCH_VERSION}.vvv.initials.gz:vvv \
- patch-${PATCH_VERSION}.vvv.quote.gz:vvv
+PATCHFILES+= patch-${VVV_PATCH_VERSION}.vvv.initials.gz:vvv \
+ patch-${VVV_PATCH_VERSION}.vvv.quote.gz:vvv
SGML_NEEDED= yes
.endif
.if defined(WITH_MUTT_EDIT_THREADS)
-PATCHFILES+= patch-${PATCH_VERSION}.cd.edit_threads.9.3:cd
+PATCHFILES+= patch-${CD_PATCH_VERSION}.cd.edit_threads.9.3:cd
CONFIGURE_ARGS+= --enable-imap-edit-threads
SGML_NEEDED= yes
.endif
.if defined(WITH_MUTT_SIGNATURE_MENU)
.error The WITH_MUTT_SIGNATURE_MENU is not available at the moment.
-PATCHFILES+= patch-${PATCH_VERSION}.cd.signatures_menu.2.1:cd
+PATCHFILES+= patch-${CD_PATCH_VERSION}.cd.signatures_menu.2.1:cd
SGML_NEEDED= yes
.endif
.if defined(WITH_MUTT_IFDEF_PATCH)
-PATCHFILES+= patch-${PATCH_VERSION}.cd.ifdef.1:cd
+PATCHFILES+= patch-${CD_PATCH_VERSION}.cd.ifdef.1:cd
SGML_NEEDED= yes
.endif
.if defined(WITH_MUTT_MBOX_HOOK_PATCH)
-PATCHFILES+= p0-patch-${PATCH_VERSION}.dw.mbox-hook.1:dw
+PATCHFILES+= p0-patch-${DW_PATCH_VERSION}.dw.mbox-hook.1:dw
.endif
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
diff --git a/mail/mutt-devel/distinfo b/mail/mutt-devel/distinfo
index 3e3287c3411a..79235d4265a3 100644
--- a/mail/mutt-devel/distinfo
+++ b/mail/mutt-devel/distinfo
@@ -1,9 +1,9 @@
MD5 (mutt/mutt-1.5.4i.tar.gz) = 3d4088f25892af6d71148eef26604f33
-MD5 (mutt/patch-1.5.4.rr.compressed.1.gz) = e2c0b3bb0be0e19a4a6cda01078e3eae
-MD5 (mutt/patch-1.5.3.vvv.nntp.gz) = 6399a40b4a7ce3448b0329ceec38f35b
-MD5 (mutt/patch-1.5.3.vvv.initials.gz) = 9397128c901c32b6de585ef089ead87f
-MD5 (mutt/patch-1.5.3.vvv.quote.gz) = dc24cc5765dfbbf98a9c2027d950c07a
+MD5 (mutt/patch-1.5.4.rr.compressed.gz) = a7b37150c35ea65049b3cd1edab5079d
+MD5 (mutt/patch-1.5.4.vvv.nntp.gz) = d0cb0f609aa0461d1b17137bd49c14cb
+MD5 (mutt/patch-1.5.4.vvv.initials.gz) = d92517da934f5c32692aecf7ece596b7
+MD5 (mutt/patch-1.5.4.vvv.quote.gz) = 80d91491679b426b0f670fa965ae3777
MD5 (mutt/patch-1.5.3.cd.edit_threads.9.3) = 753a19d8efdece04cd521c3a3079dc9f
MD5 (mutt/patch-1.5.3.cd.signatures_menu.2.1) = 6db636f0004e73ee2d9f577acd4ed380
MD5 (mutt/patch-1.5.3.cd.ifdef.1) = 01b47e075364834b82da053cac4eb69f
-MD5 (mutt/p0-patch-1.5.3.dw.mbox-hook.1) = 09f9b4229a2d63c81cfee7e1d811f84f
+MD5 (mutt/p0-patch-1.5.4.dw.mbox-hook.1) = 326f415380cc377c99d2232f16267ffe
diff --git a/mail/mutt-devel/files/extra-patch-pgp-dw b/mail/mutt-devel/files/extra-patch-pgp-dw
index e5235d0578ec..d31fdd78f693 100644
--- a/mail/mutt-devel/files/extra-patch-pgp-dw
+++ b/mail/mutt-devel/files/extra-patch-pgp-dw
@@ -17,11 +17,9 @@
The meaning of "key id" is to be taken broadly in this context: You
can either put a numerical key ID here, an e-mail address, or even
---- doc/muttrc.man.head Sun Dec 22 20:50:22 2002
-+++ doc/muttrc.man.head Thu Mar 20 21:38:47 2003
-@@ -286,7 +286,10 @@
- specify the ID of the public key to be used when encrypting messages
- to a certain recipient. The meaning of "key ID" is to be taken
+--- doc/muttrc.man.head.orig Sun Dec 22 20:50:22 2002
++++ doc/muttrc.man.head Sat Mar 22 23:43:27 2003
+@@ -288,3 +288,6 @@
broadly: This can be a different e-mail address, a numerical key ID,
-or even just an arbitrary search string.
+or even just an arbitrary search string. You may use multiple
@@ -29,8 +27,6 @@
+\fBpgp-hook\fPs result in the use of multiple \fIkey-id\fPs for
+recipient.
.TP
- \fBpush\fP \fIstring\fP
- This command adds the named \fIstring\fP to the keyboard buffer.
--- hook.c Tue Jan 21 13:25:21 2003
+++ hook.c Thu Mar 20 21:38:47 2003
@@ -117,7 +117,11 @@
diff --git a/mail/mutt-devel/files/extra-patch-smime-outlook b/mail/mutt-devel/files/extra-patch-smime-outlook
new file mode 100644
index 000000000000..355811694002
--- /dev/null
+++ b/mail/mutt-devel/files/extra-patch-smime-outlook
@@ -0,0 +1,11 @@
+--- crypt.c.orig Fri Mar 7 09:23:44 2003
++++ crypt.c Fri Mar 21 00:06:48 2003
+@@ -440,7 +440,7 @@
+ {
+ len++;
+ if (!ascii_strcasecmp ((t+len), "p7m"))
+-#if 0
++#if 1
+ return SMIMEENCRYPT;
+ #else
+ /* Not sure if this is the correct thing to do, but