aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-09 17:02:24 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-09 17:02:24 +0000
commit4be639c2986f81ae45e87c14e7ff335f7bf1967d (patch)
treeebbc7126b2e7885fd5fc4182a3654878533fd7e9 /mail/mutt/Makefile
parentcc9882126b0866d422d18599a75b24851f22481f (diff)
downloadports-4be639c2986f81ae45e87c14e7ff335f7bf1967d.tar.gz
ports-4be639c2986f81ae45e87c14e7ff335f7bf1967d.zip
Notes
Diffstat (limited to 'mail/mutt/Makefile')
-rw-r--r--mail/mutt/Makefile32
1 files changed, 13 insertions, 19 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 3988e29c778c..851250456500 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= mutt
-PORTVERSION= 1.5.24
-PORTREVISION?= 6
+PORTVERSION= 1.6.0
+PORTREVISION?= 0
CATEGORIES+= mail ipv6
-MASTER_SITES= ftp://ftp.mutt.org/mutt/ \
+MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
https://bitbucket.org/mutt/mutt/downloads/ \
ftp://ftp.demon.co.uk/pub/mirrors/mutt/ \
@@ -55,13 +55,13 @@ USES+= ncurses
OPTIONS_UNSET= NLS DOCS EXAMPLES
.else
OPTIONS_DEFINE= COMPRESSED_FOLDERS SASL DEBUG DOCS EXAMPLES FLOCK \
- GPGME GREETING_PATCH HTML ICONV IDN IFDEF_PATCH \
+ FORCEBASE64 GPGME GREETING_PATCH HTML ICONV IDN IFDEF_PATCH \
IMAP_HEADER_CACHE LOCALES_FIX MAILBOX_MANPAGES \
MAILDIR_HEADER_CACHE MAILDIR_MTIME_PATCH \
MIXMASTER NLS NNTP PARENT_CHILD_MATCH_PATCH \
QUOTE_PATCH REVERSE_REPLY_PATCH SIDEBAR_PATCH \
- SIGNATURE_MENU SMART_DATE SMIME_OUTLOOK_COMPAT SMTP \
- TOKYOCABINET TRASH_PATCH URLVIEW XML
+ SMART_DATE SMIME_OUTLOOK_COMPAT SMTP TOKYOCABINET \
+ TRASH_PATCH URLVIEW XML
OPTIONS_SINGLE= GSSAPI SCREEN
OPTIONS_RADIO= SPELL
@@ -73,6 +73,7 @@ COMPRESSED_FOLDERS_DESC= Compressed folders
SASL_DESC= SASL authentication
DEBUG_DESC= Debugging capabilities
FLOCK_DESC= flock() usage
+FORCEBASE64_DESC= Option to force base64 encoding for compose
GPGME_DESC= Gpgme interface
GREETING_PATCH_DESC= Greeting support
HTML_DESC= HTML documentation
@@ -82,7 +83,6 @@ LOCALES_FIX_DESC= Locales fix
MAILBOX_MANPAGES_DESC= Install mbox.5/mmdf.5 manpages
MAILDIR_HEADER_CACHE_DESC= Maildir header cache
MAILDIR_MTIME_PATCH_DESC= Maildir mtime patch
-MBOX_HOOK_PATCH_DESC= Enhanced mbox-hook
MIXMASTER_DESC= Mixmaster support
NCURSES_DESC= Ncurses support
NLS_DESC= Native language support
@@ -90,7 +90,6 @@ PARENT_CHILD_MATCH_PATCH_DESC= Parent/child match
QUOTE_PATCH_DESC= Extended quoting
REVERSE_REPLY_PATCH_DESC= Reverse_reply
SIDEBAR_PATCH_DESC= Sidebar support
-SIGNATURE_MENU_DESC= Signature menu
SLANG_DESC= SLANG support
SMART_DATE_DESC= Dynamic date formatting with "%@"
SMIME_OUTLOOK_COMPAT_DESC= SMIME outlook compatibility
@@ -205,17 +204,9 @@ SIDEBAR_PATCH_VARS= XML_NEEDED=yes
DOCS_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-doc-ref
-SIGNATURE_MENU_IGNORE= SIGNATURE_MENU does not work at the moment
-SIGNATURE_MENU_VARS= XML_NEEDED=yes
-SIGNATURE_MENU_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-signature-menu
-
-MBOX_HOOK_PATCH_IGNORE= MBOX_HOOK_PATCH does not work at the moment
-MBOX_HOOK_PATCH_PATCHFILES= p0-patch-${DW_MBOX_PATCH_VERSION}.dw.mbox-hook.1:dw
-
.include <bsd.port.options.mk>
DW_PATCH_VERSION= 1.5.6
-DW_MBOX_PATCH_VERSION= 1.5.18
.if !defined(VVV_PATCH_VERSION)
VVV_PATCH_VERSION= ${PORTVERSION}
.endif
@@ -225,9 +216,6 @@ RR_PATCH_VERSION= ${PORTVERSION}
.if !defined(DW_PATCH_VERSION)
DW_PATCH_VERSION= ${PORTVERSION}
.endif
-.if !defined(DW_MBOX_PATCH_VERSION)
-DW_MBOX_PATCH_VERSION= ${DW_PATCH_VERSION}
-.endif
# XXX
# this should be done automagically by aclocal but ....
@@ -268,6 +256,9 @@ post-patch-NNTP-on:
.if ${PORT_OPTIONS:MMAILDIR_MTIME_PATCH}
@${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-maildir-mtime-nntp
.endif
+.if ${PORT_OPTIONS:MFORCEBASE64}
+ @${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-forcebase64-nntp
+.endif
post-patch-NNTP-off:
.if ${PORT_OPTIONS:MSIDEBAR_PATCH}
@@ -277,6 +268,9 @@ post-patch-NNTP-off:
.if ${PORT_OPTIONS:MMAILDIR_MTIME_PATCH}
@${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-maildir-mtime
.endif
+.if ${PORT_OPTIONS:MFORCEBASE64}
+ @${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-forcebase64
+.endif
post-install:
${INSTALL_MAN} ${FILESDIR}/mailcap.5 ${STAGEDIR}${MANPREFIX}/man/man5