aboutsummaryrefslogtreecommitdiff
path: root/mail/nbsmtp/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-07-13 19:46:31 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-07-13 19:46:31 +0000
commit96d845ae0c883d7e8e5a798bcb815a861ef4b4c9 (patch)
treec0c456707ddb135c2a6c5afa82fe8f6539a28cce /mail/nbsmtp/Makefile
parent0c0f50821c89129e6c14686a6b03f7fd3cef6b86 (diff)
downloadports-96d845ae0c883d7e8e5a798bcb815a861ef4b4c9.tar.gz
ports-96d845ae0c883d7e8e5a798bcb815a861ef4b4c9.zip
Notes
Diffstat (limited to 'mail/nbsmtp/Makefile')
-rw-r--r--mail/nbsmtp/Makefile31
1 files changed, 24 insertions, 7 deletions
diff --git a/mail/nbsmtp/Makefile b/mail/nbsmtp/Makefile
index 2e5d2f42fd1a..e416d5b87726 100644
--- a/mail/nbsmtp/Makefile
+++ b/mail/nbsmtp/Makefile
@@ -4,9 +4,11 @@
#
# $FreeBSD$
#
+# WITH_SSL=yes "Support for secure connection to mail server"
+#
PORTNAME= nbsmtp
-PORTVERSION= 0.98
+PORTVERSION= 0.99
CATEGORIES= mail
MASTER_SITES= http://www.gentoo-es.org/~ferdy/ \
http://www.it.uc3m.es/~ferdy/nbsmtp/
@@ -14,15 +16,30 @@ MASTER_SITES= http://www.gentoo-es.org/~ferdy/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple program for outgoing SMTP delivery
-PLIST_FILES= bin/nbsmtp
+USE_BZIP2= yes
GNU_CONFIGURE= yes
+OPTIONS= IPV6 "Support for IPv6 connections" off \
+ DEBUG "Enable debug information (for developers)" off
+
+PLIST_FILES= bin/nbsmtp
+
MAN5= nbsmtprc.5
MAN8= nbsmtp.8
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nbsmtp ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/nbsmtp.8 ${MAN8PREFIX}/man/man8
- ${INSTALL_MAN} ${WRKSRC}/nbsmtprc.5 ${MAN5PREFIX}/man/man5
+.if defined(WITH_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --enable-ssl
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+.if !defined(WITHOUT_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>