aboutsummaryrefslogtreecommitdiff
path: root/mail/neomutt
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-06-04 19:03:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-06-04 19:03:12 +0000
commit958d4bee4ff3f8ed5385cb69caec12c45aad1309 (patch)
treee55e750e4d2b75b6b7a3df225845c6a239315c08 /mail/neomutt
parent9e937dddf1e9e00cc01a8492563fc9db656bfd76 (diff)
Notes
Diffstat (limited to 'mail/neomutt')
-rw-r--r--mail/neomutt/Makefile77
-rw-r--r--mail/neomutt/distinfo3
-rw-r--r--mail/neomutt/files/patch-staging-Makefile.am18
-rw-r--r--mail/neomutt/pkg-descr9
-rw-r--r--mail/neomutt/pkg-plist108
5 files changed, 215 insertions, 0 deletions
diff --git a/mail/neomutt/Makefile b/mail/neomutt/Makefile
new file mode 100644
index 000000000000..5146dcc63f75
--- /dev/null
+++ b/mail/neomutt/Makefile
@@ -0,0 +1,77 @@
+# $FreeBSD$
+
+PORTNAME= neomutt
+PORTVERSION= 20160530
+DISTVERSIONPREFIX= ${PORTNAME}-
+CATEGORIES= mail
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Bringing together all the Mutt Code
+
+LICENSE= GPLv1
+LICENSE_FILE= ${WRKSRC}/GPL
+
+USE_GITHUB= yes
+
+USES= autoreconf localbase ncurses shebangfix
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+
+LIB_DEPENDS= libtokyocabinet.so:databases/tokyocabinet \
+ libnotmuch.so:mail/notmuch
+BUILD_DEPENDS= gdate:sysutils/coreutils
+RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:misc/mime-support \
+ urlview:textproc/urlview
+
+OPTIONS_SUB= yes
+SHEBANG_FILES= smime_keys.pl
+
+OPTIONS_DEFINE= NLS DOCS SASL ICONV IDN FLOCK GPGME
+
+CONFIGURE_ARGS= --disable-dependency-tracking \
+ --with-docdir="${DOCSDIR}" \
+ --with-ssl="${OPENSSLBASE}" \
+ --enable-imap \
+ --enable-smtp \
+ --enable-pop \
+ --enable-nntp \
+ --enable-compressed \
+ --enable-hcache \
+ --enable-sidebar \
+ --enable-notmuch \
+ --with-tokyocabinet \
+ --without-qdbm \
+ --disable-fcntl \
+ --enable-external-dotlock
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+NLS_IMPLIES= ICONV
+
+IDN_LIB_DEPENDS= libidn.so:dns/libidn
+IDN_IMPLIES= ICONV
+IDN_CONFIGURE_WITH= idn
+
+ICONV_USES= iconv:translit
+ICONV_CONFIGURE_ON= ${ICONV_CONFIGURE_ARGS}
+ICONV_CONFIGURE_OFF= --disable-iconv
+
+FLOCK_CONFIGURE_ENABLE= flock
+
+SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
+SASL_CONFIGURE_ON= --with-sasl
+
+GPGME_LIB_DEPENDS= libgpgme.so:security/gpgme
+GPGME_CONFIGURE_ENABLE= gpgme
+
+DOCS_BUILD_DEPENDS= xsltproc:textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-xsl \
+ lynx:www/lynx
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/\`date/\`gdate/" ${WRKSRC}/Makefile.am ${WRKSRC}/doc/Makefile.am
+
+post-install:
+ ${RM} -f ${STAGEDIR}${PREFIX}/etc/mime*
+
+.include <bsd.port.mk>
diff --git a/mail/neomutt/distinfo b/mail/neomutt/distinfo
new file mode 100644
index 000000000000..23775d631bd0
--- /dev/null
+++ b/mail/neomutt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465053892
+SHA256 (neomutt-neomutt-neomutt-20160530_GH0.tar.gz) = 25d3a674bb697dc453f7e468139be8dfdc7a047ea87c0cc08b1268afc3558f21
+SIZE (neomutt-neomutt-neomutt-20160530_GH0.tar.gz) = 2498228
diff --git a/mail/neomutt/files/patch-staging-Makefile.am b/mail/neomutt/files/patch-staging-Makefile.am
new file mode 100644
index 000000000000..0fcb2723adb3
--- /dev/null
+++ b/mail/neomutt/files/patch-staging-Makefile.am
@@ -0,0 +1,18 @@
+--- Makefile.am.orig 2015-09-10 09:19:15.000000000 +0200
++++ Makefile.am 2015-09-10 09:21:00.000000000 +0200
+@@ -150,15 +150,6 @@
+ $(srcdir)/patchlist.sh < $(srcdir)/PATCHES > patchlist.c
+
+ install-exec-hook:
+- if test -f $(DESTDIR)$(bindir)/mutt.dotlock && test -f $(DESTDIR)$(bindir)/mutt_dotlock ; then \
+- rm -f $(DESTDIR)$(bindir)/mutt.dotlock ; \
+- ln -sf $(DESTDIR)$(bindir)/mutt_dotlock $(DESTDIR)$(bindir)/mutt.dotlock ; \
+- fi
+- if test -f $(DESTDIR)$(bindir)/mutt_dotlock && test x$(DOTLOCK_GROUP) != x ; then \
+- chgrp $(DOTLOCK_GROUP) $(DESTDIR)$(bindir)/mutt_dotlock && \
+- chmod $(DOTLOCK_PERMISSION) $(DESTDIR)$(bindir)/mutt_dotlock || \
+- { echo "Can't fix mutt_dotlock's permissions! This is required to lock mailboxes in the mail spool directory." >&2 ; exit 1 ; } \
+- fi
+
+ install-data-local:
+ $(MKDIR_P) $(DESTDIR)$(sysconfdir)
diff --git a/mail/neomutt/pkg-descr b/mail/neomutt/pkg-descr
new file mode 100644
index 000000000000..8feb7972c518
--- /dev/null
+++ b/mail/neomutt/pkg-descr
@@ -0,0 +1,9 @@
+What is NeoMutt?
+
+ * NeoMutt is a project of projects.
+ * A place to gather all the patches against Mutt.
+ * A place for all the developers to gather.
+
+Hopefully this will build the community and reduce duplicated effort.
+
+WWW: http://www.neomutt.org
diff --git a/mail/neomutt/pkg-plist b/mail/neomutt/pkg-plist
new file mode 100644
index 000000000000..c4ffc31d553f
--- /dev/null
+++ b/mail/neomutt/pkg-plist
@@ -0,0 +1,108 @@
+bin/flea
+bin/mutt
+bin/mutt_dotlock
+bin/muttbug
+bin/pgpewrap
+bin/pgpring
+bin/smime_keys
+@sample etc/Muttrc.dist etc/Muttrc
+man/man1/flea.1.gz
+man/man1/mutt.1.gz
+man/man1/mutt_dotlock.1.gz
+man/man1/muttbug.1.gz
+man/man1/pgpewrap.1.gz
+man/man1/pgpring.1.gz
+man/man1/smime_keys.1.gz
+man/man5/mbox.5.gz
+man/man5/mmdf.5.gz
+man/man5/muttrc.5.gz
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/GPL
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/PGP-Notes.txt
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.SECURITY
+%%PORTDOCS%%%%DOCSDIR%%/README.SSL
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/advancedusage.html
+%%PORTDOCS%%%%DOCSDIR%%/applying-patches.txt
+%%PORTDOCS%%%%DOCSDIR%%/configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/devel-notes.txt
+%%PORTDOCS%%%%DOCSDIR%%/gettingstarted.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/manual.txt
+%%PORTDOCS%%%%DOCSDIR%%/mimesupport.html
+%%PORTDOCS%%%%DOCSDIR%%/miscellany.html
+%%PORTDOCS%%%%DOCSDIR%%/optionalfeatures.html
+%%PORTDOCS%%%%DOCSDIR%%/patch-notes.txt
+%%PORTDOCS%%%%DOCSDIR%%/reference.html
+%%PORTDOCS%%%%DOCSDIR%%/samples/Mush.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/Pine.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/Tin.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/ca-bundle.crt
+%%PORTDOCS%%%%DOCSDIR%%/samples/colors.default
+%%PORTDOCS%%%%DOCSDIR%%/samples/colors.linux
+%%PORTDOCS%%%%DOCSDIR%%/samples/gpg.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.aix-3.2.5.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.aix-4.1.5.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.aix-4.2.0.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.aix-4.3.2.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.freebsd-3.3.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.glibc-2.1.3.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.glibc-2.1.90.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.hpux-10.01.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.hpux-10.20.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.hpux-11.00.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.irix-6.5.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.osf1-4.0a.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.osf1-4.0d.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.solaris-2.4.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.solaris-2.5.1.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.solaris-2.6-cjk.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.solaris-2.6.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/iconv/iconv.solaris-2.7.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/mutt_xtitle
+%%PORTDOCS%%%%DOCSDIR%%/samples/pgp2.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/pgp5.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/pgp6.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/sample.mailcap
+%%PORTDOCS%%%%DOCSDIR%%/samples/sample.muttrc
+%%PORTDOCS%%%%DOCSDIR%%/samples/sample.muttrc-tlr
+%%PORTDOCS%%%%DOCSDIR%%/samples/smime.rc
+%%PORTDOCS%%%%DOCSDIR%%/samples/smime_keys_test.pl
+%%PORTDOCS%%%%DOCSDIR%%/security.html
+%%PORTDOCS%%%%DOCSDIR%%/smime-notes.txt
+%%PORTDOCS%%%%DOCSDIR%%/tuning.html
+%%NLS%%share/locale/bg/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/da/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/de/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/el/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/es/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/et/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/id/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/it/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/mutt.mo