aboutsummaryrefslogtreecommitdiff
path: root/mail/nmh/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-06-17 12:52:46 +0000
committerCy Schubert <cy@FreeBSD.org>2014-06-17 12:52:46 +0000
commitb1aa4e6904c5c49727a802466ff51b67c965e64f (patch)
treeb328a3a990cb1a22de70bdc68465f480ce82ba0e /mail/nmh/Makefile
parent32125a492133269807edd5574dc930032f51975c (diff)
downloadports-b1aa4e6904c5c49727a802466ff51b67c965e64f.tar.gz
ports-b1aa4e6904c5c49727a802466ff51b67c965e64f.zip
Notes
Diffstat (limited to 'mail/nmh/Makefile')
-rw-r--r--mail/nmh/Makefile48
1 files changed, 16 insertions, 32 deletions
diff --git a/mail/nmh/Makefile b/mail/nmh/Makefile
index d9e44b769179..44101a484706 100644
--- a/mail/nmh/Makefile
+++ b/mail/nmh/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nmh
-PORTVERSION= 1.5
-PORTREVISION= 1
+PORTVERSION= 1.6
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= nmh
@@ -13,50 +12,39 @@ COMMENT= A cleaned up MH mailer suite
LICENSE= BSD3CLAUSE
-USES= gmake
+USES= gmake iconv shebangfix
+SHEBANG_FILES= docs/contrib/ml docs/contrib/replyfilter docs/contrib/vpick
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/libexec/nmh \
--sysconfdir=${PREFIX}/etc/nmh \
--docdir=${DOCSDIR}
-.ifdef NMH_EDITOR
-CONFIGURE_ARGS+= --with-editor=${NMH_EDITOR}
-.endif
-.ifdef NMH_MASQUERADE
-CONFIGURE_ARGS+= --enable-masquerade="${NMH_MASQUERADE}"
-.endif
-.ifdef NMH_PAGER
-CONFIGURE_ARGS+= --with-pager=${NMH_PAGER}
-.endif
-.ifdef NMH_SMTPSERVERS
-CONFIGURE_ARGS+= --with-smtpservers="${NMH_SMTPSERVERS}"
-.endif
-
-.ifdef NMH_EXTRA_CONFIGURE_ARGS
-CONFIGURE_ARGS+= ${NMH_EXTRA_CONFIGURE_ARGS}
-.endif
-MAKE_JOBS_UNSAFE= yes
-
OPTIONS_DEFINE= DOCS HASH_BKP SASL2 TLS REPLYFILTER
OPTIONS_SINGLE= MTS LOCKING
-OPTIONS_SINGLE_MTS= SMTP SENDMAIL
+OPTIONS_SINGLE_MTS= SMTP SENDMAIL_SMTP SENDMAIL_PIPE
OPTIONS_SINGLE_LOCKING= DOT FCNTL FLOCK LOCKF
SASL2_DESC= SASL2 support
-SASL2_CONFIGURE_ON= --with-cyrus-sasl
+SASL2_CONFIGURE_WITH= cyrus-sasl
SASL2_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
SASL2_LDFLAGS=-L${LOCALBASE}/lib
SASL2_CPPFLAGS=-I${LOCALBASE}/include
+
HASH_BKP_DESC= Use hash as backup prefix (default is a comma)
-HASH_BKP_CONFIGURE_ON= --with-hash-backup
+HASH_BKP_CONFIGURE_WITH= hash-backup
+
REPLYFILTER_DESC= Install dependencies for contrib/replyfilter
REPLYFILTER_RUN_DEPENDS= p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
- p5-Mail-Tools>=0:${PORTSDIR}/mail/p5-Mail-Tools
+ p5-Mail-Tools>=0:${PORTSDIR}/mail/p5-Mail-Tools \
+ w3m>=0:${PORTSDIR}/www/w3m \
+ par>=0:${PORTSDIR}/textproc/par
SMTP_DESC= Use remote SMTP
SMTP_CONFIGURE_ON= --with-mts=smtp
-SENDMAIL_DESC= Use local sendmail
-SENDMAIL_CONFIGURE_ON= --with-mts=sendmail
+SENDMAIL_SMTP_DESC= Use local sendmail (connect through socket)
+SENDMAIL_SMTP_CONFIGURE_ON= --with-mts=sendmail/smtp
+SENDMAIL_PIPE_DESC= Use local sendmail (connect through pipe)
+SENDMAIL_PIPE_CONFIGURE_ON= --with-mts=sendmail/pipe
DOT_DESC= Dot file locking
DOT_CONFIGURE_ON= --with-locking=dot
@@ -67,7 +55,7 @@ FLOCK_CONFIGURE_ON= --with-locking=flock
LOCKF_DESC= lockf file locking
LOCKF_CONFIGURE_ON= --with-locking=lockf
-OPTIONS_DEFAULT= SMTP DOT
+OPTIONS_DEFAULT= SMTP FLOCK
.include <bsd.port.options.mk>
@@ -84,8 +72,4 @@ DEBUG_FLAGS+= -O0 -Wall -Wextra -g
CONFLICTS= ja-mh-[0-9]*
-post-patch:
- @${REINPLACE_CMD} -e "s|autoconf|${AUTOCONF}|;\
- s|autoheader|${AUTOHEADER}|" ${WRKSRC}/Makefile.in
-
.include <bsd.port.mk>