aboutsummaryrefslogtreecommitdiff
path: root/mail/noattach
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-04-26 17:51:30 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-04-26 17:51:30 +0000
commiteea2bd7c981b33a7c8d82785f92550d8eb70ed8e (patch)
tree28b526f7953c767bf2e8b051183948a1409ea720 /mail/noattach
parent0de2112585c8f213bbb91fb4c7b9313d6c56f881 (diff)
downloadports-eea2bd7c981b33a7c8d82785f92550d8eb70ed8e.tar.gz
ports-eea2bd7c981b33a7c8d82785f92550d8eb70ed8e.zip
Notes
Diffstat (limited to 'mail/noattach')
-rw-r--r--mail/noattach/Makefile6
-rw-r--r--mail/noattach/distinfo4
-rw-r--r--mail/noattach/files/patch-Makefile.in20
-rw-r--r--mail/noattach/files/patch-noattach.c15
4 files changed, 22 insertions, 23 deletions
diff --git a/mail/noattach/Makefile b/mail/noattach/Makefile
index c172476a7c9e..5c926b4fab4e 100644
--- a/mail/noattach/Makefile
+++ b/mail/noattach/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= noattach
-PORTVERSION= 1.1.1
-PORTREVISION= 3
+PORTVERSION= 1.2
CATEGORIES= mail
MASTER_SITES= ftp://ftp.rhnet.is/pub/noattach/
-DISTNAME= ${PORTNAME}-1.1p1
MAINTAINER= dinoex@FreeBSD.org
COMMENT= An attachment filter for Sendmail
@@ -62,7 +60,7 @@ do-install:
${PREFIX}/etc/rc.d/noattach.sh.sample
${INSTALL_DATA} ${WRKSRC}/examples/noattach.patterns \
${PREFIX}/etc/noattach.patterns-dist
- ${INSTALL_MAN} ${WRKSRC}/doc/noattach.8 ${PREFIX}/man/man8/
+ ${INSTALL_MAN} ${WRKSRC}/noattach.8 ${PREFIX}/man/man8/
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${MKDIR} ${EXAMPLESDIR}
diff --git a/mail/noattach/distinfo b/mail/noattach/distinfo
index 3d6c0f3d9967..05050642455a 100644
--- a/mail/noattach/distinfo
+++ b/mail/noattach/distinfo
@@ -1,2 +1,2 @@
-MD5 (noattach-1.1p1.tar.gz) = 4b2baa32bc1a6ef914c1f53eb9b7a23a
-SIZE (noattach-1.1p1.tar.gz) = 99389
+MD5 (noattach-1.2.tar.gz) = b695b7ba4310da82c57785c8ac1f108a
+SIZE (noattach-1.2.tar.gz) = 126176
diff --git a/mail/noattach/files/patch-Makefile.in b/mail/noattach/files/patch-Makefile.in
index fb2a756dd7a1..761a69fca828 100644
--- a/mail/noattach/files/patch-Makefile.in
+++ b/mail/noattach/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Thu Aug 21 15:56:27 2003
-+++ Makefile.in Tue Oct 12 17:14:38 2004
-@@ -122,7 +122,7 @@
- noattach_LDFLAGS =
-
- DEFS = @DEFS@
--DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
+--- Makefile.in.orig Wed Feb 2 12:34:03 2005
++++ Makefile.in Sun Apr 17 23:02:08 2005
+@@ -77,7 +77,7 @@
+ rfc2231.$(OBJEXT)
+ noattach_OBJECTS = $(am_noattach_OBJECTS)
+ noattach_LDADD = $(LDADD)
+-DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
+DEFAULT_INCLUDES = $(MILTER_INCLUDES) -I. -I$(srcdir) -I.
- CPPFLAGS = @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
diff --git a/mail/noattach/files/patch-noattach.c b/mail/noattach/files/patch-noattach.c
index 19c07c00a793..d1c53b853e24 100644
--- a/mail/noattach/files/patch-noattach.c
+++ b/mail/noattach/files/patch-noattach.c
@@ -1,12 +1,13 @@
---- noattach.c.orig Thu Aug 21 15:52:48 2003
-+++ noattach.c Tue Oct 12 18:02:32 2004
-@@ -54,7 +54,9 @@
- #define BUFFER_SIZE (MILTER_CHUNK_SIZE+OVERLAP_SIZE)
+--- noattach.c.orig Wed Feb 2 12:16:45 2005
++++ noattach.c Sun Apr 17 23:04:29 2005
+@@ -77,8 +77,10 @@
#ifndef true
+ #ifndef SMFIF_QUARANTINE
+#ifndef __bool_true_false_are_defined
- typedef int bool;
-+#endif /* ! __bool_true_false_are_defined */
+ typedef int bool; /* kludge: typedef unneeded in 8.13.0, when
+ * quarantining was introduced */
++#endif
+ #endif
#define false 0
#define true 1
- #endif /* ! true */