aboutsummaryrefslogtreecommitdiff
path: root/mail/noattach
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-02-10 06:04:46 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-02-10 06:04:46 +0000
commita8b5fc19bbf423bd6bef98ddf32be2343f4daa12 (patch)
treed750217c66d1f075e752db38cc0353b8fddb2699 /mail/noattach
parentd4c869e236643d62e86bb0bcfd50587502f49f71 (diff)
downloadports-a8b5fc19bbf423bd6bef98ddf32be2343f4daa12.tar.gz
ports-a8b5fc19bbf423bd6bef98ddf32be2343f4daa12.zip
Notes
Diffstat (limited to 'mail/noattach')
-rw-r--r--mail/noattach/Makefile52
-rw-r--r--mail/noattach/distinfo1
-rw-r--r--mail/noattach/files/noattach.sh23
-rw-r--r--mail/noattach/pkg-comment1
-rw-r--r--mail/noattach/pkg-descr10
-rw-r--r--mail/noattach/pkg-plist14
6 files changed, 101 insertions, 0 deletions
diff --git a/mail/noattach/Makefile b/mail/noattach/Makefile
new file mode 100644
index 000000000000..5073dab1a482
--- /dev/null
+++ b/mail/noattach/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: noattach
+# Date created: 10. Feb 2002
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= noattach
+PORTVERSION= 1.0beta7
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.rhnet.is/pub/noattach/
+
+MAINTAINER= dinoex@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
+
+CTARGETS+= rays-filter
+CFLAGS+= -Wall -I$(LOCALBASE)/include ${PTHREAD_CFLAGS:S=""==}
+FLAGS+= ${PTHREAD_LIBS}
+LDFLAGS+= -L$(LOCALBASE)/lib
+GNU_CONFIGURE= yes
+DOCSFILES= AUTHORS COPYING INSTALL NEWS README ChangeLog
+SAMPLEFILES= README noattach.patterns noattach.patterns.johncon
+
+.include <bsd.port.pre.mk>
+
+.if defined(SENDMAIL_WITHOUT_MILTER)
+pre-fetch:
+ @${ECHO_MSG}
+ @${ECHO_MSG} You must unset variable SENDMAIL_WITHOUT_MILTER,
+ @${ECHO_MSG} and rebuild sendmail in the ports
+ @${FALSE}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/noattach ${PREFIX}/libexec/noattach
+ ${INSTALL_SCRIPT} ${FILESDIR}/noattach.sh \
+ ${PREFIX}/etc/rc.d/noattach.sh.sample
+ ${INSTALL_DATA} ${WRKSRC}/examples/noattach.patterns \
+ ${PREFIX}/etc/noattach.patterns-dist
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in ${DOCSFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.for i in ${SAMPLEFILES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${i} ${EXAMPLESDIR}/
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/noattach/distinfo b/mail/noattach/distinfo
new file mode 100644
index 000000000000..f6dabd087aa9
--- /dev/null
+++ b/mail/noattach/distinfo
@@ -0,0 +1 @@
+MD5 (noattach-1.0beta7.tar.gz) = 694cc2c602a3a161af096f766142ef2b
diff --git a/mail/noattach/files/noattach.sh b/mail/noattach/files/noattach.sh
new file mode 100644
index 000000000000..378b8be4e72f
--- /dev/null
+++ b/mail/noattach/files/noattach.sh
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+if ! test -x %%PREFIX%%/libexec/noattach
+then
+ exit 0
+fi
+case $1 in
+start)
+ rm -f /var/run/noattach.pid
+ %%PREFIX%%/libexec/noattach -p local:/var/run/noattach &&
+ echo -n ' noattach'
+ ;;
+stop)
+ killall noattach
+ rm -f /var/run/noattach.pid
+ ;;
+*)
+ echo "Usage: $0: [ start | stop ]" 2>&1
+ exit 65
+ ;;
+esac
diff --git a/mail/noattach/pkg-comment b/mail/noattach/pkg-comment
new file mode 100644
index 000000000000..7db0ef2d51ca
--- /dev/null
+++ b/mail/noattach/pkg-comment
@@ -0,0 +1 @@
+A attatchment filter for Sendmail
diff --git a/mail/noattach/pkg-descr b/mail/noattach/pkg-descr
new file mode 100644
index 000000000000..b2448c849c02
--- /dev/null
+++ b/mail/noattach/pkg-descr
@@ -0,0 +1,10 @@
+There really isn't much to say, noattach is a milter that parses the body
+of email messages from sendmail and checks if the filename of attachments
+matches one of the regular expressions in a given pattern file and rejects
+those emails that match.
+Filenames are MIME decoded if needed.
+
+This program needs sendmail version 8.12.1 or newer to be compiled with
+libsm and libmilter.
+
+WWW: http://freshmeat.net/projects/noattach/
diff --git a/mail/noattach/pkg-plist b/mail/noattach/pkg-plist
new file mode 100644
index 000000000000..d46bddebb816
--- /dev/null
+++ b/mail/noattach/pkg-plist
@@ -0,0 +1,14 @@
+libexec/noattach
+etc/rc.d/noattach.sh.sample
+etc/noattach.patterns-dist
+%%PORTDOCS%%share/doc/noattach/AUTHORS
+%%PORTDOCS%%share/doc/noattach/COPYING
+%%PORTDOCS%%share/doc/noattach/INSTALL
+%%PORTDOCS%%share/doc/noattach/NEWS
+%%PORTDOCS%%share/doc/noattach/README
+%%PORTDOCS%%share/doc/noattach/ChangeLog
+%%PORTDOCS%%@dirrm share/doc/noattach
+%%PORTDOCS%%share/examples/noattach/README
+%%PORTDOCS%%share/examples/noattach/noattach.patterns
+%%PORTDOCS%%share/examples/noattach/noattach.patterns.johncon
+%%PORTDOCS%%@dirrm share/examples/noattach