aboutsummaryrefslogtreecommitdiff
path: root/mail/nullmailer/Makefile
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-02-21 02:25:59 +0000
committerClive Lin <clive@FreeBSD.org>2001-02-21 02:25:59 +0000
commit5ce84d162d86e8ad4f3ccb60f794df05257e239f (patch)
treef535eadeed578d8ad7f653b9dcca3bbc5ef6d4ac /mail/nullmailer/Makefile
parent7cab70d9a8c82a1526515c6ad06a51cb11ff2906 (diff)
downloadports-5ce84d162d86e8ad4f3ccb60f794df05257e239f.tar.gz
ports-5ce84d162d86e8ad4f3ccb60f794df05257e239f.zip
Notes
Diffstat (limited to 'mail/nullmailer/Makefile')
-rw-r--r--mail/nullmailer/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/mail/nullmailer/Makefile b/mail/nullmailer/Makefile
new file mode 100644
index 000000000000..e728180b856c
--- /dev/null
+++ b/mail/nullmailer/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: nullmailer
+# Date created: Tue Jan 30 2001
+# Whom: clive
+#
+# $FreeBSD$
+#
+
+PORTNAME= nullmailer
+# PORTVERSION= 1.00RC5
+PORTVERSION= 1.00r5
+CATEGORIES= mail
+MASTER_SITES= http://www.em.ca/~bruceg/nullmailer/archive/%SUBDIR%/
+# MASTER_SITE_SUBDIR= ${PORTVERSION}
+MASTER_SITE_SUBDIR= 1.00RC5
+DISTNAME= ${PORTNAME}-1.00RC5
+
+MAINTAINER= clive@FreeBSD.org
+
+HAS_CONFIGURE= yes
+IS_INTERACTIVE= yes
+NO_PACKAGE= yes
+
+MAN1= nullmailer-inject.1 sendmail.1
+MAN7= nullmailer.7
+MAN8= nullmailer-queue.8 nullmailer-send.8
+
+pre-install:
+ @PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+do-install:
+ @cd ${WRKSRC} && make install && make install-root
+
+post-install:
+ @${INSTALL} -c files/nullmail.sh ${PREFIX}/etc/rc.d/
+ @${INSTALL} -c files/remotes.sample ${PREFIX}/etc/nullmailer/
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},'
+
+.include <bsd.port.mk>