aboutsummaryrefslogtreecommitdiff
path: root/mail/nullmailer
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2011-05-02 19:22:45 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2011-05-02 19:22:45 +0000
commitf44666d2223433afacbef5585d7c18c3595ac030 (patch)
tree3c09035aa702d6f83f814fb889dfc571b8a89637 /mail/nullmailer
parent2c8388d913f2f66ffbc22df298fd88e23485ee04 (diff)
downloadports-f44666d2223433afacbef5585d7c18c3595ac030.tar.gz
ports-f44666d2223433afacbef5585d7c18c3595ac030.zip
- Fixed package installation problems caused by missing ETCDIR [1]
- Incorporated rc.d script patch [2] - Fixed incorrect use of @ignore in pkg-plist (it ignores the next file listed in pkg-plist, not the one on the same line as the directive) - Remove the me.sample file from ETCDIR - Bumped PORTREVISION PR: ports/156755 (based on) Submitted by: Goran Lowkrantz <goran.lowkrantz@ismobile.com> [1] Suggested by: dougb [2]
Notes
Notes: svn path=/head/; revision=273488
Diffstat (limited to 'mail/nullmailer')
-rw-r--r--mail/nullmailer/Makefile6
-rw-r--r--mail/nullmailer/files/nullmailer.in8
-rw-r--r--mail/nullmailer/pkg-plist9
3 files changed, 15 insertions, 8 deletions
diff --git a/mail/nullmailer/Makefile b/mail/nullmailer/Makefile
index bd733eaa06cd..ad587fe0d5c2 100644
--- a/mail/nullmailer/Makefile
+++ b/mail/nullmailer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nullmailer
PORTVERSION= 1.05
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://untroubled.org/nullmailer/ \
@@ -48,8 +48,7 @@ MAN7= nullmailer.7
MAN8= nullmailer-queue.8 nullmailer-send.8
post-install:
- @cd ${WRKSRC} && make install-root
- @${INSTALL_DATA} -c ${FILESDIR}/remotes.sample ${PREFIX}/etc/nullmailer/
+ @cd ${WRKSRC} && make install-root install-data
# Append commands that reference the nullmailer user to the plist, because
# we need to ensure that the account has been created by bsd.port.mk by
@@ -63,6 +62,7 @@ post-install:
@${ECHO_CMD} '@exec ${CHOWN} -R ${USERS} ${LOCALSTATEDIR}/nullmailer' >> ${TMPPLIST}
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${INSTALL_DATA} -c ${FILESDIR}/remotes.sample ${PREFIX}/etc/nullmailer/
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/mail/nullmailer/files/nullmailer.in b/mail/nullmailer/files/nullmailer.in
index 2c5778ebecf1..db704f3816f4 100644
--- a/mail/nullmailer/files/nullmailer.in
+++ b/mail/nullmailer/files/nullmailer.in
@@ -1,8 +1,10 @@
#!/bin/sh
+
# $FreeBSD$
#
# PROVIDE: nullmailer
# REQUIRE: LOGIN
+# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf to enable nullmailer:
#
@@ -13,9 +15,13 @@
name=nullmailer
rcvar=`set_rcvar`
+
command=/usr/sbin/daemon
procname=%%PREFIX%%/sbin/nullmailer-send
command_args=" -cf -u %%NULLMAIL_USER%% /bin/sh -c '$procname | /usr/bin/logger -i -p mail.info -t $name'"
+
load_rc_config $name
-run_rc_command "$1"
+: nullmailer_enable=${nullmailer_enable:=NO}
+
+run_rc_command "$1"
diff --git a/mail/nullmailer/pkg-plist b/mail/nullmailer/pkg-plist
index 0f87f9149734..567408b9b218 100644
--- a/mail/nullmailer/pkg-plist
+++ b/mail/nullmailer/pkg-plist
@@ -7,10 +7,10 @@ bin/nullmailer-inject
sbin/nullmailer-queue
@exec chmod u+s %D/sbin/nullmailer-queue
sbin/nullmailer-send
-@ignore etc/nullmailer/me.sample
-etc/nullmailer/remotes.sample
+%%ETCDIR%%/me.sample
+%%ETCDIR%%/remotes.sample
@dirrm libexec/nullmailer
-@dirrmtry etc/nullmailer
+@dirrmtry %%ETCDIR%%
@cwd /
@exec mkdir -p %%LOCALSTATEDIR%%/nullmailer/queue
@exec chmod 700 %%LOCALSTATEDIR%%/nullmailer/queue
@@ -21,5 +21,6 @@ etc/nullmailer/remotes.sample
@exec mkfifo %%LOCALSTATEDIR%%/nullmailer/trigger
@exec chmod 600 %%LOCALSTATEDIR%%/nullmailer/trigger
@unexec rm -f %%LOCALSTATEDIR%%/nullmailer/trigger
-@ignore %%LOCALSTATEDIR%%/nullmailer/trigger
+@ignore
+%%LOCALSTATEDIR%%/nullmailer/trigger
@dirrmtry %%LOCALSTATEDIR%%/nullmailer