aboutsummaryrefslogtreecommitdiff
path: root/mail/opendkim/Makefile
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2014-07-17 09:50:58 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2014-07-17 09:50:58 +0000
commiteb4916735cfd3dcadd027048c012b9f836f7b65f (patch)
tree9b914055d6d81198455093dd9f0913bfebcc090b /mail/opendkim/Makefile
parentfa3a17c064e297850f0b1015d83b1c888a00ab3c (diff)
downloadports-eb4916735cfd3dcadd027048c012b9f836f7b65f.tar.gz
ports-eb4916735cfd3dcadd027048c012b9f836f7b65f.zip
Notes
Diffstat (limited to 'mail/opendkim/Makefile')
-rw-r--r--mail/opendkim/Makefile164
1 files changed, 84 insertions, 80 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 9ca1ca2fb353..9b7f57ba1e40 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= opendkim
-PORTVERSION= 2.8.3
-PORTREVISION= 1
+PORTVERSION= 2.9.2
CATEGORIES= mail security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME} \
@@ -22,7 +21,7 @@ LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
GNU_CONFIGURE= yes
NO_OPTIONS_SORT=yes
-USES= pkgconfig perl5 shebangfix
+USES= pkgconfig perl5 shebangfix libtool
USE_PERL5= run
SHEBANG_FILES= opendkim/opendkim-genkey.in
SHEBANG_FILES= opendkim/opendkim-genkey* reputation/opendkim-* stats/opendkim-*
@@ -31,124 +30,132 @@ USE_LDCONFIG= yes
PORTDOCS= *
+CONFIGURE_ARGS+= --without-tre
+
+OPTIONS_SUB= yes
OPTIONS_SINGLE= RESOLV
OPTIONS_SINGLE_RESOLV= STOCK_RESOLVER UNBOUND
-OPTIONS_DEFINE= FILTER GNUTLS LUA MEMCACHED BDB_BASE OPENDBX OPENLDAP \
- POPAUTH QUERY_CACHE STATS DEBUG DOCS
+OPTIONS_DEFINE= FILTER CURL GNUTLS JANSSON LDNS LMDB LUA MEMCACHED \
+ BDB_BASE OPENDBX OPENLDAP POPAUTH QUERY_CACHE SASL
OPTIONS_DEFAULT= FILTER LUA UNBOUND
STOCK_RESOLVER_DESC= Use the stock resolver library
+
UNBOUND_DESC= Use unbound DNS library
+UNBOUND_CONFIGURE_WITH= unbound
+UNBOUND_LIB_DEPENDS= libunbound.so:${PORTSDIR}/dns/unbound
+
FILTER_DESC= OpenDKIM filter, requires libmilter/Sendmail
+FILTER_USE= RC_SUBR=milter-opendkim
+
+CURL_DESC= Use cURL for web queries
+CURL_CONFIGURE_WITH= libcurl
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
GNUTLS_DESC= Use GnuTLS instead of OpenSSL
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+GNUTLS_CONFIGURE_WITH= gnutls
+GNUTLS_CONFIGURE_OFF= --with-openssl=${OPENSSLBASE}
+
+JANSSON_DESC= Statistics and other output as JSON data
+JANSSON_CONFIGURE_WITH= libjansson
+JANSSON_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson
+
+LDNS_DESC= Use LDNS library for DNS queries
+LDNS_CONFIGURE_WITH= ldns
+LDNS_LIB_DEPENDS= libldns.so:${PORTSDIR}/dns/ldns
+
+LMDB_DESC= Use Lightning Memory-Mapped DB key-value store
+LMDB_CONFIGURE_WITH= lmdb
+LMDB_LIB_DEPENDS= liblmdb.so:${PORTSDIR}/databases/lmdb
+
LUA_DESC= Describe filter policy with lua
+LUA_CONFIGURE_WITH= lua
+LUA_USES= lua
+
MEMCACHED_DESC= Use memcached as a data set
+MEMCACHED_CONFIGURE_WITH= libmemcached
+MEMCACHED_LIB_DEPENDS= libmemcached.so:${PORTSDIR}/databases/libmemcached
+
BDB_BASE_DESC= Use Berkeley DB from base
+
OPENDBX_DESC= Store filter policies via OpenDBX
+OPENDBX_CONFIGURE_WITH= odbx
+OPENDBX_LIB_DEPENDS= libopendbx.so:${PORTSDIR}/databases/opendbx
+
OPENLDAP_DESC= Store filter policies in LDAP
+OPENLDAP_CONFIGURE_WITH=openldap
+OPENLDAP_USE= OPENLDAP=yes
+
POPAUTH_DESC= Use POP authentication DB
+POPAUTH_CONFIGURE_ENABLE= popauth
+
QUERY_CACHE_DESC= Cache DNS query results locally
-STATS_DESC= Setup statistics tools
-DEBUG_DESC= Build with debug symbols
+QUERY_CACHE_CONFIGURE_ENABLE= query_cache
+
+SASL_DESC= Enable SASL authentication with LDAP
+SASL_CONFIGURE_WITH= sasl
+
+DOCS_CONFIGURE_ON= --docdir=${WRKDIR}/doc
MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
.include "${.CURDIR}/Makefile.options"
+
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MSASL} && ${PORT_OPTIONS:MOPENLDAP}
+WANT_OPENLDAP_SASL= yes
+.endif
+
.if ${PORT_OPTIONS:MFILTER}
-USE_RC_SUBR= milter-opendkim
-PLIST_SUB+= FILTER=""
SUB_FILES= pkg-message
WITHOUT_MILTER_CFLAGS= yes
WITHOUT_MILTER_LDFLAGS= yes
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
CONFIGURE_ARGS+= --with-milter=${MILTERBASE}
-.else
-CONFIGURE_ARGS+= --disable-filter
-PLIST_SUB+= FILTER="@comment "
.endif
-.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --with-gnutls=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.if ${PORT_OPTIONS:MLUA_ONLY_SIGNING} || \
+ ${PORT_OPTIONS:MRBL}
+.if !${PORT_OPTIONS:MLUA}
+IGNORE= Options LUA_ONLY_SIGNING and RBL require LUA as well
.endif
-
-.include "${.CURDIR}/Makefile.features"
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
.endif
-.if ! ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+=--docdir=${WRKDIR}/doc
+.if ${PORT_OPTIONS:MREPUTATION}
+.if !${PORT_OPTIONS:MCURL} || !${PORT_OPTIONS:MJANNSON}
+IGNORE= Option REPUTATION requires CURL and JANSSON as well
+.endif
.endif
-.if ${PORT_OPTIONS:MSTATS}
-CONFIGURE_ARGS+= --enable-stats
-PLIST_SUB+= STATS=""
-.else
-PLIST_SUB+= STATS="@comment "
+.if ${PORT_OPTIONS:MSTATSEXT}
+.if !${PORT_OPTIONS:MSTATS} || !${PORT_OPTIONS:MLUA}
+IGNORE= Option STATSEXT requires STATS and LUA as well
.endif
-.if ${PORT_OPTIONS:MPOPAUTH} \
- || ${PORT_OPTIONS:MQUERY_CACHE} \
- || (${PORT_OPTIONS:MFFR} && ${PORT_OPTIONS:MLDAP_CACHING} ) \
- || (${PORT_OPTIONS:MFFR} && ${PORT_OPTIONS:MREPUTATION} ) \
+.endif
+
+.if ${PORT_OPTIONS:MPOPAUTH} \
+ || ${PORT_OPTIONS:MQUERY_CACHE} \
+ || ${PORT_OPTIONS:MLDAP_CACHING} \
+ || ${PORT_OPTIONS:MREPUTATION} \
|| ${PORT_OPTIONS:MSTATS}
. if ${PORT_OPTIONS:MBDB_BASE}
CONFIGURE_ARGS+= --with-db-lib=c
. else
CONFIGURE_ARGS+= --with-db-incdir=${BDB_INCLUDE_DIR} \
- --with-db-libdir=${BDB_LIB_DIR} \
+ --with-db-libdir=${BDB_LIB_DIR} \
--with-db-lib=${BDB_LIB_NAME}
USE_BDB= 40+
. endif
.endif
-.if ${PORT_OPTIONS:MUNBOUND}
-CONFIGURE_ARGS+= --with-unbound
-LIB_DEPENDS+= libunbound.so:${PORTSDIR}/dns/unbound
-.endif
-.if ${PORT_OPTIONS:MPOPAUTH}
-CONFIGURE_ARGS+= --enable-popauth
-.endif
-.if ${PORT_OPTIONS:MQUERY_CACHE}
-CONFIGURE_ARGS+= --enable-query_cache
-.endif
-.if ${PORT_OPTIONS:MMEMCACHED}
-CONFIGURE_ARGS+= --with-libmemcached
-LIB_DEPENDS+= libmemcached.so:${PORTSDIR}/databases/libmemcached
-.else
-CONFIGURE_ARGS+= --without-libmemcached
-.endif
-.if ${PORT_OPTIONS:MOPENDBX}
-CONFIGURE_ARGS+= --with-odbx
-LIB_DEPENDS+= libopendbx.so:${PORTSDIR}/databases/opendbx
-PLIST_SUB+= ODBX=""
-.else
-CONFIGURE_ARGS+= --without-odbx
-PLIST_SUB+= ODBX="@comment "
-.endif
-.if ${PORT_OPTIONS:MOPENLDAP}
-CONFIGURE_ARGS+= --with-openldap
-LIB_DEPENDS+= libldap.so:${PORTSDIR}/net/openldap24-sasl-client
-USE_OPENLDAP= yes
-.else
-CONFIGURE_ARGS+= --without-openldap
-.endif
-.if ${PORT_OPTIONS:MLUA}
-CONFIGURE_ARGS+= --with-lua
-PLIST_SUB+= LUA=""
-USES+= lua
-.else
-PLIST_SUB+= LUA="@comment "
-.endif
pre-configure:
- ${REINPLACE_CMD} -e '/PKG_CONFIG/s/lua5\.2/lua-${LUA_VER}/' \
- -e '/PKG_CONFIG/s/cyrussasl/libsasl2/' \
- ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e '/LIBLUA_LIBS/s/lua5\.[0-9]/lua-${LUA_VER}/' \
+ -e '/PKG_CONFIG/s/lua5\.[0-9]/lua-${LUA_VER}/' \
+ -e '/PKG_CONFIG/s/cyrussasl/libsasl2/' \
+ ${WRKSRC}/configure
post-patch:
.if ${PORT_OPTIONS:MLCOV}
@@ -158,12 +165,9 @@ post-patch:
.endif
post-install:
-.if ! ${PORT_OPTIONS:MDEBUG} && ${PORT_OPTIONS:MFILTER}
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/opendkim
-.endif
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopendkim.so.9
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/mail
- ${INSTALL_DATA} ${WRKSRC}/opendkim/opendkim.conf.sample ${STAGEDIR}${PREFIX}/etc/mail/
+ ${INSTALL_DATA} ${WRKSRC}/opendkim/opendkim.conf.sample \
+ ${STAGEDIR}${PREFIX}/etc/mail/
regression-test: build
cd ${WRKSRC} ; ${MAKE} check