aboutsummaryrefslogtreecommitdiff
path: root/mail/opendkim
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-03-01 17:38:24 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-03-01 17:38:24 +0000
commit145b7db52d00bd60dac4e2e3905767d2cca8dc71 (patch)
tree3d9e9991b7225760caa1b1c3293ada6076e6ddcc /mail/opendkim
parent623d4e3ab39ebb67f20f0f2729ce8f8623630c4a (diff)
downloadports-145b7db52d00bd60dac4e2e3905767d2cca8dc71.tar.gz
ports-145b7db52d00bd60dac4e2e3905767d2cca8dc71.zip
Notes
Diffstat (limited to 'mail/opendkim')
-rw-r--r--mail/opendkim/Makefile17
-rw-r--r--mail/opendkim/Makefile.features34
-rw-r--r--mail/opendkim/distinfo4
-rw-r--r--mail/opendkim/files/patch-libopendkim_tests_t-test75.c32
-rw-r--r--mail/opendkim/pkg-plist40
5 files changed, 110 insertions, 17 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 297c23b24c84..ee2ad9e4c387 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= opendkim
-PORTVERSION= 2.4.3
+PORTVERSION= 2.5.0
CATEGORIES= mail security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME} \
@@ -28,10 +28,8 @@ GNU_CONFIGURE= yes
USE_OPENSSL= yes
USE_LDCONFIG= yes
-MAN8= opendkim-genkey.8 opendkim-genzone.8 \
- opendkim-testadsp.8 opendkim-testkey.8
-
-SUB_FILES= pkg-message
+MAN8= opendkim-genkey.8 opendkim-genzone.8 opendkim-testadsp.8 \
+ opendkim-testkey.8 opendkim-testmsg.8
OPTIONS= \
ARLIB "Asynchronous thread-safe DNS library" On \
@@ -54,6 +52,7 @@ USE_RC_SUBR= milter-opendkim
MAN5+= opendkim.conf.5
MAN8+= opendkim.8
PLIST_SUB+= FILTER=""
+SUB_FILES= pkg-message
WITHOUT_MILTER_CFLAGS= yes
WITHOUT_MILTER_LDFLAGS= yes
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
@@ -103,9 +102,6 @@ LIB_DEPENDS+= unbound:${PORTSDIR}/dns/unbound
PLIST_SUB+= ARLIB="@comment "
.else
.if defined(WITH_ARLIB)
-. if ${CC} == "clang"
-BROKEN= ARLIB option does not compile with clang
-. endif
PLIST_SUB+= ARLIB=""
CONFIGURE_ARGS+= --enable-arlib
MAN3= ar.3
@@ -150,6 +146,11 @@ post-install:
.endif
@${MKDIR} ${PREFIX}/etc/mail
${INSTALL_DATA} ${WRKSRC}/opendkim/opendkim.conf.sample ${PREFIX}/etc/mail/
+.if !defined(WITHOUT_FILTER)
@${CAT} ${PKGMESSAGE}
+.endif
+
+regression-test: build
+ cd ${WRKSRC} ; ${MAKE} check
.include <bsd.port.post.mk>
diff --git a/mail/opendkim/Makefile.features b/mail/opendkim/Makefile.features
index 8a3c2ed96d6e..c3d82ef51570 100644
--- a/mail/opendkim/Makefile.features
+++ b/mail/opendkim/Makefile.features
@@ -18,6 +18,10 @@ CONFIGURE_ARGS+= --enable-allsymbols
.if defined(WITH_ATPS) && !defined(WITHOUT_ATPS)
WITH_XTAGS= yes
CONFIGURE_ARGS+= --enable-atps
+MAN8+= opendkim-atpszone.8
+PLIST_SUB+= ATPS=""
+.else
+PLIST_SUB+= ATPS="@comment "
.endif
.if defined(WITH_CODECOVERAGE) && !defined(WITHOUT_CODECOVERAGE)
@@ -39,6 +43,10 @@ LIB_DEPENDS+= tre:${PORTSDIR}/textproc/libtre
.if defined(WITH_DKIM_REPUTATION) && !defined(WITHOUT_DKIM_REPUTATION)
CONFIGURE_ARGS+= --enable-dkim_reputation
+MAN3+= dkim-rep.3
+PLIST_SUB+= DKIMREP=""
+.else
+PLIST_SUB+= DKIMREP="@comment "
.endif
.if defined(WITH_IDENTITY_HEADER) && !defined(WITHOUT_IDENTITY_HEADER)
@@ -52,6 +60,7 @@ CONFIGURE_ARGS+= --enable-ldap_caching
.if defined(WITH_LUA_GLOBALS) && !defined(WITHOUT_LUA_GLOBALS)
CONFIGURE_ARGS+= --enable-lua_globals
+WITH_LUA= yes
.endif
.if defined(WITH_OVERSIGN) && !defined(WITHOUT_OVERSIGN)
@@ -59,7 +68,6 @@ CONFIGURE_ARGS+= --enable-oversign
.endif
.if defined(WITH_PARSE_TIME) && !defined(WITHOUT_PARSE_TIME)
-BROKEN= The feature ``_FFR_PARSE_TIME'' is incomplete, does not work
CONFIGURE_ARGS+= --enable-parsetime
.endif
@@ -67,12 +75,16 @@ CONFIGURE_ARGS+= --enable-parsetime
CONFIGURE_ARGS+= --enable-postgres_reconnect_hack
.endif
-.if defined(WITH_RATE_LIMIT) && !defined(WITHOUT_RATE_LIMIT)
+.if defined(WITH_RATE_LIMIT) || defined(WITH_RESIGN)
CONFIGURE_ARGS+= --enable-rate_limit
.endif
.if defined(WITH_RBL) && !defined(WITHOUT_RBL)
CONFIGURE_ARGS+= --enable-rbl
+MAN3+= rbl.3
+PLIST_SUB+= RBL=""
+.else
+PLIST_SUB+= RBL="@comment "
.endif
.if defined(WITH_REDIRECT) && !defined(WITHOUT_REDIRECT)
@@ -83,8 +95,17 @@ CONFIGURE_ARGS+= --enable-redirect
CONFIGURE_ARGS+= --enable-replace_rules
.endif
-.if defined(WITH_REPORT_INTERVALS) && !defined(WITHOUT_REPORT_INTERVALS)
-CONFIGURE_ARGS+= --enable-report_intervals
+.if defined(WITH_REPUTATION) && !defined(WITHOUT_REPUTATION)
+CONFIGURE_ARGS+= --enable-reputation
+MAN3+= ut.3
+MAN8+= opendkim-genrates.8 opendkim-modtotals.8
+PLIST_SUB+= REPUTE=""
+.else
+PLIST_SUB+= REPUTE="@comment "
+.endif
+
+.if defined(WITH_REPUTATION_CACHE) && !defined(WITHOUT_REPUTATION_CACHE)
+CONFIGURE_ARGS+= --enable-reputation_cache
.endif
.if defined(WITH_RESIGN) && !defined(WITHOUT_RESIGN)
@@ -105,6 +126,7 @@ CONFIGURE_ARGS+= --enable-sender_macro
.if defined(WITH_STATS) || defined(WITH_STATSEXT)
CONFIGURE_ARGS+= --enable-stats
+MAN1+= opendkim-spam.1
MAN8+= opendkim-stats.8
PLIST_SUB+= STATS=""
.else
@@ -117,6 +139,10 @@ CONFIGURE_ARGS+= --enable-statsext
.if defined(WITH_VBR) && !defined(WITHOUT_VBR)
CONFIGURE_ARGS+= --enable-vbr
+MAN3+= vbr.3
+PLIST_SUB+= VBR=""
+.else
+PLIST_SUB+= VBR="@comment "
.endif
.if defined(WITH_XTAGS) && !defined(WITHOUT_XTAGS)
diff --git a/mail/opendkim/distinfo b/mail/opendkim/distinfo
index 6a30885bae82..ac517313c8f2 100644
--- a/mail/opendkim/distinfo
+++ b/mail/opendkim/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opendkim-2.4.3.tar.gz) = c3ef73c5aa2bf8a6626b822cea08b72c954376ae892d596346973d11003c0906
-SIZE (opendkim-2.4.3.tar.gz) = 1381956
+SHA256 (opendkim-2.5.0.tar.gz) = 5c17a5c82936495b35bc12b32438ebd7b7a624e3389fcac672f7d2ec5bdc8981
+SIZE (opendkim-2.5.0.tar.gz) = 1465356
diff --git a/mail/opendkim/files/patch-libopendkim_tests_t-test75.c b/mail/opendkim/files/patch-libopendkim_tests_t-test75.c
new file mode 100644
index 000000000000..ec5e6c3e583b
--- /dev/null
+++ b/mail/opendkim/files/patch-libopendkim_tests_t-test75.c
@@ -0,0 +1,32 @@
+--- ./libopendkim/tests/t-test75.c.orig 2012-03-01 08:52:30.000000000 +0900
++++ ./libopendkim/tests/t-test75.c 2012-03-01 15:50:21.000000000 +0900
+@@ -52,6 +52,14 @@
+ dkim_query_t qtype = DKIM_QUERY_FILE;
+ unsigned char hdr[MAXHEADER + 1];
+
++#ifdef USE_GNUTLS
++ (void) gnutls_global_init();
++#endif /* USE_GNUTLS */
++
++ /* instantiate the library */
++ lib = dkim_init(NULL, NULL);
++ assert(lib != NULL);
++
+ if (!dkim_libfeature(lib, DKIM_FEATURE_PARSE_TIME))
+ {
+ printf("*** Date: value extraction SKIPPED\n");
+@@ -62,14 +70,6 @@
+ printf("*** Date: value extraction\n");
+ }
+
+-#ifdef USE_GNUTLS
+- (void) gnutls_global_init();
+-#endif /* USE_GNUTLS */
+-
+- /* instantiate the library */
+- lib = dkim_init(NULL, NULL);
+- assert(lib != NULL);
+-
+ #ifdef TEST_KEEP_FILES
+ /* set flags */
+ flags = (DKIM_LIBFLAGS_TMPFILES|DKIM_LIBFLAGS_KEEPFILES);
diff --git a/mail/opendkim/pkg-plist b/mail/opendkim/pkg-plist
index cf5f3d81d458..6f3577c4d17a 100644
--- a/mail/opendkim/pkg-plist
+++ b/mail/opendkim/pkg-plist
@@ -1,24 +1,58 @@
@comment $FreeBSD$
%%LUA%%bin/miltertest
+%%ATPS%%bin/opendkim-atpszone
bin/opendkim-genkey
+%%REPUTE%%bin/opendkim-genrates
bin/opendkim-genzone
+%%REPUTE%%bin/opendkim-modtotals
+%%STATS%%bin/opendkim-spam
%%STATS%%bin/opendkim-stats
bin/opendkim-testadsp
bin/opendkim-testkey
+bin/opendkim-testmsg
etc/mail/opendkim.conf.sample
-%%ARLIB%%include/ar/ar.h
+%%ARLIB%%include/async-resolv.h
+%%DKIMREP%%include/dkim-rep/dkim-rep.h
include/opendkim/dkim.h
+%%RBL%%include/rbl/rbl.h
+%%REPUTE%%include/repute/repute.h
+%%REPUTE%%include/ut/ut.h
+%%VBR%%include/vbr/vbr.h
%%ARLIB%%lib/libar.a
%%ARLIB%%lib/libar.la
%%ARLIB%%lib/libar.so
%%ARLIB%%lib/libar.so.2
+%%DKIMREP%%lib/libdkimrep.a
+%%DKIMREP%%lib/libdkimrep.la
+%%DKIMREP%%lib/libdkimrep.so
+%%DKIMREP%%lib/libdkimrep.so.1
lib/libopendkim.a
lib/libopendkim.la
lib/libopendkim.so
-lib/libopendkim.so.5
+lib/libopendkim.so.6
+%%RBL%%lib/librbl.a
+%%RBL%%lib/librbl.la
+%%RBL%%lib/librbl.so
+%%RBL%%lib/librbl.so.1
+%%REPUTE%%lib/librepute.a
+%%REPUTE%%lib/librepute.la
+%%REPUTE%%lib/librepute.so
+%%REPUTE%%lib/librepute.so.1
+%%REPUTE%%lib/libut.a
+%%REPUTE%%lib/libut.la
+%%REPUTE%%lib/libut.so
+%%REPUTE%%lib/libut.so.1
+%%VBR%%lib/libvbr.a
+%%VBR%%lib/libvbr.la
+%%VBR%%lib/libvbr.so
+%%VBR%%lib/libvbr.so.2
%%ARLIB%%libdata/pkgconfig/ar.pc
+%%DKIMREP%%libdata/pkgconfig/dkim-rep.pc
libdata/pkgconfig/opendkim.pc
+%%RBL%%libdata/pkgconfig/rbl.pc
+%%REPUTE%%libdata/pkgconfig/repute.pc
+%%REPUTE%%libdata/pkgconfig/ut.pc
+%%VBR%%libdata/pkgconfig/vbr.pc
%%FILTER%%sbin/opendkim
@dirrm include/opendkim
-%%ARLIB%%@dirrm include/ar
@dirrmtry etc/mail