aboutsummaryrefslogtreecommitdiff
path: root/mail/opendkim
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-09-21 12:25:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-09-21 12:25:21 +0000
commit638ea47302e4b140fb7909bc6d8ed0e258d04ec4 (patch)
tree6be44fc78bc675f23d833f14aaa98b47de1f2018 /mail/opendkim
parent910a72fd2d4fdcab965cdb098787bae9e2cf9a14 (diff)
downloadports-638ea47302e4b140fb7909bc6d8ed0e258d04ec4.tar.gz
ports-638ea47302e4b140fb7909bc6d8ed0e258d04ec4.zip
Notes
Diffstat (limited to 'mail/opendkim')
-rw-r--r--mail/opendkim/Makefile101
-rw-r--r--mail/opendkim/Makefile.features78
-rw-r--r--mail/opendkim/distinfo3
-rw-r--r--mail/opendkim/files/milter-opendkim.in177
-rw-r--r--mail/opendkim/files/patch-FEATURES12
-rw-r--r--mail/opendkim/files/patch-opendkim__Makefile.in11
-rw-r--r--mail/opendkim/pkg-descr10
-rw-r--r--mail/opendkim/pkg-message23
-rw-r--r--mail/opendkim/pkg-plist116
9 files changed, 531 insertions, 0 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
new file mode 100644
index 000000000000..c19e5ecf1223
--- /dev/null
+++ b/mail/opendkim/Makefile
@@ -0,0 +1,101 @@
+# New ports collection makefile for: opendkim
+# Date created: 2009-08-26
+# Whom: Hirohisa Yamaguchi <umq@ueo.co.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opendkim
+PORTVERSION= 1.0.0
+CATEGORIES= mail security
+MASTER_SITES= SF/opendkim
+
+MAINTAINER= umq@ueo.co.jp
+COMMENT= DKIM milter implimentation
+
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+USE_RC_SUBR= milter-opendkim
+USE_LDCONFIG= yes
+
+MAN_COMPRESSED= no
+MAN3= ar.3
+MAN5= opendkim.conf.5
+MAN8= opendkim-genkey.8 opendkim-testadsp.8 \
+ opendkim-testkey.8 opendkim.8
+PORTDOCS0= FEATURES INSTALL KNOWNBUGS LICENSE LICENSE.Sendmail \
+ README RELEASE_NOTES RELEASE_NOTES.Sendmail
+PORTDOCS= docs/*
+
+.include <bsd.port.pre.mk>
+
+WITHOUT_MILTER_CFLAGS= yes
+WITHOUT_MILTER_LDFLAGS= yes
+.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
+CONFIGURE_ARGS+= --with-milter=${MILTERBASE}
+
+.if ${OSVERSION} < 700000
+WITH_OPENSSL_PORT= yes
+.endif
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+
+.include "${.CURDIR}/Makefile.features"
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if (defined(WITH_POPAUTH) \
+ || defined(WITH_QUERY_CACHE) \
+ || defined(WITH_BODYLENGTH_DB) \
+ || defined(WITH_STATS)) \
+ && !defined(WITH_BDB_BASE)
+#BROKEN= LIBDB_INCDIR nor LIBDB_LIBDIRS cannot be set individually
+CONFIGURE_ARGS+= --with-db
+USE_BDB= 41+
+.endif
+.if defined(WITH_UNBOUND) && !defined(WITHOUT_UNBOUND)
+BROKEN= configure fails since arlib cannot be disabled
+.if defined(WITH_ARLIB)
+IGNORE= libar cannot be used simultaneously with libunbound
+.endif
+CONFIGURE_ARGS+= --with-unbound \
+ --disable-arlib
+LIB_DEPENDS+= unbound:${PORTSDIR}/dns/unbound
+PLIST_SUB+= ARLIB="@comment "
+.else
+.if !defined(WITHOUT_ARLIB)
+PLIST_SUB+= ARLIB=""
+CONFIGURE_ARGS+= --enable-arlib
+.else
+CONFIGURE_ARGS+= --disable-arlib
+PLIST_SUB+= ARLIB="@comment "
+.endif
+.endif
+.if defined(WITH_POPAUTH) && !defined(WITHOUT_POPAUTH)
+CONFIGURE_ARGS+= --enable-popauth
+.endif
+.if defined(WITH_QUERY_CACHE) && !defined(WITHOUT_QUERY_CACHE)
+CONFIGURE_ARGS+= --enable-querycache
+.endif
+
+post-extract:
+.for f in ${PORTDOCS0}
+ @${CP} ${WRKSRC}/${f} ${WRKSRC}/docs/
+.endfor
+
+post-install:
+.if !defined(WITH_DEBUG)
+ @${STRIP_CMD} ${PREFIX}/sbin/opendkim
+.endif
+ @${MKDIR} ${PREFIX}/etc/mail
+ ${INSTALL_DATA} ${WRKSRC}/opendkim/opendkim.conf.sample ${PREFIX}/etc/mail/
+.if !defined(NOPORTDOCS)
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/mail/opendkim/Makefile.features b/mail/opendkim/Makefile.features
new file mode 100644
index 000000000000..f5a98303898b
--- /dev/null
+++ b/mail/opendkim/Makefile.features
@@ -0,0 +1,78 @@
+# Makefile.features
+# Author: Hirohisa Yamaguchi <umq@ueo.co.jp>
+#
+# This file is used to tune build time options.
+# Please refer FEATURES file distributed with the source for details.
+#
+# $FreeBSD$
+#
+
+.if defined(WITH_BODYLENGTH_DB) && !defined(WITHOUT_BODYLENGTH_DB)
+CONFIGURE_ARGS+= --enable-bodylengthdb
+.endif
+
+.if defined(WITH_CAPTURE_UNKNOWN_ERRORS) && !defined(WITHOUT_CAPTURE_UNKNOWN_ERRORS)
+CONFIGURE_ARGS+= --enable-captureerrors
+.endif
+
+.if defined(WITH_COMMAIZE) && !defined(WITHOUT_COMMAIZE)
+CONFIGURE_ARGS+= --enable-commaize
+.endif
+
+.if defined(WITH_DIFFHEADERS) && !defined(WITHOUT_DIFFHEADERS)
+CONFIGURE_ARGS+= --enable-diffheaders
+LIB_DEPENDS+= tre:${PORTSDIR}/textproc/libtre
+.endif
+
+.if defined(WITH_DKIM_REPUTATION) && !defined(WITHOUT_DKIM_REPUTATION)
+CONFIGURE_ARGS+= --enable-dkimreputation
+.endif
+
+.if defined(WITH_DNS_UPGRADE) && !defined(WITHOUT_DNS_UPGRADE)
+CONFIGURE_ARGS+= --enable-dnsupgrade
+.endif
+
+.if defined(WITH_MULTIPLE_SIGNATURES) && !defined(WITHOUT_MULTIPLE_SIGNATURES)
+CONFIGURE_ARGS+= --enable-multiplesigs
+.endif
+
+.if defined(WITH_PARSE_TIME) && !defined(WITHOUT_PARSE_TIME)
+BROKEN= The feature ``_FFR_PARSE_TIME'' is incomplete, does not work
+CONFIGURE_ARGS+= --enable-parsetime
+.endif
+
+.if defined(WITH_REPLACE_RULES) && !defined(WITHOUT_REPLACE_RULES)
+CONFIGURE_ARGS+= -enable-replacerules
+.endif
+
+.if defined(WITH_REPORT_INTERVALS) && !defined(WITHOUT_REPORT_INTERVALS)
+CONFIGURE_ARGS+= --enable-reportintervals
+.endif
+
+.if defined(WITH_SELECT_CANONICALIZATION) && !defined(WITHOUT_SELECT_CANONICALIZATION)
+CONFIGURE_ARGS+= --enable-selectcanon
+.endif
+
+.if defined(WITH_SELECTOR_HEADER) && !defined(WITHOUT_SELECTOR_HEADER)
+CONFIGURE_ARGS+= --enable-selectorheader
+.endif
+
+.if defined(WITH_SENDER_HEADERS) && !defined(WITHOUT_SENDER_HEADERS)
+CONFIGURE_ARGS+= --enable-senderheaders
+.endif
+
+.if defined(WITH_STATS) && !defined(WITHOUT_STATS)
+CONFIGURE_ARGS+= --enable-stats
+MAN8+= opendkim-stats.8
+PLIST_SUB+= STATS=""
+.else
+PLIST_SUB+= STATS="@comment "
+.endif
+
+.if defined(WITH_VBR) && !defined(WITHOUT_VBR)
+CONFIGURE_ARGS+= --enable-vbr
+.endif
+
+.if defined(WITH_ZTAGS) && !defined(WITHOUT_ZTAGS)
+CONFIGURE_ARGS+= --enable-ztags
+.endif
diff --git a/mail/opendkim/distinfo b/mail/opendkim/distinfo
new file mode 100644
index 000000000000..65da617a5052
--- /dev/null
+++ b/mail/opendkim/distinfo
@@ -0,0 +1,3 @@
+MD5 (opendkim-1.0.0.tar.gz) = ecc09da6a40ba55b922d284d43db5468
+SHA256 (opendkim-1.0.0.tar.gz) = 9420aa7b0bd0bcd0122675d412060dc807fcc0cec65028c038f150a43f260aa5
+SIZE (opendkim-1.0.0.tar.gz) = 885016
diff --git a/mail/opendkim/files/milter-opendkim.in b/mail/opendkim/files/milter-opendkim.in
new file mode 100644
index 000000000000..b3df99541f84
--- /dev/null
+++ b/mail/opendkim/files/milter-opendkim.in
@@ -0,0 +1,177 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: milter-opendkim
+# REQUIRE: DAEMON
+# BEFORE: mail
+# KEYWORD: shutdown
+
+# Define these milteropendkim_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/milteropendkim
+#
+# milteropendkim_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable dkim-milter
+# milteropendkim_uid (str): Set username to run milter.
+# milteropendkim_profiles (list): Set to "" by default.
+# Define your profiles here.
+# milteropendkim_cfgfile (str): Configuration file. See opendkim.conf(5)
+#
+# milteropendkim_${profile}_* : Variables per profile.
+# Sockets must be different from each other.
+#
+# all parameters below now can be set in opendkim.conf(5).
+# milteropendkim_socket (str): Path to the milter socket.
+# milteropendkim_domain (str): Domainpart of From: in mails to sign.
+# milteropendkim_key (str): Path to the private key file to sign with.
+# milteropendkim_selector (str): Selector to use when signing
+# milteropendkim_alg (str): Algorithm to use when signing
+# milteropendkim_flags (str): Flags passed to start command.
+
+. %%RC_SUBR%%
+
+name="milteropendkim"
+rcvar=`set_rcvar`
+
+start_precmd="dkim_prepcmd"
+stop_postcmd="dkim_postcmd"
+command="%%PREFIX%%/sbin/opendkim"
+_piddir="/var/run/milteropendkim"
+pidfile="${_piddir}/pid"
+
+load_rc_config $name
+
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+#
+: ${milteropendkim_enable="NO"}
+: ${milteropendkim_uid="mailnull"}
+: ${milteropendkim_profiles=""}
+: ${milteropendkim_cfgfile="%%PREFIX%%/etc/mail/opendkim.conf"}
+
+: ${milteropendkim_socket=""}
+: ${milteropendkim_domain=""}
+: ${milteropendkim_key=""}
+: ${milteropendkim_selector=""}
+: ${milteropendkim_alg=""}
+# Options other than above can be set with $milteropendkim_flags.
+# see dkim-milter documentation for detail.
+
+if [ -n "$2" ]; then
+ profile="$2"
+ if [ "x${milteropendkim_profiles}" != "x" ]; then
+ pidfile="${_piddir}/${profile}.pid"
+ eval milteropendkim_enable="\${milteropendkim_${profile}_enable:-${milteropendkim_enable}}"
+ eval milteropendkim_socket="\${milteropendkim_${profile}_socket:-}"
+ if [ "x${milteropendkim_socket}" = "x" ];then
+ echo "You must define a socket (milteropendkim_${profile}_socket)"
+ exit 1
+ fi
+ eval milteropendkim_cfgfile="\${milteropendkim_${profile}_cfgfile:-${milteropendkim_cfgfile}}"
+ eval milteropendkim_domain="\${milteropendkim_${profile}_domain:-${milteropendkim_domain}}"
+ eval milteropendkim_key="\${milteropendkim_${profile}_key:-${milteropendkim_key}}"
+ eval milteropendkim_selector="\${milteropendkim_${profile}_selector:-${milteropendkim_selector}}"
+ eval milteropendkim_alg="\${milteropendkim_${profile}_alg:-${milteropendkim_alg}}"
+ eval milteropendkim_flags="\${milteropendkim_${profile}_flags:-${milteropendkim_flags}}"
+ if [ -f "${milteropendkim_cfgfile}" ];then
+ milteropendkim_cfgfile="-x ${milteropendkim_cfgfile}"
+ else
+ milteropendkim_cfgfile=""
+ fi
+ if [ "x${milteropendkim_socket}" != "x" ];then
+ _socket_prefix="-p"
+ fi
+ if [ "x${milteropendkim_uid}" != "x" ];then
+ _uid_prefix="-u"
+ fi
+ if [ "x${milteropendkim_domain}" != "x" ];then
+ milteropendkim_domain="-d ${milteropendkim_domain}"
+ fi
+ if [ "x${milteropendkim_key}" != "x" ];then
+ milteropendkim_key="-k ${milteropendkim_key}"
+ fi
+ if [ "x${milteropendkim_selector}" != "x" ];then
+ milteropendkim_selector="-s ${milteropendkim_selector}"
+ fi
+ if [ "x${milteropendkim_alg}" != "x" ];then
+ milteropendkim_alg="-S ${milteropendkim_alg}"
+ fi
+ command_args="-l ${_socket_prefix} ${milteropendkim_socket} ${_uid_prefix} ${milteropendkim_uid} -P ${pidfile} ${milteropendkim_cfgfile} ${milteropendkim_domain} ${milteropendkim_key} ${milteropendkim_selector} ${milteropendkim_alg}"
+ else
+ echo "$0: extra argument ignored"
+ fi
+else
+ if [ "x${milteropendkim_profiles}" != "x" -a "x$1" != "x" ]; then
+ if [ "x$1" != "xrestart" ]; then
+ for profile in ${milteropendkim_profiles}; do
+ echo "===> milteropendkim profile: ${profile}"
+ %%PREFIX%%/etc/rc.d/milter-opendkim $1 ${profile}
+ retcode="$?"
+ if [ "0${retcode}" -ne 0 ]; then
+ failed="${profile} (${retcode}) ${failed:-}"
+ else
+ success="${profile} ${success:-}"
+ fi
+ done
+ exit 0
+ else
+ restart_precmd=""
+ fi
+ else
+ if [ -f "${milteropendkim_cfgfile}" ];then
+ milteropendkim_cfgfile="-x ${milteropendkim_cfgfile}"
+ else
+ milteropendkim_cfgfile=""
+ fi
+ if [ "x${milteropendkim_socket}" != "x" ];then
+ _socket_prefix="-p"
+ fi
+ if [ "x${milteropendkim_uid}" != "x" ];then
+ _uid_prefix="-u"
+ fi
+ if [ "x${milteropendkim_domain}" != "x" ];then
+ milteropendkim_domain="-d ${milteropendkim_domain}"
+ fi
+ if [ "x${milteropendkim_key}" != "x" ];then
+ milteropendkim_key="-k ${milteropendkim_key}"
+ fi
+ if [ "x${milteropendkim_selector}" != "x" ];then
+ milteropendkim_selector="-s ${milteropendkim_selector}"
+ fi
+ if [ "x${milteropendkim_alg}" != "x" ];then
+ milteropendkim_alg="-S ${milteropendkim_alg}"
+ fi
+ command_args="-l ${_socket_prefix} ${milteropendkim_socket} ${_uid_prefix} ${milteropendkim_uid} -P ${pidfile} ${milteropendkim_cfgfile} ${milteropendkim_domain} ${milteropendkim_key} ${milteropendkim_selector} ${milteropendkim_alg}"
+ fi
+fi
+
+dkim_prepcmd ()
+{
+ if [ -S ${milteropendkim_socket##local:} ] ; then
+ rm -f ${milteropendkim_socket##local:}
+ elif [ -S ${milteropendkim_socket##unix:} ] ; then
+ rm -f ${milteropendkim_socket##unix:}
+ fi
+ if [ ! -d ${_piddir} ] ; then
+ mkdir -p ${_piddir}
+ fi
+ if [ -n "${milteropendkim_uid}" ] ; then
+ chown ${milteropendkim_uid} ${_piddir}
+ fi
+}
+
+dkim_postcmd()
+{
+ if [ -S ${milteropendkim_socket##local:} ] ; then
+ rm -f ${milteropendkim_socket##local:}
+ elif [ -S ${milteropendkim_socket##unix:} ] ; then
+ rm -f ${milteropendkim_socket##unix:}
+ fi
+ # just if the directory is empty
+ rmdir ${_piddir} > /dev/null 2>&1
+}
+
+run_rc_command "$1"
diff --git a/mail/opendkim/files/patch-FEATURES b/mail/opendkim/files/patch-FEATURES
new file mode 100644
index 000000000000..165f3585f22e
--- /dev/null
+++ b/mail/opendkim/files/patch-FEATURES
@@ -0,0 +1,12 @@
+--- ./FEATURES.orig 2009-08-04 06:31:48.000000000 +0900
++++ ./FEATURES 2009-08-27 20:35:42.000000000 +0900
+@@ -74,6 +74,9 @@
+ to use when signing based on the contents of an arbitrary
+ header. (opendkim)
+
++senderheaders Optional control over which headers are used by the filter
++ to make the sign vs. verify decision. (opendkim)
++
+ stats Optional generation of statistics about pass/fail sorted
+ by domain and canonicalization. Requires Sleepycat DB.
+ (opendkim, libopendkim)
diff --git a/mail/opendkim/files/patch-opendkim__Makefile.in b/mail/opendkim/files/patch-opendkim__Makefile.in
new file mode 100644
index 000000000000..2723f90aeace
--- /dev/null
+++ b/mail/opendkim/files/patch-opendkim__Makefile.in
@@ -0,0 +1,11 @@
+--- ./opendkim/Makefile.in.orig 2009-08-15 01:44:49.000000000 +0900
++++ ./opendkim/Makefile.in 2009-08-27 20:36:49.000000000 +0900
+@@ -327,7 +327,7 @@
+ AM_LDFLAGS = -pthread
+ sbin_SCRIPTS = opendkim-genkey.sh
+ exampledir = $(datarootdir)/doc/@PACKAGE@
+-example_DATA = opendkim.conf.sample
++example_DATA =
+ @BUILD_FILTER_TRUE@opendkim_SOURCES = opendkim.c opendkim.h opendkim-ar.c opendkim-ar.h opendkim-arf.c opendkim-arf.h opendkim-config.h opendkim-crypto.c opendkim-crypto.h opendkim-db.c opendkim-db.h config.c config.h stats.c stats.h test.c test.h util.c util.h
+ @BUILD_FILTER_TRUE@opendkim_CFLAGS = $(am__append_2) $(am__append_6) \
+ @BUILD_FILTER_TRUE@ $(am__append_7) $(am__append_8) \
diff --git a/mail/opendkim/pkg-descr b/mail/opendkim/pkg-descr
new file mode 100644
index 000000000000..ecb21dd91bf4
--- /dev/null
+++ b/mail/opendkim/pkg-descr
@@ -0,0 +1,10 @@
+OpenDKIM is an open source implementation of the DKIM sender authentication
+system proposed by the E-mail Signing Technology Group (ESTG), now a proposed
+standard of the IETF (RFC4871).
+
+The OpenDKIM package consists of a library that implements the DKIM service
+and a milter-based filter application that can plug in to any milter-aware
+MTA to provide that service to sufficiently recent sendmail MTAs and other
+MTAs that support the milter protocol.
+
+WWW: http://opendkim.org/
diff --git a/mail/opendkim/pkg-message b/mail/opendkim/pkg-message
new file mode 100644
index 000000000000..36f4cab66ac8
--- /dev/null
+++ b/mail/opendkim/pkg-message
@@ -0,0 +1,23 @@
+************************************************************************
+
+In order to run this port, write your opendkim.conf and:
+
+if you use sendmail, add the milter socket `socketspec' in
+/etc/mail/<your_configuration>.mc:
+
+INPUT_MAIL_FILTER(`dkim-filter', `S=_YOUR_SOCKET_SPEC_, F=T, T=R:2m')
+
+or if you use postfix write your milter socket `socketspec' in
+${PREFIX}/etc/mail/main.cf:
+
+smtpd_milters = _YOUR_SOCKET_SPEC_
+
+
+And to run the milter from startup, add milteropendkim_enable="YES" in
+your /etc/rc.conf.
+Extra options can be found in startup script.
+
+Note: milter sockets must be accessible from postfix/smtpd;
+ using inet sockets might be preferred.
+
+************************************************************************
diff --git a/mail/opendkim/pkg-plist b/mail/opendkim/pkg-plist
new file mode 100644
index 000000000000..605ad53591a0
--- /dev/null
+++ b/mail/opendkim/pkg-plist
@@ -0,0 +1,116 @@
+@comment $FreeBSD$
+etc/mail/opendkim.conf.sample
+%%ARLIB%%include/ar/ar.h
+%%ARLIB%%include/ar/manual.h
+include/opendkim/dkim.h
+%%ARLIB%%lib/libar.a
+lib/libopendkim.a
+lib/libopendkim.la
+lib/libopendkim.so
+lib/libopendkim.so.0
+sbin/opendkim
+sbin/opendkim-genkey.sh
+%%STATS%%sbin/opendkim-stats
+sbin/opendkim-testadsp
+sbin/opendkim-testkey
+%%PORTDOCS%%share/doc/opendkim/FEATURES
+%%PORTDOCS%%share/doc/opendkim/INSTALL
+%%PORTDOCS%%share/doc/opendkim/KNOWNBUGS
+%%PORTDOCS%%share/doc/opendkim/LICENSE
+%%PORTDOCS%%share/doc/opendkim/LICENSE.Sendmail
+%%PORTDOCS%%share/doc/opendkim/README
+%%PORTDOCS%%share/doc/opendkim/RELEASE_NOTES
+%%PORTDOCS%%share/doc/opendkim/RELEASE_NOTES.Sendmail
+%%PORTDOCS%%share/doc/opendkim/draft-ietf-dkim-deployment-07.txt
+%%PORTDOCS%%share/doc/opendkim/draft-ietf-dkim-rfc4871-errata-07.txt
+%%PORTDOCS%%share/doc/opendkim/draft-kucherawy-dkim-reporting-04.txt
+%%PORTDOCS%%share/doc/opendkim/draft-shafranovich-feedback-report-07.txt
+%%PORTDOCS%%share/doc/opendkim/rfc4686.txt
+%%PORTDOCS%%share/doc/opendkim/rfc4871.txt
+%%PORTDOCS%%share/doc/opendkim/rfc5016.txt
+%%PORTDOCS%%share/doc/opendkim/rfc5451.txt
+%%PORTDOCS%%share/doc/opendkim/rfc5518.txt
+%%PORTDOCS%%share/doc/opendkim/rfc5585.txt
+%%PORTDOCS%%share/doc/opendkim/rfc5617.txt
+share/opendkim/dkim.html
+share/opendkim/dkim_alg_t.html
+share/opendkim/dkim_body.html
+share/opendkim/dkim_canon_t.html
+share/opendkim/dkim_cbstat.html
+share/opendkim/dkim_chunk.html
+share/opendkim/dkim_close.html
+share/opendkim/dkim_dnssec.html
+share/opendkim/dkim_eoh.html
+share/opendkim/dkim_eom.html
+share/opendkim/dkim_flush_cache.html
+share/opendkim/dkim_free.html
+share/opendkim/dkim_get_user_context.html
+share/opendkim/dkim_getcachestats.html
+share/opendkim/dkim_getdomain.html
+share/opendkim/dkim_geterror.html
+share/opendkim/dkim_getmode.html
+share/opendkim/dkim_getpolicystr.html
+share/opendkim/dkim_getpresult.html
+share/opendkim/dkim_getpresultstr.html
+share/opendkim/dkim_getresultstr.html
+share/opendkim/dkim_getsighdr.html
+share/opendkim/dkim_getsiglist.html
+share/opendkim/dkim_getsignature.html
+share/opendkim/dkim_header.html
+share/opendkim/dkim_init.html
+share/opendkim/dkim_key_syntax.html
+share/opendkim/dkim_lib.html
+share/opendkim/dkim_minbody.html
+share/opendkim/dkim_ohdrs.html
+share/opendkim/dkim_options.html
+share/opendkim/dkim_param_t.html
+share/opendkim/dkim_policy.html
+share/opendkim/dkim_policy_getdnssec.html
+share/opendkim/dkim_policy_getreportinfo.html
+share/opendkim/dkim_policy_syntax.html
+share/opendkim/dkim_policy_t.html
+share/opendkim/dkim_presult.html
+share/opendkim/dkim_pstate.html
+share/opendkim/dkim_query_t.html
+share/opendkim/dkim_set_dns_callback.html
+share/opendkim/dkim_set_final.html
+share/opendkim/dkim_set_key_lookup.html
+share/opendkim/dkim_set_margin.html
+share/opendkim/dkim_set_policy_lookup.html
+share/opendkim/dkim_set_prescreen.html
+share/opendkim/dkim_set_signature_handle.html
+share/opendkim/dkim_set_signature_handle_free.html
+share/opendkim/dkim_set_signature_tagvalues.html
+share/opendkim/dkim_set_signer.html
+share/opendkim/dkim_set_user_context.html
+share/opendkim/dkim_sig_getbh.html
+share/opendkim/dkim_sig_getcanonlen.html
+share/opendkim/dkim_sig_getcontext.html
+share/opendkim/dkim_sig_getdnssec.html
+share/opendkim/dkim_sig_getdomain.html
+share/opendkim/dkim_sig_geterror.html
+share/opendkim/dkim_sig_geterrorstr.html
+share/opendkim/dkim_sig_getflags.html
+share/opendkim/dkim_sig_getkeysize.html
+share/opendkim/dkim_sig_getreportinfo.html
+share/opendkim/dkim_sig_getselector.html
+share/opendkim/dkim_sig_getsignalg.html
+share/opendkim/dkim_sig_getsigntime.html
+share/opendkim/dkim_sig_hdrsigned.html
+share/opendkim/dkim_sig_ignore.html
+share/opendkim/dkim_sig_process.html
+share/opendkim/dkim_sig_syntax.html
+share/opendkim/dkim_sigerror.html
+share/opendkim/dkim_siginfo.html
+share/opendkim/dkim_sigkey_t.html
+share/opendkim/dkim_sign.html
+share/opendkim/dkim_ssl_version.html
+share/opendkim/dkim_stat.html
+share/opendkim/dkim_verify.html
+share/opendkim/index.html
+share/opendkim/overview.html
+share/opendkim/rfc2822_mailbox_split.html
+@dirrm share/opendkim
+@dirrm include/opendkim
+@dirrm include/ar
+@dirrm etc/mail