aboutsummaryrefslogtreecommitdiff
path: root/mail/opendmarc
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-06-28 19:55:52 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-06-28 19:55:52 +0000
commita29ffe66dfce66b9c50bcd92d19a8aa2471f4a6e (patch)
tree62b387bba72441a234a040a195d9277c6d23897a /mail/opendmarc
parent166e60b91fb9becaa0f70938acd767e9bfdd74f5 (diff)
downloadports-a29ffe66dfce66b9c50bcd92d19a8aa2471f4a6e.tar.gz
ports-a29ffe66dfce66b9c50bcd92d19a8aa2471f4a6e.zip
Notes
Diffstat (limited to 'mail/opendmarc')
-rw-r--r--mail/opendmarc/Makefile37
-rw-r--r--mail/opendmarc/distinfo2
-rw-r--r--mail/opendmarc/files/opendmarc.in34
-rw-r--r--mail/opendmarc/pkg-descr14
-rw-r--r--mail/opendmarc/pkg-plist15
5 files changed, 102 insertions, 0 deletions
diff --git a/mail/opendmarc/Makefile b/mail/opendmarc/Makefile
new file mode 100644
index 000000000000..18d83410cd0d
--- /dev/null
+++ b/mail/opendmarc/Makefile
@@ -0,0 +1,37 @@
+# Created by: Jaap Akkerhuis <jaap@NLnetLabs.nl>
+# $FreeBSD$
+
+PORTNAME= opendmarc
+PORTVERSION= 1.1.3
+CATEGORIES= mail security
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME} \
+ ${PORTNAME}/Previous%20Releases
+
+MAINTAINER= jaap@NLnetLabs.nl
+COMMENT= DMARC library an milter implementation
+
+LICENSE= BSD SENDMAIL
+LICENSE_COMB= multi
+
+LICENSE_FILE_SENDMAIL= ${WRKSRC}/LICENSE.Sendmail
+LICENSE_GROUPS_SENDMAIL= FSF OSI
+LICENSE_NAME_SENDMAIL= Sendmail Open Source License
+LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USE_RC_SUBR= opendmarc
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+PORTDOCS= *
+MAN5= opendmarc.conf.5
+MAN8= opendmarc-check.8 opendmarc-expire.8 opendmarc-import.8 \
+ opendmarc-params.8 opendmarc-reports.8 opendmarc.8
+
+post-install:
+ @${MKDIR} ${PREFIX}/etc/mail
+ ${INSTALL_DATA} \
+ ${WRKSRC}/opendmarc/opendmarc.conf.sample ${PREFIX}/etc/mail
+
+.include <bsd.port.mk>
diff --git a/mail/opendmarc/distinfo b/mail/opendmarc/distinfo
new file mode 100644
index 000000000000..99cfb4c124d1
--- /dev/null
+++ b/mail/opendmarc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (opendmarc-1.1.3.tar.gz) = 4f9511ebd8cefb6e5a4d836f6285a1b6e4d682daec79fdba9fc7925b5f4fcfca
+SIZE (opendmarc-1.1.3.tar.gz) = 586574
diff --git a/mail/opendmarc/files/opendmarc.in b/mail/opendmarc/files/opendmarc.in
new file mode 100644
index 000000000000..e03cfe37bd97
--- /dev/null
+++ b/mail/opendmarc/files/opendmarc.in
@@ -0,0 +1,34 @@
+#!/bin/sh
+# $FreeBSD$
+
+# PROVIDE: opendmarc
+# REQUIRE: LOGIN
+# BEFORE: mail
+# KEYWORD: opendmarc
+
+# Define these opendmarc_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/opendmarc
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+#
+
+. /etc/rc.subr
+
+name="opendmarc"
+rcvar=opendmarc_enable
+
+command="%%PREFIX%%/sbin/opendmarc"
+
+load_rc_config $name
+
+opendmarc_enable=${opendmarc_enable-"NO"}
+opendmarc_runas=${opendmarc_runas-"mailnull:mailnull"}
+opendmarc_pidfile=${opendmarc_pidfile-"/var/run/opendmarc.pid"}
+opendmarc_socketspec=${opendmarc_socketspec-"inet:8893@localhost"}
+opendmarc_cfgfile=${opendmarc_cfgfile-"%%PREFIX%%/etc/mail/opendmarc.conf"}
+opendmarc_flags=${opendmarc_flags-"-l -P $opendmarc_pidfile \
+ -c $opendmarc_cfgfile -p $opendmarc_socketspec -u $opendmarc_runas"}
+
+run_rc_command "$1"
diff --git a/mail/opendmarc/pkg-descr b/mail/opendmarc/pkg-descr
new file mode 100644
index 000000000000..f3208bd1ebe9
--- /dev/null
+++ b/mail/opendmarc/pkg-descr
@@ -0,0 +1,14 @@
+OpenDMARC is an open source implementation of Domain-based Message
+Authentication, Reporting & Conformance, or DMARC. It builds on the
+successes of technologies such as DomainKeys Identified Mail (DKIM)
+and the Sender Policy Framework (SPF) to create an infrastructure
+that enforces policy on domain names that are visible to end users,
+and creates a feedback framework for identifying and tracking
+fraudulent use of domain names in email.
+
+It includes a library for handling DMARC record parsing,
+a database schema and tools for aggregating and processing transaction
+history to produce DMARC reports, and a filter that ties it all together
+with an MTA using the milter protocol.
+
+WWW: http://www.trusteddomain.org/opendmarc.html
diff --git a/mail/opendmarc/pkg-plist b/mail/opendmarc/pkg-plist
new file mode 100644
index 000000000000..c09f496de027
--- /dev/null
+++ b/mail/opendmarc/pkg-plist
@@ -0,0 +1,15 @@
+etc/mail/opendmarc.conf.sample
+include/opendmarc/dmarc.h
+lib/libopendmarc.a
+lib/libopendmarc.la
+lib/libopendmarc.so.1
+lib/libopendmarc.so
+sbin/opendmarc
+sbin/opendmarc-check
+sbin/opendmarc-expire
+sbin/opendmarc-import
+sbin/opendmarc-importstats
+sbin/opendmarc-params
+sbin/opendmarc-reports
+@dirrm include/opendmarc
+@dirrmtry etc/mail