aboutsummaryrefslogtreecommitdiff
path: root/mail/opensmtpd-extras
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-04-16 16:49:21 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-04-16 16:49:21 +0000
commit24ea943106d3111a054d3475f3c6ec410461c037 (patch)
treec3f1da6a645db1459b206f63f511b29643afc195 /mail/opensmtpd-extras
parentf8eb8a9827942222faddbb7d15a7af9c41d0b328 (diff)
Notes
Diffstat (limited to 'mail/opensmtpd-extras')
-rw-r--r--mail/opensmtpd-extras/Makefile50
1 files changed, 20 insertions, 30 deletions
diff --git a/mail/opensmtpd-extras/Makefile b/mail/opensmtpd-extras/Makefile
index 4537b0ab9f04..27f3aada29f1 100644
--- a/mail/opensmtpd-extras/Makefile
+++ b/mail/opensmtpd-extras/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opensmtpd-extras
PORTVERSION= 201602042118
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES+= mail
MASTER_SITES= http://www.opensmtpd.org/archives/
@@ -22,15 +22,17 @@ GNU_CONFIGURE= yes
.if empty(SLAVE_PORT)
OPTIONS_GROUP= FILTER TABLE
-OPTIONS_GROUP_FILTER= SPAMASSASSIN
+OPTIONS_GROUP_FILTER= DNSBL PAUSE REGEX SPAMASSASSIN
OPTIONS_GROUP_TABLE= LDAP MYSQL PASSWD PGSQL PYTHON REDIS SMAP SQLITE
OPTIONS_DEFAULT= ${OPTIONS_GROUP_FILTER} ${OPTIONS_GROUP_TABLE}
# Filters
+DNSBL_DESC= Check messages against DNSBLs
+PAUSE_DESC= Pause incoming messages to reduce spam
SPAMASSASSIN_DESC= Check messages with SpamAssassin
# Tables
-PASSWD_DESC= passwd(5) table support
-SMAP_DESC= Socketmap protocol support
+PASSWD_DESC= passwd(5) table support
+SMAP_DESC= Socketmap protocol support
OPTIONS_SUB= yes
@@ -42,39 +44,27 @@ NO_ARCH= yes
#
# Filters
#
-
-SPAMASSASSIN_BUILD_DEPENDS= ${INSTALL_DIR}/filter-spamassassin:mail/opensmtpd-extras-filter-spamassassin
-SPAMASSASSIN_RUN_DEPENDS= ${SPAMASSASSIN_BUILD_DEPENDS}
+DNSBL_RUN_DEPENDS= ${INSTALL_DIR}/filter-dnsbl:mail/opensmtpd-extras-filter-dnsbl
+PAUSE_RUN_DEPENDS= ${INSTALL_DIR}/filter-pause:mail/opensmtpd-extras-filter-pause
+REGEX_RUN_DEPENDS= ${INSTALL_DIR}/filter-regex:mail/opensmtpd-extras-filter-regex
+SPAMASSASSIN_RUN_DEPENDS= ${INSTALL_DIR}/filter-spamassassin:mail/opensmtpd-extras-filter-spamassassin
#
# Tables
#
-
-MYSQL_BUILD_DEPENDS= ${INSTALL_DIR}/table-mysql:mail/opensmtpd-extras-table-mysql
-MYSQL_RUN_DEPENDS= ${MYSQL_BUILD_DEPENDS}
-
-PASSWD_BUILD_DEPENDS= ${INSTALL_DIR}/table-passwd:mail/opensmtpd-extras-table-passwd
-PASSWD_RUN_DEPENDS= ${PASSWD_BUILD_DEPENDS}
-
-PGSQL_BUILD_DEPENDS= ${INSTALL_DIR}/table-postgres:mail/opensmtpd-extras-table-postgresql
-PGSQL_RUN_DEPENDS= ${PGSQL_BUILD_DEPENDS}
-
-PYTHON_BUILD_DEPENDS= ${INSTALL_DIR}/table-python:mail/opensmtpd-extras-table-python
-PYTHON_RUN_DEPENDS= ${PYTHON_BUILD_DEPENDS}
-
-REDIS_BUILD_DEPENDS= ${INSTALL_DIR}/table-redis:mail/opensmtpd-extras-table-redis
-REDIS_RUN_DEPENDS= ${REDIS_BUILD_DEPENDS}
-
-SMAP_BUILD_DEPENDS= ${INSTALL_DIR}/table-socketmap:mail/opensmtpd-extras-table-socketmap
-SMAP_RUN_DEPENDS= ${SMAP_BUILD_DEPENDS}
-
-SQLITE_BUILD_DEPENDS= ${INSTALL_DIR}/table-sqlite:mail/opensmtpd-extras-table-sqlite
-SQLITE_RUN_DEPENDS= ${SQLITE_BUILD_DEPENDS}
+MYSQL_RUN_DEPENDS= ${INSTALL_DIR}/table-mysql:mail/opensmtpd-extras-table-mysql
+PASSWD_RUN_DEPENDS= ${INSTALL_DIR}/table-passwd:mail/opensmtpd-extras-table-passwd
+PGSQL_RUN_DEPENDS= ${INSTALL_DIR}/table-postgres:mail/opensmtpd-extras-table-postgresql
+PYTHON_RUN_DEPENDS= ${INSTALL_DIR}/table-python:mail/opensmtpd-extras-table-python
+REDIS_RUN_DEPENDS= ${INSTALL_DIR}/table-redis:mail/opensmtpd-extras-table-redis
+SMAP_RUN_DEPENDS= ${INSTALL_DIR}/table-socketmap:mail/opensmtpd-extras-table-socketmap
+SQLITE_RUN_DEPENDS= ${INSTALL_DIR}/table-sqlite:mail/opensmtpd-extras-table-sqlite
.else
# Only install this for the opensmtpd-extras master port
-post-install:
- @${RM} ${STAGEDIR}${MAN3PREFIX}/man/man3/filter_api.3
+pre-patch:
+ @${REINPLACE_CMD} -e '/man_MANS.*filter_api.3/s/^/#/' \
+ ${WRKSRC}/extras/wip/filters/Makefile.am
.endif